summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-11-20 14:00:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-11-20 14:00:26 +0000
commit4bc466dcebc8e086190befbaaf617c74b62121aa (patch)
treec150aec192d00ef7775f1e802cae81832ce646b3 /net-libs/liboauth
parentVersion bump; rename usb USE flag in libusb, add udev USE flag; simplify ebui... (diff)
downloadgentoo-2-4bc466dcebc8e086190befbaaf617c74b62121aa.tar.gz
gentoo-2-4bc466dcebc8e086190befbaaf617c74b62121aa.tar.bz2
gentoo-2-4bc466dcebc8e086190befbaaf617c74b62121aa.zip
Version bump; use EAPI=4 and simplify ebuild.
(Portage version: 2.2.0_alpha76/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/liboauth')
-rw-r--r--net-libs/liboauth/ChangeLog7
-rw-r--r--net-libs/liboauth/liboauth-0.9.5.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-libs/liboauth/ChangeLog b/net-libs/liboauth/ChangeLog
index 113ea2061ac1..e4bd32b7c209 100644
--- a/net-libs/liboauth/ChangeLog
+++ b/net-libs/liboauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/liboauth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.9 2011/09/24 15:10:42 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.10 2011/11/20 14:00:26 flameeyes Exp $
+
+*liboauth-0.9.5 (20 Nov 2011)
+
+ 20 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> +liboauth-0.9.5.ebuild:
+ Version bump; use EAPI=4 and simplify ebuild.
24 Sep 2011; Fabian Groffen <grobian@gentoo.org> liboauth-0.9.4.ebuild:
Fixed for Prefix (EAPI=3) and marked ~x64-macos
diff --git a/net-libs/liboauth/liboauth-0.9.5.ebuild b/net-libs/liboauth/liboauth-0.9.5.ebuild
new file mode 100644
index 000000000000..74b7ed2660f5
--- /dev/null
+++ b/net-libs/liboauth/liboauth-0.9.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-0.9.5.ebuild,v 1.1 2011/11/20 14:00:26 flameeyes Exp $
+
+EAPI=4
+
+DESCRIPTION="C library implementing the OAuth secure authentication protocol"
+HOMEPAGE="http://liboauth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ http://liboauth.sourceforge.net/pool/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="curl doc bindist +nss"
+
+REQUIRED_USE="bindist? ( nss )"
+
+CDEPEND="
+ nss? ( dev-libs/nss
+ curl? ( || ( net-misc/curl[ssl,nss,-gnutls] net-misc/curl[-ssl] ) )
+ )
+
+ !nss? ( dev-libs/openssl
+ curl? ( || ( net-misc/curl[ssl,-nss,-gnutls] net-misc/curl[-ssl] ) )
+ )
+
+ net-misc/curl
+"
+
+RDEPEND="${CDEPEND}"
+
+DEPEND="${CDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ media-fonts/freefont-ttf
+ )
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf=
+
+ if use nss || use bindist; then
+ myconf="${myconf} --enable-nss"
+ else
+ myconf="${myconf} --disable-nss"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-static \
+ $(use_enable !curl curl) \
+ $(use_enable curl libcurl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ # make sure fonts are found
+ export DOTFONTPATH="${EPREFIX}"/usr/share/fonts/freefont-ttf
+ emake dox
+ fi
+}
+
+src_test() {
+ # explicitly allow parallel test build
+ emake check
+}
+
+DOCS=( AUTHORS ChangeLog LICENSE.OpenSSL NEWS README )
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+}