summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-26 00:28:58 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-26 00:28:58 +0000
commita153b80781f2dadb657dae2051302a0d351576f4 (patch)
tree53fc2015abbad4dd03db2bb7b389279cc7a0cdc4 /net-libs/libkpeople
parentRemove old. (diff)
downloadgentoo-2-a153b80781f2dadb657dae2051302a0d351576f4.tar.gz
gentoo-2-a153b80781f2dadb657dae2051302a0d351576f4.tar.bz2
gentoo-2-a153b80781f2dadb657dae2051302a0d351576f4.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-libs/libkpeople')
-rw-r--r--net-libs/libkpeople/ChangeLog7
-rw-r--r--net-libs/libkpeople/libkpeople-0.2.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-libs/libkpeople/ChangeLog b/net-libs/libkpeople/ChangeLog
index d4478c5ac784..83f5006fcf2c 100644
--- a/net-libs/libkpeople/ChangeLog
+++ b/net-libs/libkpeople/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libkpeople
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/ChangeLog,v 1.5 2014/03/09 16:45:19 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/ChangeLog,v 1.6 2014/04/26 00:28:58 johu Exp $
+
+*libkpeople-0.2.2 (26 Apr 2014)
+
+ 26 Apr 2014; Johannes Huber <johu@gentoo.org> +libkpeople-0.2.2.ebuild:
+ Version bump.
09 Mar 2014; Johannes Huber <johu@gentoo.org> libkpeople-0.2.1.ebuild:
Fix DEPEND by upstream changes.
diff --git a/net-libs/libkpeople/libkpeople-0.2.2.ebuild b/net-libs/libkpeople/libkpeople-0.2.2.ebuild
new file mode 100644
index 000000000000..81672ccc74d0
--- /dev/null
+++ b/net-libs/libkpeople/libkpeople-0.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/libkpeople-0.2.2.ebuild,v 1.1 2014/04/26 00:28:58 johu Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+KDE_LINGUAS="bs cs da de fi fr hu lt nl pt pt_BR ro ru sk sl sv uk"
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://projects.kde.org/projects/playground/network/libkpeople"
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+IUSE="debug examples test"
+
+RDEPEND="
+ $(add_kdebase_dep kdepimlibs)
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with examples)
+ )
+
+ kde4-base_src_configure
+}