summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-03-28 04:37:13 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-03-28 04:37:13 +0000
commitbe9da052f94fec1a3e7d45a11bfbd04af1e5316b (patch)
treec89474186fd53656db03b8323fd4aa9678f8046c /net-libs/libasyncns
parentFix deps more (diff)
downloadgentoo-2-be9da052f94fec1a3e7d45a11bfbd04af1e5316b.tar.gz
gentoo-2-be9da052f94fec1a3e7d45a11bfbd04af1e5316b.tar.bz2
gentoo-2-be9da052f94fec1a3e7d45a11bfbd04af1e5316b.zip
Fix libdir in pkg-config file. Prevents bogus libtool warnings while building clients of this library.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libasyncns')
-rw-r--r--net-libs/libasyncns/ChangeLog11
-rw-r--r--net-libs/libasyncns/files/libasyncns-0.8-libdir.patch10
-rw-r--r--net-libs/libasyncns/libasyncns-0.8-r1.ebuild54
-rw-r--r--net-libs/libasyncns/libasyncns-0.8.ebuild6
4 files changed, 76 insertions, 5 deletions
diff --git a/net-libs/libasyncns/ChangeLog b/net-libs/libasyncns/ChangeLog
index 1c7f1dd581ef..51772436cb9c 100644
--- a/net-libs/libasyncns/ChangeLog
+++ b/net-libs/libasyncns/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libasyncns
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.21 2010/08/10 00:25:05 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.22 2011/03/28 04:37:12 ford_prefect Exp $
+
+*libasyncns-0.8-r1 (28 Mar 2011)
+
+ 28 Mar 2011; Arun Raghavan <ford_prefect@gentoo.org> libasyncns-0.8.ebuild,
+ +libasyncns-0.8-r1.ebuild, +files/libasyncns-0.8-libdir.patch:
+ Fix libdir in pkg-config file. Prevents bogus libtool warnings while building
+ clients of this library.
10 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-libasyncns-0.3.ebuild, -libasyncns-0.4.ebuild:
diff --git a/net-libs/libasyncns/files/libasyncns-0.8-libdir.patch b/net-libs/libasyncns/files/libasyncns-0.8-libdir.patch
new file mode 100644
index 000000000000..44deca5dca2c
--- /dev/null
+++ b/net-libs/libasyncns/files/libasyncns-0.8-libdir.patch
@@ -0,0 +1,10 @@
+--- libasyncns-0.8/libasyncns.pc.in.orig 2011-03-27 03:45:59.804339219 +0100
++++ libasyncns-0.8/libasyncns.pc.in 2011-03-27 03:46:12.368119660 +0100
+@@ -1,6 +1,6 @@
+ prefix=@prefix@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
++libdir=@libdir@
+ includedir=${prefix}/include
+
+ Name: libasyncns
diff --git a/net-libs/libasyncns/libasyncns-0.8-r1.ebuild b/net-libs/libasyncns/libasyncns-0.8-r1.ebuild
new file mode 100644
index 000000000000..99d80e57866e
--- /dev/null
+++ b/net-libs/libasyncns/libasyncns-0.8-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/libasyncns-0.8-r1.ebuild,v 1.1 2011/03/28 04:37:13 ford_prefect Exp $
+
+EAPI=3
+inherit eutils libtool flag-o-matic
+
+DESCRIPTION="C library for executing name service queries asynchronously."
+HOMEPAGE="http://0pointer.de/lennart/projects/libasyncns/"
+SRC_URI="http://0pointer.de/lennart/projects/libasyncns/${P}.tar.gz"
+
+SLOT="0"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+
+IUSE="doc debug"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # fix libdir in pkgconfig file
+ epatch "${FILESDIR}/${P}-libdir.patch"
+ elibtoolize
+}
+
+src_configure() {
+ # libasyncns uses assert()
+ use debug || append-flags -DNDEBUG
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-dependency-tracking \
+ --disable-lynx
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ doxygen doxygen/doxygen.conf || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc; then
+ docinto apidocs
+ dohtml html/*
+ fi
+}
diff --git a/net-libs/libasyncns/libasyncns-0.8.ebuild b/net-libs/libasyncns/libasyncns-0.8.ebuild
index 7eb13dd78101..866d51f0411d 100644
--- a/net-libs/libasyncns/libasyncns-0.8.ebuild
+++ b/net-libs/libasyncns/libasyncns-0.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/libasyncns-0.8.ebuild,v 1.1 2010/06/01 20:43:06 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/libasyncns-0.8.ebuild,v 1.2 2011/03/28 04:37:12 ford_prefect Exp $
EAPI=3
-inherit libtool flag-o-matic
+inherit eutils libtool flag-o-matic
DESCRIPTION="C library for executing name service queries asynchronously."
HOMEPAGE="http://0pointer.de/lennart/projects/libasyncns/"