summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-21 10:05:49 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-21 10:05:49 +0000
commit2e6d1cf7232523a6fe33faf040f27f3307d21a05 (patch)
tree2b898d34c07cc3b8cb122bce68ef4f4729202ba1 /net-libs/http-parser
parentBugfix release (diff)
downloadgentoo-2-2e6d1cf7232523a6fe33faf040f27f3307d21a05.tar.gz
gentoo-2-2e6d1cf7232523a6fe33faf040f27f3307d21a05.tar.bz2
gentoo-2-2e6d1cf7232523a6fe33faf040f27f3307d21a05.zip
add static-libs USE flag
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/ChangeLog5
-rw-r--r--net-libs/http-parser/http-parser-2.3.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/net-libs/http-parser/ChangeLog b/net-libs/http-parser/ChangeLog
index a7750b00e0b8..85c2bfd2d85b 100644
--- a/net-libs/http-parser/ChangeLog
+++ b/net-libs/http-parser/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/http-parser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.4 2014/06/21 09:54:24 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.5 2014/06/21 10:05:49 hasufell Exp $
+
+ 21 Jun 2014; Julian Ospald <hasufell@gentoo.org> http-parser-2.3.ebuild:
+ add static-libs USE flag
*http-parser-2.3 (21 Jun 2014)
diff --git a/net-libs/http-parser/http-parser-2.3.ebuild b/net-libs/http-parser/http-parser-2.3.ebuild
index 0dbb1f62e0ac..a013929ffb11 100644
--- a/net-libs/http-parser/http-parser-2.3.ebuild
+++ b/net-libs/http-parser/http-parser-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/http-parser-2.3.ebuild,v 1.1 2014/06/21 09:54:24 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/http-parser-2.3.ebuild,v 1.2 2014/06/21 10:05:49 hasufell Exp $
EAPI=5
@@ -16,22 +16,24 @@ SRC_URI="https://github.com/joyent/http-parser/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="MIT"
SLOT="0/${SONAMEVER}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="static-libs"
src_prepare() {
- tc-export CC
+ tc-export CC AR
epatch "${FILESDIR}"/${P}-flags.patch
multilib_copy_sources
}
multilib_src_compile() {
emake library
+ use static-libs && emake package
}
multilib_src_install() {
doheader http_parser.h
dolib.so ${SONAME}
dosym ${SONAME} /usr/$(get_libdir)/libhttp_parser.so
+ use static-libs && dolib.a libhttp_parser.a
}
multilib_src_install_all() {