summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:41:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:41:32 +0000
commitb9bf0571be2a003eebe989df91c6ce7bae7711cd (patch)
tree36b7560a0106f3293851258d375e5e3486f8399c /net-libs/glib-networking
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-b9bf0571be2a003eebe989df91c6ce7bae7711cd.tar.gz
gentoo-2-b9bf0571be2a003eebe989df91c6ce7bae7711cd.tar.bz2
gentoo-2-b9bf0571be2a003eebe989df91c6ce7bae7711cd.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/ChangeLog9
-rw-r--r--net-libs/glib-networking/files/glib-networking-2.40.1-unittests.patch45
-rw-r--r--net-libs/glib-networking/glib-networking-2.40.1.ebuild57
3 files changed, 110 insertions, 1 deletions
diff --git a/net-libs/glib-networking/ChangeLog b/net-libs/glib-networking/ChangeLog
index 83f179bfa8a1..36260159ca2c 100644
--- a/net-libs/glib-networking/ChangeLog
+++ b/net-libs/glib-networking/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/glib-networking
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/ChangeLog,v 1.80 2014/04/27 08:15:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/ChangeLog,v 1.81 2014/04/27 17:41:32 eva Exp $
+
+*glib-networking-2.40.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +glib-networking-2.40.1.ebuild,
+ +files/glib-networking-2.40.1-unittests.patch:
+ Version bump for Gnome 3.12.
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -glib-networking-2.32.3.ebuild,
-glib-networking-2.34.2.ebuild, -glib-networking-2.36.2.ebuild:
diff --git a/net-libs/glib-networking/files/glib-networking-2.40.1-unittests.patch b/net-libs/glib-networking/files/glib-networking-2.40.1-unittests.patch
new file mode 100644
index 000000000000..4301b84620b7
--- /dev/null
+++ b/net-libs/glib-networking/files/glib-networking-2.40.1-unittests.patch
@@ -0,0 +1,45 @@
+From 8867e6a0b3b84b41b5a61c5194fa1300c5c39d8c Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 25 Apr 2014 22:59:01 +0200
+Subject: [PATCH] test connection is not PKCS#11 related
+
+Avoids silly test failure:
+
+CCLD connection
+/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../lib64/Scrt1.o: In
+function `_start':
+(.text+0x20): undefined reference to `main'
+collect2: error: ld returned 1 exit status
+Makefile:897: recipe for target 'connection' failed
+make[4]: *** [connection] Error 1
+---
+ tls/tests/Makefile.am | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tls/tests/Makefile.am b/tls/tests/Makefile.am
+index 6287b9c..009b388 100644
+--- a/tls/tests/Makefile.am
++++ b/tls/tests/Makefile.am
+@@ -15,6 +15,9 @@ test_programs = \
+ connection \
+ $(NULL)
+
++connection_SOURCES = connection.c \
++ mock-interaction.c mock-interaction.h
++
+ if HAVE_PKCS11
+
+ test_programs += \
+@@ -33,9 +36,6 @@ pkcs11_slot_SOURCES = pkcs11-slot.c \
+ mock-pkcs11.c mock-pkcs11.h \
+ mock-interaction.c mock-interaction.h
+
+-connection_SOURCES = connection.c \
+- mock-interaction.c mock-interaction.h
+-
+ endif
+
+ testfiles_data = \
+--
+1.9.0
+
diff --git a/net-libs/glib-networking/glib-networking-2.40.1.ebuild b/net-libs/glib-networking/glib-networking-2.40.1.ebuild
new file mode 100644
index 000000000000..66c41e6bf424
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.40.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/glib-networking-2.40.1.ebuild,v 1.1 2014/04/27 17:41:32 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="http://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="+gnome +libproxy smartcard +ssl test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.39.1:2
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ libproxy? ( >=net-libs/libproxy-0.4.6-r3:= )
+ smartcard? (
+ >=app-crypt/p11-kit-0.8
+ >=net-libs/gnutls-2.12.8:=[pkcs11] )
+ ssl? (
+ app-misc/ca-certificates
+ >=net-libs/gnutls-2.12.8:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( sys-apps/dbus[X] )
+"
+# eautoreconf needs >=sys-devel/autoconf-2.65:2.5
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-unittests.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(use_with gnome gnome-proxy) \
+ $(use_with libproxy) \
+ $(use_with smartcard pkcs11) \
+ $(use_with ssl gnutls)
+}
+
+src_test() {
+ Xemake check
+}