summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-23 22:36:54 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-23 22:36:54 +0000
commitd38d7c848c9382f7b50645ed423a9ed750df5425 (patch)
treee88d62600678964a6a069bf2103b5e2169da5ef8 /net-irc
parentRemove <herd>no-herd</herd>. (diff)
downloadgentoo-2-d38d7c848c9382f7b50645ed423a9ed750df5425.tar.gz
gentoo-2-d38d7c848c9382f7b50645ed423a9ed750df5425.tar.bz2
gentoo-2-d38d7c848c9382f7b50645ed423a9ed750df5425.zip
version bump
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.202.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 2f1a64557906..0d75211608e8 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.51 2011/09/14 08:32:02 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.52 2011/09/23 22:36:54 wired Exp $
+
+*znc-0.202 (23 Sep 2011)
+
+ 23 Sep 2011; Alex Alexander <wired@gentoo.org> +znc-0.202.ebuild:
+ version bump
*znc-9999 (14 Sep 2011)
diff --git a/net-irc/znc/znc-0.202.ebuild b/net-irc/znc/znc-0.202.ebuild
new file mode 100644
index 000000000000..a1e32fe197b2
--- /dev/null
+++ b/net-irc/znc/znc-0.202.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.202.ebuild,v 1.1 2011/09/23 22:36:54 wired Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="python? 3"
+inherit base python
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="http://znc.in/releases/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ares debug extras ipv6 perl python ssl sasl tcl"
+
+RDEPEND="
+ ares? ( >=net-dns/c-ares-1.5 )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="
+ dev-util/pkgconfig
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 3
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use python && echo "--enable-python=python-$(python_get_version)") \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README.md || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}