summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-16 07:09:14 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-16 07:09:14 +0000
commit42b330822a1ca151a86b23aced18176659974777 (patch)
tree50a911cb850aa54411e20bb92d2229ada66ec6c6 /net-irc
parentFix HOMEPAGE. (diff)
downloadgentoo-2-42b330822a1ca151a86b23aced18176659974777.tar.gz
gentoo-2-42b330822a1ca151a86b23aced18176659974777.tar.bz2
gentoo-2-42b330822a1ca151a86b23aced18176659974777.zip
Version bump. Fix SRC_URI.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/sic/ChangeLog7
-rw-r--r--net-irc/sic/sic-1.0.ebuild4
-rw-r--r--net-irc/sic/sic-1.1.ebuild33
3 files changed, 41 insertions, 3 deletions
diff --git a/net-irc/sic/ChangeLog b/net-irc/sic/ChangeLog
index e5d920c48770..8bf8c357de67 100644
--- a/net-irc/sic/ChangeLog
+++ b/net-irc/sic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/sic
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/ChangeLog,v 1.6 2012/02/16 07:03:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/ChangeLog,v 1.7 2012/02/16 07:09:14 jer Exp $
+
+*sic-1.1 (16 Feb 2012)
+
+ 16 Feb 2012; Jeroen Roovers <jer@gentoo.org> sic-1.0.ebuild, +sic-1.1.ebuild:
+ Version bump. Fix SRC_URI.
16 Feb 2012; Jeroen Roovers <jer@gentoo.org> sic-1.0.ebuild:
Fix HOMEPAGE.
diff --git a/net-irc/sic/sic-1.0.ebuild b/net-irc/sic/sic-1.0.ebuild
index 7038404f5844..150b33681554 100644
--- a/net-irc/sic/sic-1.0.ebuild
+++ b/net-irc/sic/sic-1.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/sic-1.0.ebuild,v 1.3 2012/02/16 07:03:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/sic-1.0.ebuild,v 1.4 2012/02/16 07:09:14 jer Exp $
inherit toolchain-funcs
DESCRIPTION="An extremly simple IRC client"
HOMEPAGE="http://tools.suckless.org/sic"
-SRC_URI="http://code.suckless.org/dl/tools/${P}.tar.gz"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
diff --git a/net-irc/sic/sic-1.1.ebuild b/net-irc/sic/sic-1.1.ebuild
new file mode 100644
index 000000000000..fab51494cf2a
--- /dev/null
+++ b/net-irc/sic/sic-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/sic-1.1.ebuild,v 1.1 2012/02/16 07:09:14 jer Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="http://tools.suckless.org/sic"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e "s/-s //g" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}