summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-17 11:58:54 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-17 11:58:54 +0000
commit3f267af169f284bb318ca11976d7ee03428694ff (patch)
tree56a4be7f976d8b6a3e84c1b9897cd2da30740011 /net-irc
parentFixed repoman warnings (Manifest recommit) (diff)
downloadgentoo-2-3f267af169f284bb318ca11976d7ee03428694ff.tar.gz
gentoo-2-3f267af169f284bb318ca11976d7ee03428694ff.tar.bz2
gentoo-2-3f267af169f284bb318ca11976d7ee03428694ff.zip
Removed old ebuilds. Added a patch for 2.0.10 which fixes a crash on obscure window managers. Marked 2.0.9 stable on x86.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.111
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.101
-rw-r--r--net-irc/xchat/files/xc2010-fixfocus.diff17
-rw-r--r--net-irc/xchat/xchat-1.8.11.ebuild98
-rw-r--r--net-irc/xchat/xchat-2.0.10-r1.ebuild3
-rw-r--r--net-irc/xchat/xchat-2.0.10.ebuild88
-rw-r--r--net-irc/xchat/xchat-2.0.9.ebuild4
8 files changed, 28 insertions, 192 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 5459be4ce35c..9ed8aaa22fab 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.107 2004/07/06 21:10:35 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.108 2004/07/17 11:58:53 swegener Exp $
+
+ 17 Jul 2004; Sven Wegener <swegener@gentoo.org> +files/xc2010-fixfocus.diff,
+ -xchat-1.8.11.ebuild, xchat-2.0.10-r1.ebuild, -xchat-2.0.10.ebuild,
+ xchat-2.0.9.ebuild:
+ Removed old ebuilds. Added a patch for 2.0.10 which fixes a crash on obscure
+ window managers. Marked 2.0.9 stable on x86.
*xchat-2.0.10-r1 (06 Jul 2004)
diff --git a/net-irc/xchat/files/digest-xchat-1.8.11 b/net-irc/xchat/files/digest-xchat-1.8.11
deleted file mode 100644
index feaf933fc312..000000000000
--- a/net-irc/xchat/files/digest-xchat-1.8.11
+++ /dev/null
@@ -1 +0,0 @@
-MD5 951f5b2fe2d5deef08f7f519414072a1 xchat-1.8.11.tar.bz2 850453
diff --git a/net-irc/xchat/files/digest-xchat-2.0.10 b/net-irc/xchat/files/digest-xchat-2.0.10
deleted file mode 100644
index 71b7e42a086e..000000000000
--- a/net-irc/xchat/files/digest-xchat-2.0.10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 968bc5f074fd7c202a8d63758bd5b62d xchat-2.0.10.tar.bz2 1113265
diff --git a/net-irc/xchat/files/xc2010-fixfocus.diff b/net-irc/xchat/files/xc2010-fixfocus.diff
new file mode 100644
index 000000000000..318750af5074
--- /dev/null
+++ b/net-irc/xchat/files/xc2010-fixfocus.diff
@@ -0,0 +1,17 @@
+# Fixes rare crash on window focus (only on some obscure WindowManagers)
+--- xchat-2.0.10/src/fe-gtk/maingui.c 2004-06-29 15:27:24.000000000 +1000
++++ xchat-2.0.10p1/src/fe-gtk/maingui.c 2004-07-13 01:11:02.000000000 +1000
+@@ -2131,8 +2142,11 @@
+ mg_tabwin_focus_cb (GtkWindow * win, GdkEventFocus *event, gpointer userdata)
+ {
+ current_sess = current_tab;
+- gtk_xtext_check_marker_visibility(GTK_XTEXT (current_sess->gui->xtext));
+- plugin_emit_dummy_print (current_sess, "Focus Window");
++ if (current_sess)
++ {
++ gtk_xtext_check_marker_visibility (GTK_XTEXT (current_sess->gui->xtext));
++ plugin_emit_dummy_print (current_sess, "Focus Window");
++ }
+ return FALSE;
+ }
+
diff --git a/net-irc/xchat/xchat-1.8.11.ebuild b/net-irc/xchat/xchat-1.8.11.ebuild
deleted file mode 100644
index e69a9dab6ccf..000000000000
--- a/net-irc/xchat/xchat-1.8.11.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.11.ebuild,v 1.17 2004/07/15 00:49:33 agriffis Exp $
-
-inherit eutils
-
-IUSE="gnome gtk ipv6 mmx nls perl python ssl"
-
-DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
-SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
-HOMEPAGE="http://www.xchat.org/"
-
-SLOT="1"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc ~sparc alpha"
-
-RDEPEND="gtk? ( =x11-libs/gtk+-1.2* )
- python? ( >=dev-lang/python-2.2-r7 )
- perl? ( >=dev-lang/perl-5.6.1 )
- gnome? ( <gnome-base/gnome-panel-1.5.0
- >=media-libs/gdk-pixbuf-0.22.0 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
-
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.10.38 )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/xc1811fixststint.diff
-
- # Fix for sock5 vulnerability - see #46856
- epatch ${FILESDIR}/xc208-fixsocks5.diff
-
- use python && ( \
- cp configure configure.orig
- local mylibs=`/usr/bin/python-config`
- sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' \
- configure.orig > configure
- )
-}
-
-src_compile() {
-
- local myopts myflags
-
- if ! use perl; then
- use gnome \
- && myopts="${myopts} --enable-gnome --enable-panel" \
- CFLAGS="${CFLAGS} -I/usr/include/orbit-1.0" \
- || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
- else
- myopts="${myopts} --disable-gnome"
- fi
-
- use gtk \
- || myopts="${myopts} --disable-gtkfe"
-
- use ssl \
- && myopts="${myopts} --enable-openssl"
-
- use perl \
- || myopts="${myopts} --disable-perl"
-
- use nls \
- && myopts="${myopts} --enable-nls --enable-hebrew --enable-japanese-conv" \
- || myopts="${myopts} --disable-nls --disable-hebrew --disable-japanese-conv"
-
- if use x86
- then
- use mmx \
- && myopts="${myopts} --enable-mmx" \
- || myopts="${myopts} --disable-mmx"
- fi
-
- use ipv6 \
- && myopts="${myopts} --enable-ipv6"
-
- use python \
- && myflags="`python-config`" \
- && myopts="${myopts} --enable-python"
-
-
- econf ${myopts} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- use gnome && ( \
- insinto /usr/share/gnome/apps/Internet
- doins xchat.desktop
- )
-
- dodoc AUTHORS COPYING ChangeLog README
-}
diff --git a/net-irc/xchat/xchat-2.0.10-r1.ebuild b/net-irc/xchat/xchat-2.0.10-r1.ebuild
index 3ac09ab8d9f1..7634ad834856 100644
--- a/net-irc/xchat/xchat-2.0.10-r1.ebuild
+++ b/net-irc/xchat/xchat-2.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.10-r1.ebuild,v 1.1 2004/07/06 21:10:35 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.10-r1.ebuild,v 1.2 2004/07/17 11:58:54 swegener Exp $
inherit flag-o-matic eutils
@@ -38,6 +38,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/xc2010-fixtabcomp.diff
+ epatch ${FILESDIR}/xc2010-fixfocus.diff
}
src_compile() {
diff --git a/net-irc/xchat/xchat-2.0.10.ebuild b/net-irc/xchat/xchat-2.0.10.ebuild
deleted file mode 100644
index ffec21b5d4d7..000000000000
--- a/net-irc/xchat/xchat-2.0.10.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.10.ebuild,v 1.1 2004/07/02 22:17:29 swegener Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="Graphical IRC client"
-SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2"
-HOMEPAGE="http://www.xchat.org/"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips"
-IUSE="perl tcltk python ssl mmx ipv6 nls"
-# Local use flag for the text frontend (bug #26427)
-IUSE="${IUSE} xchattext xchatnogtk"
-
-# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
-if [ ${ARCH} = "sparc" ]
-then
- replace-flags "-O3" "-O2"
-fi
-
-RDEPEND=">=dev-libs/glib-2.0.3
- !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
- perl? ( >=dev-lang/perl-5.6.1 )
- ssl? ( >=dev-libs/openssl-0.9.6d )
- python? ( dev-lang/python )
- tcltk? ( dev-lang/tcl )
- nls? ( sys-devel/gettext )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.7
- >=sys-apps/sed-4"
-
-src_compile() {
-
- # xchat's configure script uses sys.path to find library path
- # instead of python-config (#25943)
- unset PYTHONPATH
-
- # test for local usage of xchatnogtk
- local gtkconf
- use xchatnogtk \
- && gtkconf="--disable-gtkfe" \
- || gtkconf="--enable-gtkfe"
-
- econf \
- ${gtkconf} \
- `use_enable ssl openssl` \
- `use_enable perl` \
- `use_enable python` \
- `use_enable tcltk tcl` \
- `use_enable mmx` \
- `use_enable ipv6` \
- `use_enable nls` \
- `use_enable xchattext textfe` \
- --program-suffix=-2 \
- || die "Configure failed"
-
- emake || die "Compile failed"
-
-}
-
-src_install() {
-
- # some magic to create a menu entry for xchat 2
- sed -i \
- -e "s:^Exec=xchat$:Exec=xchat-2:" \
- -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
- xchat.desktop
-
- make DESTDIR=${D} install || die "Install failed"
-
- # install plugin development header
- insinto /usr/include/xchat
- doins src/common/xchat-plugin.h
-
- dodoc ChangeLog README*
-
-}
-
-pkg_postinst() {
- einfo
- einfo "With this release the tab completion behaviour has changed."
- einfo "See http://forum.xchat.org/viewtopic.php?p=653 for more info."
- einfo
-}
diff --git a/net-irc/xchat/xchat-2.0.9.ebuild b/net-irc/xchat/xchat-2.0.9.ebuild
index e268a280b2e9..847087ae23d3 100644
--- a/net-irc/xchat/xchat-2.0.9.ebuild
+++ b/net-irc/xchat/xchat-2.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.9.ebuild,v 1.2 2004/06/24 23:10:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.9.ebuild,v 1.3 2004/07/17 11:58:54 swegener Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.xchat.org/"
LICENSE="GPL-2"
SLOT="2"
-KEYWORDS="~x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips"
+KEYWORDS="x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips"
IUSE="perl tcltk python ssl mmx ipv6 nls"
# Local use flag for the text frontend (bug #26427)
IUSE="${IUSE} xchattext xchatnogtk"