summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-06-07 09:27:08 +0000
committerAlex Alexander <wired@gentoo.org>2010-06-07 09:27:08 +0000
commit39704abacc43c077d031bf031255ce968bb09c3d (patch)
tree47ada39dc71d6bdf12652611be19ccafc7f3f24d /net-irc/znc
parentamd64 stable (bug #305607) (diff)
downloadgentoo-2-39704abacc43c077d031bf031255ce968bb09c3d.tar.gz
gentoo-2-39704abacc43c077d031bf031255ce968bb09c3d.tar.bz2
gentoo-2-39704abacc43c077d031bf031255ce968bb09c3d.zip
znc: version bump, added tcl USE, removed obsolete nomodules USE
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.090.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 4959bb1a445d..641185962a7f 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.33 2010/04/13 11:53:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.34 2010/06/07 09:27:08 wired Exp $
+
+*znc-0.090 (07 Jun 2010)
+
+ 07 Jun 2010; Alex Alexander <wired@gentoo.org> +znc-0.090.ebuild:
+ version bump, added tcl USE, removed obsolete nomodules USE
13 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> znc-0.080.ebuild:
x86 stable wrt bug #313585
diff --git a/net-irc/znc/znc-0.090.ebuild b/net-irc/znc/znc-0.090.ebuild
new file mode 100644
index 000000000000..5867911fd4f5
--- /dev/null
+++ b/net-irc/znc/znc-0.090.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.090.ebuild,v 1.1 2010/06/07 09:27:07 wired Exp $
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ares debug extras ipv6 perl ssl sasl tcl"
+
+DEPEND="
+ ares? ( net-dns/c-ares )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}