summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-20 14:36:53 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-20 14:36:53 +0000
commit1fac68ae827e9d33b4eb14279f7a4910e4e912fa (patch)
tree00af436ac22d1b8d0f85b0fb5198c2045cf7a506 /net-irc/xchat
parentfix my stupid mistake. (diff)
downloadgentoo-2-1fac68ae827e9d33b4eb14279f7a4910e4e912fa.tar.gz
gentoo-2-1fac68ae827e9d33b4eb14279f7a4910e4e912fa.tar.bz2
gentoo-2-1fac68ae827e9d33b4eb14279f7a4910e4e912fa.zip
Revision bump to pull in two fixes for plugins from upstream CVS.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/2.4.4-plugin-fixes.patch38
-rw-r--r--net-irc/xchat/files/digest-xchat-2.4.4-r11
-rw-r--r--net-irc/xchat/xchat-2.4.4-r1.ebuild88
4 files changed, 134 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 25f5cc0534e2..7c36684507f2 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.166 2005/07/12 04:46:23 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.167 2005/07/20 14:36:53 swegener Exp $
+
+*xchat-2.4.4-r1 (20 Jul 2005)
+
+ 20 Jul 2005; Sven Wegener <swegener@gentoo.org>
+ +files/2.4.4-plugin-fixes.patch, +xchat-2.4.4-r1.ebuild:
+ Revision bump to pull in two fixes for plugins from upstream CVS.
12 Jul 2005; Stephen P. Becker <geoman@gentoo.org> xchat-2.4.3.ebuild:
stable on mips
diff --git a/net-irc/xchat/files/2.4.4-plugin-fixes.patch b/net-irc/xchat/files/2.4.4-plugin-fixes.patch
new file mode 100644
index 000000000000..125c80386eb1
--- /dev/null
+++ b/net-irc/xchat/files/2.4.4-plugin-fixes.patch
@@ -0,0 +1,38 @@
+Index: plugins/perl/perl.c
+===================================================================
+RCS file: /cvsroot/xchat/xchat2/plugins/perl/perl.c,v
+retrieving revision 1.75
+retrieving revision 1.76
+diff -u -B -b -r1.75 -r1.76
+--- plugins/perl/perl.c 12 Jun 2005 23:37:39 -0000 1.75
++++ plugins/perl/perl.c 30 Jun 2005 14:37:35 -0000 1.76
+@@ -1273,7 +1273,9 @@
+ }
+ initialized = 1;
+
+- xchat_plugin_get_info (plugin_name, plugin_desc, plugin_version, NULL);
++ *plugin_name = "Perl";
++ *plugin_desc = "Perl scripting interface";
++ *plugin_version = VERSION;
+
+ xchat_hook_command (ph, "load", XCHAT_PRI_NORM, perl_command_load, 0, 0);
+ xchat_hook_command (ph, "unload", XCHAT_PRI_NORM, perl_command_unload, 0,
+Index: plugins/python/python.c
+===================================================================
+RCS file: /cvsroot/xchat/xchat2/plugins/python/python.c,v
+retrieving revision 1.18
+retrieving revision 1.19
+diff -u -B -b -r1.18 -r1.19
+--- plugins/python/python.c 29 Mar 2005 06:23:17 -0000 1.18
++++ plugins/python/python.c 25 Jun 2005 14:57:53 -0000 1.19
+@@ -2052,7 +2052,9 @@
+ }
+ initialized = 1;
+
+- xchat_plugin_get_info (plugin_name, plugin_desc, plugin_version, NULL);
++ *plugin_name = "Python";
++ *plugin_version = VERSION;
++ *plugin_desc = "Python scripting interface";
+
+ /* Initialize python. */
+ Py_SetProgramName("xchat");
diff --git a/net-irc/xchat/files/digest-xchat-2.4.4-r1 b/net-irc/xchat/files/digest-xchat-2.4.4-r1
new file mode 100644
index 000000000000..2edd631e72a6
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.4.4-r1
@@ -0,0 +1 @@
+MD5 c853dbc73c3ba5127388584381bd4dce xchat-2.4.4.tar.bz2 1285259
diff --git a/net-irc/xchat/xchat-2.4.4-r1.ebuild b/net-irc/xchat/xchat-2.4.4-r1.ebuild
new file mode 100644
index 000000000000..442f8cedfa92
--- /dev/null
+++ b/net-irc/xchat/xchat-2.4.4-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.4.4-r1.ebuild,v 1.1 2005/07/20 14:36:53 swegener Exp $
+
+inherit flag-o-matic eutils versionator
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl tcltk python ssl mmx ipv6 nls xchattext xchatnogtk xchatdccserver"
+
+# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+if [ ${ARCH} = "sparc" ]
+then
+ replace-flags "-O[3-9]" "-O2"
+fi
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ !net-irc/xchat-gnome"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ >=sys-apps/sed-4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-plugin-fixes.patch
+ use xchatdccserver && epatch "${FILESDIR}"/xchat-dccserver-0.5.patch
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ --program-suffix=-2 \
+ || die "Configure failed"
+
+ emake || die "Compile failed"
+
+}
+
+src_install() {
+
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ make DESTDIR="${D}" install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+
+}