summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-05-04 09:38:43 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-05-04 09:38:43 +0000
commit1c81628cca99596e1782b04c7d10bd5c981f99a7 (patch)
tree7a25358798f6bf166a3439e62c27cfeaff76430d /net-irc/xchat
parentStable on x86. (diff)
downloadgentoo-2-1c81628cca99596e1782b04c7d10bd5c981f99a7.tar.gz
gentoo-2-1c81628cca99596e1782b04c7d10bd5c981f99a7.tar.bz2
gentoo-2-1c81628cca99596e1782b04c7d10bd5c981f99a7.zip
Restore 2.6.6, bug 176975
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog6
-rw-r--r--net-irc/xchat/files/digest-xchat-2.6.65
-rw-r--r--net-irc/xchat/files/xchat-2.6.6-suffix.patch12
-rw-r--r--net-irc/xchat/xchat-2.6.6.ebuild90
4 files changed, 112 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index d4d4c25646e0..ec63c99071df 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.241 2007/05/03 13:52:05 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.242 2007/05/04 09:38:43 armin76 Exp $
+
+ 04 May 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/xchat-2.6.6-suffix.patch, +xchat-2.6.6.ebuild:
+ Restore 2.6.6, bug 176975
03 May 2007; Gustavo Zacarias <gustavoz@gentoo.org> xchat-2.8.2.ebuild:
Stable on sparc
diff --git a/net-irc/xchat/files/digest-xchat-2.6.6 b/net-irc/xchat/files/digest-xchat-2.6.6
new file mode 100644
index 000000000000..a1bad7599800
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.6.6
@@ -0,0 +1,5 @@
+MD5 43c187582beb31e744c4c5a833a022b5 xchat-2.6.6.tar.bz2 1098934
+RMD160 27cef034342dc831e2ddb11f8bd5f6cb727e8f93 xchat-2.6.6.tar.bz2 1098934
+SHA256 c4b38d29e6a9872c8ffde27c8866d8c3b9f1fe6e227cef5fed39bc79f983d44c xchat-2.6.6.tar.bz2 1098934
+RMD160 24cc9bd414b1dd0e7e38ba9a49d12257aeb89e68 xchat-dccserver-0.6.patch.bz2 49320
+SHA256 90a49a8d810380020c507c1a36f02e7d972cf92b5e4802dcd5cc518cba29078f xchat-dccserver-0.6.patch.bz2 49320
diff --git a/net-irc/xchat/files/xchat-2.6.6-suffix.patch b/net-irc/xchat/files/xchat-2.6.6-suffix.patch
new file mode 100644
index 000000000000..bf5ac2fafcc0
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.6.6-suffix.patch
@@ -0,0 +1,12 @@
+diff -Nur xchat-2.6.6.orig/plugins/dbus/xchat-remote.c xchat-2.6.6/plugins/dbus/xchat-remote.c
+--- xchat-2.6.6.orig/plugins/dbus/xchat-remote.c 2006-07-15 08:27:21.000000000 +0000
++++ xchat-2.6.6/plugins/dbus/xchat-remote.c 2006-10-13 14:16:57.801263851 +0000
+@@ -110,7 +110,7 @@
+ if (fork() == 0)
+ {
+ gchar *url = g_strdup_printf ("--url=%s", opt_open_url);
+- execl (PREFIX"/bin/"PACKAGE_TARNAME, PACKAGE_TARNAME, "-a", url, NULL);
++ execl (PREFIX"/bin/"PACKAGE_TARNAME"-2", PACKAGE_TARNAME"-2", "-a", url, NULL);
+ }
+ } else
+ write_error (_("Failed to complete command"), error);
diff --git a/net-irc/xchat/xchat-2.6.6.ebuild b/net-irc/xchat/xchat-2.6.6.ebuild
new file mode 100644
index 000000000000..7529b743083d
--- /dev/null
+++ b/net-irc/xchat/xchat-2.6.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.6.ebuild,v 1.16 2007/05/04 09:38:43 armin76 Exp $
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ xchatdccserver? ( mirror://gentoo/${PN}-dccserver-0.6.patch.bz2 )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="perl dbus tcl python ssl mmx ipv6 nls spell xchattext xchatnogtk xchatdccserver"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.6.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcl? ( dev-lang/tcl )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.35 ) ) )
+ spell? ( app-text/enchant )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+ epatch "${FILESDIR}"/xchat-2.6.6-suffix.patch
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [ ${ARCH} = "sparc" ] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable spell spell static) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ --program-suffix=-2 \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}