summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-07-14 20:47:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-07-14 20:47:04 +0000
commitc4cb535294ecfe3a445e772f65829e15fed2e4e8 (patch)
tree6ca7ce23954393d7c3acbf36ebab908613a31456 /net-irc/rbot
parentBump (diff)
downloadgentoo-2-c4cb535294ecfe3a445e772f65829e15fed2e4e8.tar.gz
gentoo-2-c4cb535294ecfe3a445e772f65829e15fed2e4e8.tar.bz2
gentoo-2-c4cb535294ecfe3a445e772f65829e15fed2e4e8.zip
Add missing dependency over rake when nls USE flag is enabled. Thanks to Chris Henhawke (bunder) for reporting. Remove rc1 ebuild.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-irc/rbot')
-rw-r--r--net-irc/rbot/ChangeLog7
-rw-r--r--net-irc/rbot/rbot-0.9.11_rc1.ebuild141
-rw-r--r--net-irc/rbot/rbot-0.9.11_rc2.ebuild8
-rw-r--r--net-irc/rbot/rbot-9999-r10.ebuild8
4 files changed, 18 insertions, 146 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index 55025bd8c1c8..fa868557d40b 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/rbot
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.37 2008/07/14 10:29:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.38 2008/07/14 20:47:04 flameeyes Exp $
+
+ 14 Jul 2008; Diego Pettenò <flameeyes@gentoo.org>
+ -rbot-0.9.11_rc1.ebuild, rbot-0.9.11_rc2.ebuild, rbot-9999-r10.ebuild:
+ Add missing dependency over rake when nls USE flag is enabled. Thanks to
+ Chris Henhawke (bunder) for reporting. Remove rc1 ebuild.
*rbot-0.9.11_rc2 (14 Jul 2008)
diff --git a/net-irc/rbot/rbot-0.9.11_rc1.ebuild b/net-irc/rbot/rbot-0.9.11_rc1.ebuild
deleted file mode 100644
index 015d19ebb3b6..000000000000
--- a/net-irc/rbot/rbot-0.9.11_rc1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.11_rc1.ebuild,v 1.4 2008/07/08 02:02:36 the_paya Exp $
-
-inherit ruby eutils
-
-[[ ${PV} == *"9999" ]] && inherit git
-
-DESCRIPTION="rbot is a ruby IRC bot"
-HOMEPAGE="http://ruby-rbot.org/"
-
-LICENSE="GPL-2 as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd"
-IUSE="spell aspell timezone translator shorturl dict figlet
- fortune cal host toilet hunspell"
-ILINGUAS="zh_CN zh_TW ru nl de fr it ja"
-
-for lang in $ILINGUAS; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
-RDEPEND=">=virtual/ruby-1.8
- dev-ruby/ruby-bdb
- timezone? ( dev-ruby/tzinfo )
- spell? (
- aspell? ( app-text/aspell )
- !aspell? (
- hunspell? ( app-text/hunspell )
- !hunspell? ( app-text/ispell )
- )
- )
- translator? ( dev-ruby/mechanize )
- shorturl? ( dev-ruby/shorturl )
- dict? ( dev-ruby/ruby-dict )
- figlet? ( app-misc/figlet )
- toilet? ( app-misc/toilet )
- fortune? ( games-misc/fortune-mod )
- cal? ( || ( sys-apps/util-linux sys-freebsd/freebsd-ubin ) )
- host? ( net-dns/bind-tools )"
-
-if [[ ${PV} == *"9999" ]]; then
- SRC_URI=""
- EGIT_REPO_URI="git://ruby-rbot.org/rbot.git"
-else
- MY_P="${P/_/-}"
- S="${WORKDIR}/${P%_*}"
- SRC_URI="http://ruby-rbot.org/download/${MY_P}-no-mo.tgz"
-fi
-
-pkg_setup() {
- enewuser rbot -1 -1 /var/lib/rbot nobody
-}
-
-src_unpack() {
- if [[ ${PV} == *"9999" ]]; then
- git_src_unpack
-
- cd "${S}"
- sed -i -e '/\$version=/s:".\+":"'${PV}'":' bin/rbot \
- || die "Unable to fix rbot script version."
- else
- unpack ${A}
- fi
-}
-
-src_compile() {
- disable_rbot_plugin() {
- mv "${S}"/data/rbot/plugins/$1.rb{,.disabled}
- }
- use_rbot_plugin() {
- use $1 && return
- disable_rbot_plugin "$2"
- }
- rbot_conf() {
- echo "$1: $2" >> "${T}"/rbot.conf
- }
- use_rbot_conf_path() {
- use "$1" \
- && rbot_conf "$2" "$3" \
- || rbot_conf "$2" /bin/false
- }
-
- local spell_program="/usr/bin/ispell"
- if use !spell; then
- disable_rbot_plugin spell
- spell_program="/bin/false"
- elif use aspell; then
- spell_program="/usr/bin/ispell-aspell"
- elif use hunspell; then
- spell_program="/usr/bin/hunspell -i"
- fi
-
- rbot_conf spell.program "${spell_program}"
-
- if use !figlet && use !toilet; then
- disable_rbot_plugin figlet
- fi
-
- use_rbot_conf_path figlet figlet.path /usr/bin/figlet
- use_rbot_conf_path toilet toilet.path /usr/bin/toilet
-
- use_rbot_plugin timezone time
- use_rbot_plugin translator translator
- use_rbot_plugin shorturl shortenurls
- use_rbot_plugin dict dictclient
-
- use_rbot_plugin fortune fortune
- use_rbot_conf_path fortune fortune.path /usr/bin/fortune
-
- use_rbot_plugin cal cal
- use_rbot_conf_path cal cal.path /usr/bin/cal
-
- use_rbot_plugin host host
- use_rbot_conf_path host host.path /usr/bin/host
-
- local rbot_datadir="${D}"/usr/share/rbot
-
- ruby_econf || die "ruby_econf failed"
-}
-
-src_install() {
- ${RUBY} setup.rb install --prefix="${D}" \
- || die "setup.rb install failed"
-
- diropts -o rbot -g nobody -m 0700
- keepdir /var/lib/rbot
-
- insinto /etc
- doins "${T}"/rbot.conf
-
- newinitd "${FILESDIR}/rbot.init" rbot
- newconfd "${FILESDIR}/rbot.conf" rbot
-}
-
-pkg_postinst() {
- einfo
- elog "rbot now can be started as a normal service."
- elog "Check /etc/conf.d/rbot file for more information about this feature."
- einfo
-}
diff --git a/net-irc/rbot/rbot-0.9.11_rc2.ebuild b/net-irc/rbot/rbot-0.9.11_rc2.ebuild
index 881c47121dfa..6557b7bfe8f1 100644
--- a/net-irc/rbot/rbot-0.9.11_rc2.ebuild
+++ b/net-irc/rbot/rbot-0.9.11_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.11_rc2.ebuild,v 1.1 2008/07/14 10:29:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.11_rc2.ebuild,v 1.2 2008/07/14 20:47:04 flameeyes Exp $
inherit ruby eutils
@@ -39,7 +39,11 @@ RDEPEND=">=virtual/ruby-1.8
fortune? ( games-misc/fortune-mod )
cal? ( || ( sys-apps/util-linux sys-freebsd/freebsd-ubin ) )
host? ( net-dns/bind-tools )"
-DEPEND="nls? ( dev-ruby/ruby-gettext )"
+DEPEND="
+ nls? (
+ dev-ruby/ruby-gettext
+ dev-ruby/rake
+ )"
if [[ ${PV} == *"9999" ]]; then
SRC_URI=""
diff --git a/net-irc/rbot/rbot-9999-r10.ebuild b/net-irc/rbot/rbot-9999-r10.ebuild
index 909b72e45292..e8e65a7f426a 100644
--- a/net-irc/rbot/rbot-9999-r10.ebuild
+++ b/net-irc/rbot/rbot-9999-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r10.ebuild,v 1.3 2008/07/14 10:29:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r10.ebuild,v 1.4 2008/07/14 20:47:04 flameeyes Exp $
inherit ruby eutils
@@ -39,7 +39,11 @@ RDEPEND=">=virtual/ruby-1.8
fortune? ( games-misc/fortune-mod )
cal? ( || ( sys-apps/util-linux sys-freebsd/freebsd-ubin ) )
host? ( net-dns/bind-tools )"
-DEPEND="nls? ( dev-ruby/ruby-gettext )"
+DEPEND="
+ nls? (
+ dev-ruby/ruby-gettext
+ dev-ruby/rake
+ )"
if [[ ${PV} == *"9999" ]]; then
SRC_URI=""