summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-07-14 10:29:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-07-14 10:29:00 +0000
commit4792029aa12e7e834ab08a4d1bd9f76bc9fd27cb (patch)
treeccdf6da7d52a9b705649596b571a7d2b85b04659 /net-irc/rbot
parentadd virtualx eclass to allow test suite to run properly (diff)
downloadgentoo-2-4792029aa12e7e834ab08a4d1bd9f76bc9fd27cb.tar.gz
gentoo-2-4792029aa12e7e834ab08a4d1bd9f76bc9fd27cb.tar.bz2
gentoo-2-4792029aa12e7e834ab08a4d1bd9f76bc9fd27cb.zip
Version bump to rc2, this re-integrates the nls support.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-irc/rbot')
-rw-r--r--net-irc/rbot/ChangeLog8
-rw-r--r--net-irc/rbot/rbot-0.9.11_rc2.ebuild181
-rw-r--r--net-irc/rbot/rbot-9999-r10.ebuild4
3 files changed, 190 insertions, 3 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index fc015e5499a6..55025bd8c1c8 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/rbot
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.36 2008/07/08 02:02:36 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.37 2008/07/14 10:29:00 flameeyes Exp $
+
+*rbot-0.9.11_rc2 (14 Jul 2008)
+
+ 14 Jul 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +rbot-0.9.11_rc2.ebuild, rbot-9999-r10.ebuild:
+ Version bump to rc2, this re-integrates the nls support.
08 Jul 2008; Javier Villavicencio <the_paya@gentoo.org>
rbot-0.9.11_rc1.ebuild:
diff --git a/net-irc/rbot/rbot-0.9.11_rc2.ebuild b/net-irc/rbot/rbot-0.9.11_rc2.ebuild
new file mode 100644
index 000000000000..881c47121dfa
--- /dev/null
+++ b/net-irc/rbot/rbot-0.9.11_rc2.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.11_rc2.ebuild,v 1.1 2008/07/14 10:29:00 flameeyes Exp $
+
+inherit ruby eutils
+
+[[ ${PV} == *"9999" ]] && inherit git
+
+DESCRIPTION="rbot is a ruby IRC bot"
+HOMEPAGE="http://ruby-rbot.org/"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd"
+IUSE="spell aspell timezone translator shorturl nls dict figlet
+ fortune cal host toilet hunspell"
+ILINGUAS="zh_CN zh_TW ru nl de fr it ja"
+
+for lang in $ILINGUAS; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+RDEPEND=">=virtual/ruby-1.8
+ dev-ruby/ruby-bdb
+ timezone? ( dev-ruby/tzinfo )
+ spell? (
+ aspell? ( app-text/aspell )
+ !aspell? (
+ hunspell? ( app-text/hunspell )
+ !hunspell? ( app-text/ispell )
+ )
+ )
+ translator? ( dev-ruby/mechanize )
+ shorturl? ( dev-ruby/shorturl )
+ nls? ( dev-ruby/ruby-gettext )
+ dict? ( dev-ruby/ruby-dict )
+ figlet? ( app-misc/figlet )
+ toilet? ( app-misc/toilet )
+ fortune? ( games-misc/fortune-mod )
+ cal? ( || ( sys-apps/util-linux sys-freebsd/freebsd-ubin ) )
+ host? ( net-dns/bind-tools )"
+DEPEND="nls? ( dev-ruby/ruby-gettext )"
+
+if [[ ${PV} == *"9999" ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="git://ruby-rbot.org/rbot.git"
+else
+ MY_P="${P/_/-}"
+ S="${WORKDIR}/${P%_*}"
+ SRC_URI="http://ruby-rbot.org/download/${MY_P}.tgz"
+fi
+
+pkg_setup() {
+ enewuser rbot -1 -1 /var/lib/rbot nobody
+}
+
+src_unpack() {
+ if [[ ${PV} == *"9999" ]]; then
+ git_src_unpack
+
+ cd "${S}"
+ sed -i -e '/\$version=/s:".\+":"'${PV}'":' bin/rbot \
+ || die "Unable to fix rbot script version."
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ disable_rbot_plugin() {
+ mv "${S}"/data/rbot/plugins/$1.rb{,.disabled}
+ }
+ use_rbot_plugin() {
+ use $1 && return
+ disable_rbot_plugin "$2"
+ }
+ rbot_conf() {
+ echo "$1: $2" >> "${T}"/rbot.conf
+ }
+ use_rbot_conf_path() {
+ use "$1" \
+ && rbot_conf "$2" "$3" \
+ || rbot_conf "$2" /bin/false
+ }
+
+ local spell_program="/usr/bin/ispell"
+ if use !spell; then
+ disable_rbot_plugin spell
+ spell_program="/bin/false"
+ elif use aspell; then
+ spell_program="/usr/bin/ispell-aspell"
+ elif use hunspell; then
+ spell_program="/usr/bin/hunspell -i"
+ fi
+
+ rbot_conf spell.program "${spell_program}"
+
+ if use !figlet && use !toilet; then
+ disable_rbot_plugin figlet
+ fi
+
+ use_rbot_conf_path figlet figlet.path /usr/bin/figlet
+ use_rbot_conf_path toilet toilet.path /usr/bin/toilet
+
+ use_rbot_plugin timezone time
+ use_rbot_plugin translator translator
+ use_rbot_plugin shorturl shortenurls
+ use_rbot_plugin dict dictclient
+
+ use_rbot_plugin fortune fortune
+ use_rbot_conf_path fortune fortune.path /usr/bin/fortune
+
+ use_rbot_plugin cal cal
+ use_rbot_conf_path cal cal.path /usr/bin/cal
+
+ use_rbot_plugin host host
+ use_rbot_conf_path host host.path /usr/bin/host
+
+ local rbot_datadir="${D}"/usr/share/rbot
+
+ # This is unfortunately pretty manual at the moment, but it's just
+ # to avoid having to run special scripts to package new versions
+ # of rbot. The default if new languages are added that are not
+ # considered for an opt-out here is to install them, so you just
+ # need to add them later.
+ if use nls; then
+ strip-linguas ${ILINGUAS}
+ if [[ -n ${LINGUAS} ]]; then
+ # As the the language name used by the rbot data files does
+ # not correspond to the ISO codes we usually use for LINGUAS,
+ # the following list of local varables will work as a
+ # dictionary to get the name used by rbot from the ISO code.
+ local lang_rbot_zh_CN="traditional_chinese"
+ local lang_rbot_ru="russian"
+ local lang_rbot_nl="dutch"
+ local lang_rbot_de="german"
+ local lang_rbot_fr="french"
+ local lang_rbot_it="italian"
+ local lang_rbot_ja="japanese"
+
+ for lang in ${ILINGUAS}; do
+ use linguas_${lang} && continue
+
+ lang_varname="lang_rbot_${lang}"
+ lang_rbot=${!lang_varname}
+
+ rm -r \
+ "${S}"/data/rbot/languages/${lang_rbot}.lang \
+ "${S}"/data/rbot/templates/lart/larts-${lang_rbot} \
+ "${S}"/data/rbot/templates/lart/praises-${lang_rbot} \
+ "${S}"/data/rbot/templates/salut/salut-${lang_rbot} \
+ "${S}"/po/${lang}
+ done
+ fi
+
+ rake makemo || die "locale generation failed"
+ fi
+
+ ruby_econf || die "ruby_econf failed"
+}
+
+src_install() {
+ ${RUBY} setup.rb install --prefix="${D}" \
+ || die "setup.rb install failed"
+
+ diropts -o rbot -g nobody -m 0700
+ keepdir /var/lib/rbot
+
+ insinto /etc
+ doins "${T}"/rbot.conf
+
+ newinitd "${FILESDIR}/rbot.init" rbot
+ newconfd "${FILESDIR}/rbot.conf" rbot
+}
+
+pkg_postinst() {
+ einfo
+ elog "rbot now can be started as a normal service."
+ elog "Check /etc/conf.d/rbot file for more information about this feature."
+ einfo
+}
diff --git a/net-irc/rbot/rbot-9999-r10.ebuild b/net-irc/rbot/rbot-9999-r10.ebuild
index 413b823027f4..909b72e45292 100644
--- a/net-irc/rbot/rbot-9999-r10.ebuild
+++ b/net-irc/rbot/rbot-9999-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r10.ebuild,v 1.2 2008/07/02 14:04:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r10.ebuild,v 1.3 2008/07/14 10:29:00 flameeyes Exp $
inherit ruby eutils
@@ -47,7 +47,7 @@ if [[ ${PV} == *"9999" ]]; then
else
MY_P="${P/_/-}"
S="${WORKDIR}/${P%_*}"
- SRC_URI="http://ruby-rbot.org/download/${MY_P}-no-mo.tgz"
+ SRC_URI="http://ruby-rbot.org/download/${MY_P}.tgz"
fi
pkg_setup() {