summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-09-05 21:40:22 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-09-05 21:40:22 +0000
commitedec903152dbf2f0408885325887b9a3b91f070e (patch)
tree945f81f0c3ecfb9ec916c61caa441f5d1b212330 /net-irc/epic4
parentA graphical interface for administering users and groups (diff)
downloadgentoo-2-edec903152dbf2f0408885325887b9a3b91f070e.tar.gz
gentoo-2-edec903152dbf2f0408885325887b9a3b91f070e.tar.bz2
gentoo-2-edec903152dbf2f0408885325887b9a3b91f070e.zip
Version bump wrt bug #144255, thanks to deww for reporting
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/ChangeLog9
-rw-r--r--net-irc/epic4/epic4-2.4.ebuild84
-rw-r--r--net-irc/epic4/files/digest-epic4-2.24
-rw-r--r--net-irc/epic4/files/digest-epic4-2.46
4 files changed, 101 insertions, 2 deletions
diff --git a/net-irc/epic4/ChangeLog b/net-irc/epic4/ChangeLog
index 931ae4841b8c..568af81cba2c 100644
--- a/net-irc/epic4/ChangeLog
+++ b/net-irc/epic4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/epic4
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.55 2005/08/24 23:44:20 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.56 2006/09/05 21:40:22 jokey Exp $
+
+*epic4-2.4 (05 Sep 2006)
+
+ 05 Sep 2006; Markus Ullmann <jokey@gentoo.org> +epic4-2.4.ebuild:
+ Version bump wrt bug #144255, thanks to deww for reporting
24 Aug 2005; Aron Griffis <agriffis@gentoo.org> epic4-2.2.ebuild:
stable on ia64
diff --git a/net-irc/epic4/epic4-2.4.ebuild b/net-irc/epic4/epic4-2.4.ebuild
new file mode 100644
index 000000000000..388e3f376cce
--- /dev/null
+++ b/net-irc/epic4/epic4-2.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-2.4.ebuild,v 1.1 2006/09/05 21:40:22 jokey Exp $
+
+inherit flag-o-matic eutils
+
+HELP_V="20050315"
+
+DESCRIPTION="Epic4 IRC Client"
+HOMEPAGE="http://epicsol.org/"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-${HELP_V}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc-macos sparc x86"
+IUSE="ipv6 perl ssl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )"
+
+pkg_setup() {
+ if use perl && built_with_use dev-lang/perl ithreads
+ then
+ error "You need perl compiled with USE=\"-ithreads\" to be able to compile epic4."
+ die "perl with USE=\"-ithreads\" needed"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/epic-defaultserver.patch
+
+ rm -f ${WORKDIR}/help/Makefile
+ find ${WORKDIR}/help -type d -name CVS -print0 | xargs -0 rm -r
+}
+
+src_compile() {
+ replace-flags "-O?" "-O"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ssl) \
+ || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die "einstall failed"
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+
+ cd ${S}/doc
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp SILLINESS TS4
+
+ insinto /usr/share/epic/help
+ doins -r ${WORKDIR}/help/* || die "doins failed"
+}
+
+pkg_postinst() {
+ einfo "If /usr/share/epic/script/local does not exist, I will now"
+ einfo "create it. If you do not like the look/feel of this file, or"
+ einfo "if you'd prefer to use your own script, simply remove this"
+ einfo "file. If you want to prevent this file from being installed"
+ einfo "in the future, simply create an empty file with this name."
+
+ if [ ! -f ${ROOT}/usr/share/epic/script/local ]
+ then
+ cp ${FILESDIR}/local ${ROOT}/usr/share/epic/script/
+ fi
+
+ # Fix for bug 59075
+ chmod 755 ${ROOT}/usr/share/epic/help
+}
diff --git a/net-irc/epic4/files/digest-epic4-2.2 b/net-irc/epic4/files/digest-epic4-2.2
index c48eabe180ed..4ee0e124873c 100644
--- a/net-irc/epic4/files/digest-epic4-2.2
+++ b/net-irc/epic4/files/digest-epic4-2.2
@@ -1,2 +1,6 @@
MD5 e4d5d799b43f3c7882e8e7616099d4fc epic4-2.2.tar.bz2 623254
+RMD160 8f1f1b446bd3260e665093864f1becc0b625be32 epic4-2.2.tar.bz2 623254
+SHA256 7f3f011c2392e19c0f12ae669c28f14e8a730918778809191672300dced76291 epic4-2.2.tar.bz2 623254
MD5 9888d1af465ca72bf9a02487264071a5 epic4-help-20050315.tar.gz 332502
+RMD160 b4237357e905468ab4fd7710283d6bffee067c5e epic4-help-20050315.tar.gz 332502
+SHA256 714afd07348731e6ac82e1f6548acc12e84539b3106ab27fa5d00ed5696256f7 epic4-help-20050315.tar.gz 332502
diff --git a/net-irc/epic4/files/digest-epic4-2.4 b/net-irc/epic4/files/digest-epic4-2.4
new file mode 100644
index 000000000000..9d2e938bb7f7
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-2.4
@@ -0,0 +1,6 @@
+MD5 19338b1246287b3ea2050d63d50a838b epic4-2.4.tar.bz2 624067
+RMD160 94b7dd1991349848edc0e5165d4d76b396bb859c epic4-2.4.tar.bz2 624067
+SHA256 b2a7e2465950081feb1f8f438a662a1c41c2d53f9888f07c7a316733871f4125 epic4-2.4.tar.bz2 624067
+MD5 9888d1af465ca72bf9a02487264071a5 epic4-help-20050315.tar.gz 332502
+RMD160 b4237357e905468ab4fd7710283d6bffee067c5e epic4-help-20050315.tar.gz 332502
+SHA256 714afd07348731e6ac82e1f6548acc12e84539b3106ab27fa5d00ed5696256f7 epic4-help-20050315.tar.gz 332502