summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-11-30 19:24:56 +0000
committerPeter Volkov <pva@gentoo.org>2010-11-30 19:24:56 +0000
commit76de158283f40f4bf94f0b04eccc697b1b2d5ed2 (patch)
treee0e8dfc5eea39ec8b4d2bedbc4d453ce9ef2770f /net-im
parentStable for HPPA (bug #347225). (diff)
downloadgentoo-2-76de158283f40f4bf94f0b04eccc697b1b2d5ed2.tar.gz
gentoo-2-76de158283f40f4bf94f0b04eccc697b1b2d5ed2.tar.bz2
gentoo-2-76de158283f40f4bf94f0b04eccc697b1b2d5ed2.zip
Style fixes, wrt Nikoli.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog5
-rw-r--r--net-im/psi/psi-9999.ebuild74
2 files changed, 45 insertions, 34 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index 9623b6f7cbd6..c01286def735 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/psi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.203 2010/11/28 18:41:26 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.204 2010/11/30 19:24:56 pva Exp $
+
+ 30 Nov 2010; Peter Volkov <pva@gentoo.org> psi-9999.ebuild:
+ Style fixes, wrt Nikoli.
28 Nov 2010; Peter Volkov <pva@gentoo.org> psi-9999.ebuild, metadata.xml:
Fixed debug USE flag, update svn paths, thank Nikoli for this job.
diff --git a/net-im/psi/psi-9999.ebuild b/net-im/psi/psi-9999.ebuild
index 0a8e60d9c124..6078b2f12247 100644
--- a/net-im/psi/psi-9999.ebuild
+++ b/net-im/psi/psi-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-9999.ebuild,v 1.9 2010/11/28 18:41:26 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-9999.ebuild,v 1.10 2010/11/30 19:24:56 pva Exp $
EAPI="2"
@@ -24,7 +24,8 @@ KEYWORDS=""
IUSE="crypt dbus debug doc enchant extras jingle iconsets spell ssl xscreensaver powersave
plugins -whiteboarding webkit"
-RDEPEND=">=x11-libs/qt-gui-4.4:4[qt3support,dbus?]
+RDEPEND="
+ >=x11-libs/qt-gui-4.4:4[qt3support,dbus?]
>=x11-libs/qt-qt3support-4.4:4
>=app-crypt/qca-2.0.2:2
whiteboarding? ( x11-libs/qt-svg:4 )
@@ -34,8 +35,8 @@ RDEPEND=">=x11-libs/qt-gui-4.4:4[qt3support,dbus?]
)
xscreensaver? ( x11-libs/libXScrnSaver )
extras? ( webkit? ( x11-libs/qt-webkit ) )
- app-arch/unzip"
-
+ app-arch/unzip
+"
DEPEND="${RDEPEND}
extras? (
${SUBVERSION_DEPEND}
@@ -44,18 +45,19 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
dev-util/pkgconfig
"
-PDEPEND="crypt? ( app-crypt/qca-gnupg:2 )
+PDEPEND="
+ crypt? ( app-crypt/qca-gnupg:2 )
jingle? (
net-im/psimedia
app-crypt/qca-ossl:2
)
- ssl? ( app-crypt/qca-ossl:2 )"
-
+ ssl? ( app-crypt/qca-ossl:2 )
+"
RESTRICT="test"
pkg_setup() {
- for x in iconsets plugins powersave webkit whiteboarding;do
- use ${x} && use !extras && \
+ for x in iconsets plugins powersave webkit whiteboarding; do
+ use ${x} && use !extras && \
ewarn "USE=${x} is only available in Psi+ and requires USE=extras, ${x} will be disabled."
done
@@ -115,7 +117,7 @@ src_unpack() {
src_prepare() {
if use extras; then
EPATCH_EXCLUDE="${MY_EPATCH_EXCLUDE}
- " \
+ " \
EPATCH_SOURCE="${WORKDIR}/patches/" EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch
use powersave && epatch "${WORKDIR}/patches/dev/psi-reduce-power-consumption.patch"
@@ -141,25 +143,32 @@ src_prepare() {
src_configure() {
# unable to use econf because of non-standard configure script
# disable growl as it is a MacOS X extension only
- local confcmd="./configure
- --prefix=/usr
- --qtdir=/usr
- --disable-bundled-qca
- --disable-growl
- --no-separate-debug-info
- $(use dbus || echo '--disable-qdbus')
- $(use debug && echo '--debug')
- $(use spell && {
- use enchant && echo '--disable-aspell' || echo '--disable-enchant'
- } || echo '--disable-aspell --disable-enchant')
- $(use xscreensaver || echo '--disable-xss')
- $(use extras && {
- use plugins && echo '--enable-plugins'
- use webkit && echo '--enable-webkit'
- } )"
-
- echo "${confcmd}"
- ${confcmd} || die "configure failed"
+ local myconf="
+ --prefix=/usr
+ --qtdir=/usr
+ --disable-bundled-qca
+ --disable-growl
+ --no-separate-debug-info
+ "
+ use dbus || myconf+=" --disable-qdbus"
+ use debug && myconf+=" --debug"
+ if use spell; then
+ if use enchant; then
+ myconf+=" --disable-aspell"
+ else
+ myconf+=" --disable-enchant"
+ fi
+ else
+ myconf+=" --disable-aspell --disable-enchant"
+ fi
+ use xscreensaver || myconf+=" --disable-xss"
+ if use extras; then
+ use plugins && myconf+=" --enable-plugins"
+ use webkit && myconf+=" --enable-webkit"
+ fi
+
+ einfo "./configure ${myconf}"
+ ./configure ${myconf} || die "configure failed"
eqmake4
}
@@ -176,9 +185,9 @@ src_compile() {
src_install() {
emake INSTALL_ROOT="${D}" install || die "emake install failed"
- rm -f "${D}"/usr/share/psi/{COPYING,README}
# this way the docs will be installed in the standard gentoo dir
+ rm -f "${D}"/usr/share/psi/{COPYING,README}
newdoc iconsets/roster/README README.roster || die
newdoc iconsets/system/README README.system || die
newdoc certs/README README.certs || die
@@ -195,8 +204,7 @@ src_install() {
fi
if use doc; then
- cd doc
- dohtml -r api || die "dohtml failed"
+ dohtml -r doc/api || die "dohtml failed"
fi
# install translations
@@ -206,7 +214,7 @@ src_install() {
if use linguas_${x}; then
lrelease "${x}/${PN}_${x}.ts" || die "lrelease ${x} failed"
doins "${x}/${PN}_${x}.qm" || die
- newins "${x}/INFO" "INFO.${x}"
+ newins "${x}/INFO" "${PN}_${x}.INFO"
fi
done
}