summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-02 12:48:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-02 12:48:17 +0000
commit1a6464c78d931356d9473d9025bd059b95f1e45c (patch)
tree008b55022df6b99483f0b0c77b3143bccfb0e87b /net-im
parentFix license, bug 445456. (diff)
downloadgentoo-2-1a6464c78d931356d9473d9025bd059b95f1e45c.tar.gz
gentoo-2-1a6464c78d931356d9473d9025bd059b95f1e45c.tar.bz2
gentoo-2-1a6464c78d931356d9473d9025bd059b95f1e45c.zip
Version bump wrt #443440 by Galym Kerimbekov and Tom Wijsman
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skype/ChangeLog7
-rw-r--r--net-im/skype/skype-4.1.0.20.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index d7b888658e53..fcf1f68f13f4 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/skype
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.141 2012/12/02 11:27:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.142 2012/12/02 12:48:17 ssuominen Exp $
+
+*skype-4.1.0.20 (02 Dec 2012)
+
+ 02 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +skype-4.1.0.20.ebuild:
+ Version bump wrt #443440 by Galym Kerimbekov and Tom Wijsman
02 Dec 2012; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Drop to maintainer-needed@gentoo.org
diff --git a/net-im/skype/skype-4.1.0.20.ebuild b/net-im/skype/skype-4.1.0.20.ebuild
new file mode 100644
index 000000000000..057622cacfbd
--- /dev/null
+++ b/net-im/skype/skype-4.1.0.20.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-4.1.0.20.ebuild,v 1.1 2012/12/02 12:48:17 ssuominen Exp $
+
+EAPI=5
+inherit eutils gnome2-utils pax-utils
+
+DESCRIPTION="An P2P Internet Telephony (VoiceIP) client"
+HOMEPAGE="http://www.skype.com/"
+SRC_URI="http://download.${PN}.com/linux/${P}.tar.bz2"
+
+LICENSE="${PN}-4.0.0.7-copyright ${PN}-4.0.0.7-third-party_attributions.txt"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel selinux"
+
+QA_PREBUILT=opt/bin/${PN}
+RESTRICT="mirror strip" #299368
+
+EMUL_X86_VER=20120520
+
+DEPEND="x11-libs/qt-core:4"
+RDEPEND="${DEPEND}
+ virtual/ttf-fonts
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-${EMUL_X86_VER}
+ >=app-emulation/emul-linux-x86-qtlibs-${EMUL_X86_VER}
+ >=app-emulation/emul-linux-x86-soundlibs-${EMUL_X86_VER}
+ >=app-emulation/emul-linux-x86-xlibs-${EMUL_X86_VER}
+ )
+ !amd64? (
+ media-libs/alsa-lib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXv
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4[accessibility,dbus]
+ x11-libs/qt-webkit:4
+ )
+ selinux? ( sec-policy/selinux-skype )"
+
+src_compile() {
+ type -P lrelease >/dev/null && lrelease lang/*.ts
+ rm -f lang/*.ts
+}
+
+src_install() {
+ into /opt
+ dobin ${PN}
+ fowners root:audio /opt/bin/${PN}
+
+ insinto /etc/dbus-1/system.d
+ doins ${PN}.conf
+
+ insinto /usr/share/skype
+ doins -r avatars lang sounds
+
+ dodoc README
+
+ local res
+ for res in 16 32 48; do
+ newicon -s ${res} icons/SkypeBlue_${res}x${res}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} 'Skype VoIP' ${PN} 'Network;InstantMessaging;Telephony'
+
+ if use pax_kernel; then
+ pax-mark Cm "${ED}"/opt/bin/${PN} || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+
+ echo PRELINK_PATH_MASK=/opt/bin/${PN} > ${T}/99${PN}
+ doenvd "${T}"/99${PN} #430142
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+
+ rm -rf "${EROOT}"/usr/share/${PN} #421165
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ # http://bugs.gentoo.org/360815
+ elog "For webcam support, see \"LD_PRELOAD\" section of \"README.lib\" document provided by"
+ elog "media-libs/libv4l package and \"README\" document of this package."
+ if use amd64; then
+ elog "You can install app-emulation/emul-linux-x86-medialibs package for the 32bit"
+ elog "libraries from the media-libs/libv4l package."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}