summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-03-31 09:09:22 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-03-31 09:09:22 +0000
commitf1ec5e4c0c2522d72e77c4f622e09deacbab1f49 (patch)
tree8dcfc36d58bad20de3cec8d2ca2e49669f9268fc /net-im/imcom
parentunmask (diff)
downloadgentoo-2-f1ec5e4c0c2522d72e77c4f622e09deacbab1f49.tar.gz
gentoo-2-f1ec5e4c0c2522d72e77c4f622e09deacbab1f49.tar.bz2
gentoo-2-f1ec5e4c0c2522d72e77c4f622e09deacbab1f49.zip
new version
Diffstat (limited to 'net-im/imcom')
-rw-r--r--net-im/imcom/ChangeLog6
-rw-r--r--net-im/imcom/files/Makefile-1.30_beta838
-rw-r--r--net-im/imcom/files/digest-imcom-1.30_beta81
-rw-r--r--net-im/imcom/imcom-1.30_beta8.ebuild39
4 files changed, 83 insertions, 1 deletions
diff --git a/net-im/imcom/ChangeLog b/net-im/imcom/ChangeLog
index eab7d2461eff..e6ed6eba4a92 100644
--- a/net-im/imcom/ChangeLog
+++ b/net-im/imcom/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-im/imcom
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/imcom/ChangeLog,v 1.6 2003/02/12 08:01:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/imcom/ChangeLog,v 1.7 2003/03/31 09:09:22 lordvan Exp $
+*imcom-1.30_beta8 (31 MAr 2003)
+ 31 Mar 2003; Thomas Raschbacher <lordvan@gentoo.org> imcom-1.30_beta8.ebuild:
+ new version
+
*imcom-1.30_beta7 (25 Jan 2003)
25 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org> imcom-1.30_beta7.ebuild:
version bump + remove old 1.30beta2*+patch
diff --git a/net-im/imcom/files/Makefile-1.30_beta8 b/net-im/imcom/files/Makefile-1.30_beta8
new file mode 100644
index 000000000000..587f0a3b2ac7
--- /dev/null
+++ b/net-im/imcom/files/Makefile-1.30_beta8
@@ -0,0 +1,38 @@
+prefix=/usr
+exec_prefix = ${prefix}
+bindir = ${exec_prefix}/bin
+datadir = ${prefix}/share
+mandir = ${prefix}/man
+
+all:
+ chmod +x imcom CLI.py LogHandler.py AccountCreator.py
+
+install: all install-docs
+ mkdir -p ${DESTDIR}/${datadir}/imcom
+ cp *.py ${DESTDIR}/${datadir}/imcom
+ mkdir -p ${DESTDIR}/${bindir}
+ cp imcom ${DESTDIR}/${bindir}
+
+install-docs:
+ mkdir -p ${DESTDIR}/${datadir}/doc/imcom${MYVER}
+ cp docs/*.html ${DESTDIR}/${datadir}/doc/imcom${MYVER}
+ cp CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW ${DESTDIR}/${datadir}/doc/imcom${MYVER}
+ mkdir -p ${DESTDIR}/${mandir}/man1/
+ cp docs/imcom.1 ${DESTDIR}/${mandir}/man1/imcom.1
+
+
+
+uninstall:
+ rm -rf ${datadir}/imcom
+ rm -f ${bindir}/imcom
+ rm -f ${mandir}/man1/imcom.1
+
+clean:
+ rm -f config.status config.log config.cache *.pyc
+
+distclean: clean
+ rm -rf CVS docs/CVS
+ rm -f imcom Makefile
+ rm -f docs/imcom.7
+ chmod a-x CLI.py LogHandler.py AccountCreator.py
+ rm -f *~ .#*
diff --git a/net-im/imcom/files/digest-imcom-1.30_beta8 b/net-im/imcom/files/digest-imcom-1.30_beta8
new file mode 100644
index 000000000000..3807b350c541
--- /dev/null
+++ b/net-im/imcom/files/digest-imcom-1.30_beta8
@@ -0,0 +1 @@
+MD5 d53626d8db67953524d2964048274491 imcom-1.30beta8.tar.gz 292109
diff --git a/net-im/imcom/imcom-1.30_beta8.ebuild b/net-im/imcom/imcom-1.30_beta8.ebuild
new file mode 100644
index 000000000000..e60967187a21
--- /dev/null
+++ b/net-im/imcom/imcom-1.30_beta8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/imcom/imcom-1.30_beta8.ebuild,v 1.1 2003/03/31 09:09:22 lordvan Exp $
+
+MYVER=1.30beta8
+S=${WORKDIR}/${PN}-${MYVER}
+#SRC_URI="http://imcom.floobin.cx/files/${P}.tar.gz"
+SRC_URI="http://nafai.dyndns.org/files/imcom-betas/${PN}-${MYVER}.tar.gz"
+HOMEPAGE="http://imcom.floobin.cx"
+DESCRIPTION="Python commandline Jabber Client"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/PyXML-0.7"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ #make
+ # fixing it ..
+ cp ${FILESDIR}/Makefile-1.30_beta8 ${S}/Makefile
+ pwd
+ make
+}
+
+src_install() {
+ dodoc AutoStatus.API CONTRIBUTORS LICENSE README* TODO WHATSNEW
+ dodoc docs/*
+ make MYVER=${MYVER} DESTDIR=${D} install
+}