summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-08-09 12:27:33 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-08-09 12:27:33 +0000
commitc6e76d6c09328402ae135123ddabe94ffe294ffc (patch)
tree770810cf6e21bbfa5ca5fb35c6c39b687c2a67a6 /net-ftp
parentpybugz initial commit (diff)
downloadgentoo-2-c6e76d6c09328402ae135123ddabe94ffe294ffc.tar.gz
gentoo-2-c6e76d6c09328402ae135123ddabe94ffe294ffc.tar.bz2
gentoo-2-c6e76d6c09328402ae135123ddabe94ffe294ffc.zip
version bump - fixed bug #142615 autoconf depend on gnutls
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.43
-rw-r--r--net-ftp/lftp/lftp-3.5.4.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 743edc8f0127..fcb529eef3eb 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.114 2006/08/03 03:06:57 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.115 2006/08/09 12:27:33 dragonheart Exp $
+
+*lftp-3.5.4 (09 Aug 2006)
+
+ 09 Aug 2006; Daniel Black <dragonheart@gentoo.org> +lftp-3.5.4.ebuild:
+ version bump - fixed bug #142615 autoconf depend on gnutls thanks to Fritz
+ Heinrichmeyer
03 Aug 2006; Daniel Black <dragonheart@gentoo.org> lftp-3.5.2.ebuild,
lftp-3.5.2-r1.ebuild:
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.4 b/net-ftp/lftp/files/digest-lftp-3.5.4
new file mode 100644
index 000000000000..8ad129ee369f
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.4
@@ -0,0 +1,3 @@
+MD5 1c7f49822793d03588fd4080c40281a7 lftp-3.5.4.tar.bz2 1320471
+RMD160 bfa694c29623f4519f1f11b6137cefc703f3f7b4 lftp-3.5.4.tar.bz2 1320471
+SHA256 94e599136235023d6c0d7b971d6602f08c1cfc93c8c5dc05880b4c3f67f725a1 lftp-3.5.4.tar.bz2 1320471
diff --git a/net-ftp/lftp/lftp-3.5.4.ebuild b/net-ftp/lftp/lftp-3.5.4.ebuild
new file mode 100644
index 000000000000..a76c9facde10
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.4.ebuild,v 1.1 2006/08/09 12:27:33 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ !ppc-macos? ( >=sys-libs/readline-5.1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ >=sys-devel/autoconf-2.60"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}