summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-06-19 08:48:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-06-19 08:48:45 +0000
commitbb8fe091db3048eb41263cc9ba952e263b7ffd56 (patch)
treeee8e6e121ec29ed9a5315f5d20b2d13fcf91f225 /net-ftp
parentBump (diff)
downloadgentoo-2-bb8fe091db3048eb41263cc9ba952e263b7ffd56.tar.gz
gentoo-2-bb8fe091db3048eb41263cc9ba952e263b7ffd56.tar.bz2
gentoo-2-bb8fe091db3048eb41263cc9ba952e263b7ffd56.zip
Version bump, updated translations
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog7
-rw-r--r--net-ftp/filezilla/filezilla-3.7.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index ceee7c9ab08c..e60f6f0656f2 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.98 2013/05/27 09:33:06 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.99 2013/06/19 08:48:45 voyageur Exp $
+
+*filezilla-3.7.1 (19 Jun 2013)
+
+ 19 Jun 2013; Bernard Cafarelli <voyageur@gentoo.org> +filezilla-3.7.1.ebuild:
+ Version bump, updated translations
*filezilla-3.7.0.2 (27 May 2013)
diff --git a/net-ftp/filezilla/filezilla-3.7.1.ebuild b/net-ftp/filezilla/filezilla-3.7.1.ebuild
new file mode 100644
index 000000000000..371d6c23260f
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.7.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.7.1.ebuild,v 1.1 2013/06/19 08:48:45 voyageur Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="aqua dbus nls test"
+
+RDEPEND=">=app-admin/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/tinyxml-2.6.1-r1[stl]
+ net-dns/libidn
+ >=net-libs/gnutls-3.1
+ aqua? ( >=x11-libs/wxGTK-2.8.12:2.8[aqua] )
+ !aqua? ( >=x11-libs/wxGTK-2.8.12:2.8[X] x11-misc/xdg-utils )
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3.5.1-debug.patch
+ append-cppflags -DTIXML_USE_STL
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-tinyxml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+
+ if use aqua ; then
+ cat > "${T}/${PN}" <<-EOF
+ #!${EPREFIX}/bin/bash
+ open "${EPREFIX}"/Applications/FileZilla.app
+ EOF
+ rm "${ED}/usr/bin/${PN}" || die
+ dobin "${T}/${PN}"
+ insinto /Applications
+ doins "${S}"/FileZilla.app
+ fi
+}