summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-06 20:59:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-06 20:59:08 +0000
commitc092cd53c3f3056e6a2f60f756c5242f03848668 (patch)
tree50c4a479cb2a74330294e3216b6462f23ff23240 /net-ftp/ftpcube
parentFix broken Manifest entry for ChangeLog. (diff)
downloadgentoo-2-c092cd53c3f3056e6a2f60f756c5242f03848668.tar.gz
gentoo-2-c092cd53c3f3056e6a2f60f756c5242f03848668.tar.bz2
gentoo-2-c092cd53c3f3056e6a2f60f756c5242f03848668.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/ftpcube')
-rw-r--r--net-ftp/ftpcube/ChangeLog6
-rw-r--r--net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild24
2 files changed, 19 insertions, 11 deletions
diff --git a/net-ftp/ftpcube/ChangeLog b/net-ftp/ftpcube/ChangeLog
index 5e59fb032f2a..5ea6c9b582dd 100644
--- a/net-ftp/ftpcube/ChangeLog
+++ b/net-ftp/ftpcube/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/ftpcube
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.41 2010/02/08 09:02:41 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.42 2010/04/06 20:59:08 arfrever Exp $
+
+ 06 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ ftpcube-0.5.1-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
08 Feb 2010; Peter Volkov <pva@gentoo.org> ftpcube-0.5.1-r1.ebuild:
Add inherit eutils for epatch.
diff --git a/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild b/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild
index 80f07489dc6d..558bfb3d7b73 100644
--- a/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild
+++ b/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild,v 1.4 2010/02/08 09:02:41 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.5.1-r1.ebuild,v 1.5 2010/04/06 20:59:08 arfrever Exp $
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
-MY_P="${P/_beta/-b}"
DESCRIPTION="Graphical FTP client using wxPython"
-SRC_URI="mirror://sourceforge/ftpcube/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/ftpcube/${P}.tar.gz"
HOMEPAGE="http://ftpcube.sourceforge.net/"
KEYWORDS="~amd64 hppa ~ppc sparc x86"
@@ -16,14 +19,15 @@ IUSE="sftp"
DEPEND="=dev-python/wxpython-2.6*
sftp? ( dev-python/paramiko )"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
-S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="libftpcube"
-src_unpack() {
- distutils_src_unpack
+src_prepare() {
+ distutils_src_prepare
epatch "${FILESDIR}/${P}-wxversion.patch"
-}
-src_install() {
- distutils_src_install --install-scripts=/usr/bin
+ # setup.cfg specifies /usr/local location for data and scripts.
+ rm -f setup.cfg
}