summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-26 21:46:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-26 21:46:53 +0000
commit547383f2ba094dcdb475ff707ba25dabcd81cacd (patch)
treecf99f1bd007dd65594f3dd8c9de3c7a91b7eb07f /net-ftp/atftp/atftp-0.7-r1.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-547383f2ba094dcdb475ff707ba25dabcd81cacd.tar.gz
gentoo-2-547383f2ba094dcdb475ff707ba25dabcd81cacd.tar.bz2
gentoo-2-547383f2ba094dcdb475ff707ba25dabcd81cacd.zip
Major fixups, bugs: #104218 - password extension for linksys gear, #109638 - pcre fix and more features, #109912 - 64bit fixes, #110591 - test fixes, #126520 - glibc 2.4 support.
(Portage version: 2.1_rc2)
Diffstat (limited to 'net-ftp/atftp/atftp-0.7-r1.ebuild')
-rw-r--r--net-ftp/atftp/atftp-0.7-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-ftp/atftp/atftp-0.7-r1.ebuild b/net-ftp/atftp/atftp-0.7-r1.ebuild
new file mode 100644
index 000000000000..e0d539a433a8
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/atftp-0.7-r1.ebuild,v 1.1 2006/05/26 21:46:53 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DEBIAN_PV="11"
+DEBIAN_A="${PN}_${PV}-${DEBIAN_PV}.diff.gz"
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz
+ http://ftp.debian.org/debian/pool/main/a/${PN}/${DEBIAN_A}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ selinux? ( sec-policy/selinux-tftpd )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ !virtual/tftp"
+PROVIDE="virtual/tftp"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}"/${DEBIAN_A}
+ epatch "${FILESDIR}"/${P}-pcre.patch
+ epatch "${FILESDIR}"/${P}-password.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ epatch "${FILESDIR}"/${P}-glibc24.patch
+ # remove upstream's broken CFLAGS
+ sed -i.orig -e \
+ '/^CFLAGS="-g -Wall -D_REENTRANT"/s,".*","",g' \
+ ${S}/configure
+}
+
+src_compile() {
+ append-flags -D_REENTRANT -DRATE_CONTROL
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp \
+ || die "./configure failed"
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Installation failed"
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc ${S}/docs/*
+
+ docinto test
+ cd ${S}/test
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}