summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-13 21:33:50 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-13 21:33:50 +0000
commit5028c69fceeaf709579e6a8b897f6ec92f5009a9 (patch)
tree5667627e8ea7a6c0f715f0d15f6c6fe2ef7c0fe3 /net-fs
parentVersion bump. (diff)
downloadgentoo-2-5028c69fceeaf709579e6a8b897f6ec92f5009a9.tar.gz
gentoo-2-5028c69fceeaf709579e6a8b897f6ec92f5009a9.tar.bz2
gentoo-2-5028c69fceeaf709579e6a8b897f6ec92f5009a9.zip
Version bump #407981 by hal.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/ChangeLog9
-rw-r--r--net-fs/libnfs/libnfs-1.3.0.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/net-fs/libnfs/ChangeLog b/net-fs/libnfs/ChangeLog
index caee6b4242aa..60996c1bfa81 100644
--- a/net-fs/libnfs/ChangeLog
+++ b/net-fs/libnfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/libnfs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.1 2011/11/06 23:17:33 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.2 2012/03/13 21:33:50 vapier Exp $
+
+*libnfs-1.3.0 (13 Mar 2012)
+
+ 13 Mar 2012; Mike Frysinger <vapier@gentoo.org> +libnfs-1.3.0.ebuild:
+ Version bump #407981 by hal.
*libnfs-9999 (06 Nov 2011)
diff --git a/net-fs/libnfs/libnfs-1.3.0.ebuild b/net-fs/libnfs/libnfs-1.3.0.ebuild
new file mode 100644
index 000000000000..31de96e26a65
--- /dev/null
+++ b/net-fs/libnfs/libnfs-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-1.3.0.ebuild,v 1.1 2012/03/13 21:33:50 vapier Exp $
+
+EAPI="4"
+
+inherit autotools
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/tarball/${P} -> ${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ mv sahlberg-libnfs-* "${S}" || die
+ fi
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-tirpc \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}