summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-06-14 15:29:00 +0000
committerYixun Lan <dlan@gentoo.org>2014-06-14 15:29:00 +0000
commit161d280131f6e4624d2b75cb0fa41197b42d38b9 (patch)
treeb804620f7c64fe2173303418534f7430db216467 /net-fs
parentbump (diff)
downloadgentoo-2-161d280131f6e4624d2b75cb0fa41197b42d38b9.tar.gz
gentoo-2-161d280131f6e4624d2b75cb0fa41197b42d38b9.tar.bz2
gentoo-2-161d280131f6e4624d2b75cb0fa41197b42d38b9.zip
fix missing stdarg.h, bug 513196
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog6
-rw-r--r--net-fs/autofs/autofs-5.1.0.ebuild6
-rw-r--r--net-fs/autofs/files/autofs-5.1.0-fix-missing-stdarg.patch43
3 files changed, 53 insertions, 2 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 2b11768b061a..22b2725dd87f 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.175 2014/06/14 07:48:09 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.176 2014/06/14 15:29:00 dlan Exp $
+
+ 14 Jun 2014; Yixun Lan <dlan@gentoo.org> autofs-5.1.0.ebuild,
+ +files/autofs-5.1.0-fix-missing-stdarg.patch:
+ fix missing stdarg.h, bug 513196
*autofs-5.1.0 (14 Jun 2014)
diff --git a/net-fs/autofs/autofs-5.1.0.ebuild b/net-fs/autofs/autofs-5.1.0.ebuild
index b2df45ccbb4e..0b618317edad 100644
--- a/net-fs/autofs/autofs-5.1.0.ebuild
+++ b/net-fs/autofs/autofs-5.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.1.0.ebuild,v 1.1 2014/06/14 07:48:09 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.1.0.ebuild,v 1.2 2014/06/14 15:29:00 dlan Exp $
EAPI=5
@@ -47,6 +47,10 @@ DEPEND="${RDEPEND}
CONFIG_CHECK="~AUTOFS4_FS"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-missing-stdarg.patch"
+)
+
src_prepare() {
# Upstream's patchset
if [[ -n ${PATCH_VER} ]]; then
diff --git a/net-fs/autofs/files/autofs-5.1.0-fix-missing-stdarg.patch b/net-fs/autofs/files/autofs-5.1.0-fix-missing-stdarg.patch
new file mode 100644
index 000000000000..411a6d088dcc
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.1.0-fix-missing-stdarg.patch
@@ -0,0 +1,43 @@
+From b9653c08896fcb08c441177e5918458f09111351 Mon Sep 17 00:00:00 2001
+From: "Yixun Lan (dlan)" <dennis.yxun@gmail.com>
+Date: Sat, 14 Jun 2014 23:16:36 +0800
+Subject: [PATCH] fix undefined va_{start,end} error
+
+https://bugs.gentoo.org/show_bug.cgi?id=513196
+
+---
+
+x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -rdynamic -pie -o automount auto
+mount.o indirect.o direct.o spawn.o module.o mount.o lookup.o state.o flag.o ../
+lib/autofs.a -lpthread -lnsl -ldl
+../lib/autofs.a(defaults.o): In function `message':
+/var/tmp/portage/net-fs/autofs-5.1.0/work/autofs-5.1.0/lib/defaults.c:179: undef
+ined reference to `va_start'
+/var/tmp/portage/net-fs/autofs-5.1.0/work/autofs-5.1.0/lib/defaults.c:186: undefined reference to `va_end'
+collect2: error: ld returned 1 exit status
+Makefile:33: recipe for target 'automount' failed
+make[1]: *** [automount] Error 1
+make[1]: Leaving directory '/var/tmp/portage/net-fs/autofs-5.1.0/work/autofs-5.1.0/daemon'
+Makefile:14: recipe for target 'daemon' failed
+make: *** [daemon] Error 2
+
+Signed-off-by: Yixun Lan (dlan) <dennis.yxun@gmail.com>
+---
+ lib/defaults.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/defaults.c b/lib/defaults.c
+index 2b03ea2..5728e67 100644
+--- a/lib/defaults.c
++++ b/lib/defaults.c
+@@ -16,6 +16,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <stdarg.h>
+ #include <ctype.h>
+ #include <string.h>
+ #include <sys/utsname.h>
+--
+1.8.5.2
+