summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2004-10-05 20:00:07 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2004-10-05 20:00:07 +0000
commit85de59e484c48f429c9f933ab36df7c085c204d6 (patch)
treecaeb1583c3db830158c35baba0af23e25b646d71 /net-fs/coda
parentremoved zlib check. (Manifest recommit) (diff)
downloadgentoo-2-85de59e484c48f429c9f933ab36df7c085c204d6.tar.gz
gentoo-2-85de59e484c48f429c9f933ab36df7c085c204d6.tar.bz2
gentoo-2-85de59e484c48f429c9f933ab36df7c085c204d6.zip
Fixed mistake in pkg_config of coda. First ask where, then check for problems.
Diffstat (limited to 'net-fs/coda')
-rw-r--r--net-fs/coda/ChangeLog7
-rw-r--r--net-fs/coda/coda-6.0.6.ebuild27
2 files changed, 20 insertions, 14 deletions
diff --git a/net-fs/coda/ChangeLog b/net-fs/coda/ChangeLog
index 11751bb14b04..ddbfe052bec4 100644
--- a/net-fs/coda/ChangeLog
+++ b/net-fs/coda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/coda
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.10 2004/10/03 19:37:12 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.11 2004/10/05 20:00:07 griffon26 Exp $
+
+ 05 Oct 2004; Maurice van der Pot <griffon26@gentoo.org> coda-6.0.6.ebuild:
+ During setup of the initial configuration, first ask the user where to
+ store file data, so the location can be checked for an existing vice
+ partition that needs to be removed.
03 Oct 2004; Maurice van der Pot <griffon26@gentoo.org> coda-6.0.6.ebuild:
Ebuild now allows user to set up initial configuration after installation.
diff --git a/net-fs/coda/coda-6.0.6.ebuild b/net-fs/coda/coda-6.0.6.ebuild
index d0aea3be48d4..d6e768170242 100644
--- a/net-fs/coda/coda-6.0.6.ebuild
+++ b/net-fs/coda/coda-6.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.6.ebuild,v 1.6 2004/10/03 19:37:12 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.6.ebuild,v 1.7 2004/10/05 20:00:07 griffon26 Exp $
inherit eutils
@@ -157,6 +157,18 @@ pkg_config () {
exit 1
fi
+ # Ask for the location of (amongst other things) the vice partition
+ ewarn "This default configuration of coda will require 350MB of free space"
+ ewarn "for Recoverable Virtual Memory. Additional space is required for"
+ ewarn "the files that you store on your coda volume."
+ echo
+ einfon "Please specify where coda should store this data [${CODA_STORAGE_DIR}]: "
+ read new_storage_dir
+ if [ "x${new_storage_dir}" != "x" ]; then
+ CODA_STORAGE_DIR=${new_storage_dir}
+ fi
+ echo
+
# Check if an existing server.conf is in the way
conf=$(codaconfedit server.conf)
intheway=
@@ -164,7 +176,7 @@ pkg_config () {
intheway="${intheway} ${conf}"
fi
- # Check if an existing /var/lib/vice is in the way
+ # Check if an existing vice root dir is in the way
if [ -e ${CODA_ROOT_DIR} ]; then
intheway="${intheway} ${CODA_ROOT_DIR}"
fi
@@ -183,17 +195,6 @@ pkg_config () {
exit 1
fi
- ewarn "This default configuration of coda will require 350MB of free space"
- ewarn "for Recoverable Virtual Memory. Additional space is required for"
- ewarn "the files that you store on your coda volume."
- echo
- einfon "Please specify where coda should store this data [${CODA_STORAGE_DIR}]: "
- read new_storage_dir
- if [ "x${new_storage_dir}" != "x" ]; then
- CODA_STORAGE_DIR=${new_storage_dir}
- fi
-
- echo
einfo "A default coda server and client configuration will be set up that consists of:"
einfo "- a coda SCM (System Control Machine)"
einfo "- a coda administrator '${CODA_ADMIN_NAME}' with coda uid ${CODA_ADMIN_UID} and password 'changeme'"