summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-02-24 18:51:52 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-02-24 18:51:52 +0000
commit3796f643960fc7a8d6a97d935288c7ec3b55cdb9 (patch)
tree630b57644e8bafffb61018a7d715bb4680bb79ad /net-firewall
parentVersion bump, security bug #404095. (diff)
downloadgentoo-2-3796f643960fc7a8d6a97d935288c7ec3b55cdb9.tar.gz
gentoo-2-3796f643960fc7a8d6a97d935288c7ec3b55cdb9.tar.bz2
gentoo-2-3796f643960fc7a8d6a97d935288c7ec3b55cdb9.zip
Version Bump; See Bug 405509; Thanks a lot to Richard
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall/ChangeLog8
-rw-r--r--net-firewall/shorewall/files/shorewall.initd7
-rw-r--r--net-firewall/shorewall/shorewall-4.5.0.1.ebuild59
3 files changed, 70 insertions, 4 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index fedf9f982bce..e1acb3eac4fc 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.201 2012/01/23 13:39:48 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.202 2012/02/24 18:51:52 constanze Exp $
+
+*shorewall-4.5.0.1 (24 Feb 2012)
+
+ 24 Feb 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-4.5.0.1.ebuild, files/shorewall.initd:
+ Version Bump
23 Jan 2012; Tobias Klausmann <klausman@gentoo.org>
shorewall-4.4.23.2.ebuild:
diff --git a/net-firewall/shorewall/files/shorewall.initd b/net-firewall/shorewall/files/shorewall.initd
index ca60f9ead7e9..66ba391823d2 100644
--- a/net-firewall/shorewall/files/shorewall.initd
+++ b/net-firewall/shorewall/files/shorewall.initd
@@ -1,9 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.1 2009/10/09 12:22:43 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.2 2012/02/24 18:51:52 constanze Exp $
-opts="start stop restart clear reset refresh check"
+extra_commands="check clear"
+extra_started_commands="refresh reset"
depend() {
need net
diff --git a/net-firewall/shorewall/shorewall-4.5.0.1.ebuild b/net-firewall/shorewall/shorewall-4.5.0.1.ebuild
new file mode 100644
index 000000000000..d14f7930d7e1
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.5.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.5.0.1.ebuild,v 1.1 2012/02/24 18:51:52 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}"
+MY_P_DOCS="${P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ >=net-firewall/shorewall-core-${MY_PV_BASE}"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}
+
+pkg_postinst() {
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+}