summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-09 16:10:00 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-09 16:10:00 +0000
commit0c870cb780947a691682c544ee1904afc3adc2cd (patch)
tree09c6aed6e3a46959b12bf02cdb7e3485f36f05fd /net-firewall
parentAdd missing DEPEND on dev-java/ant-contrib. Fixes bug #177814. (diff)
downloadgentoo-2-0c870cb780947a691682c544ee1904afc3adc2cd.tar.gz
gentoo-2-0c870cb780947a691682c544ee1904afc3adc2cd.tar.bz2
gentoo-2-0c870cb780947a691682c544ee1904afc3adc2cd.zip
Fix Makefile for non bash shells.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog6
-rw-r--r--net-firewall/iptables/files/iptables-1.3.7-test-dir.patch15
-rw-r--r--net-firewall/iptables/iptables-1.3.7.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 17e78d4d75cd..2dcf154ea9fc 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.132 2007/05/06 09:54:40 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.133 2007/05/09 16:10:00 uberlord Exp $
+
+ 09 May 2007; Roy Marples <uberlord@gentoo.org>
+ +files/iptables-1.3.7-test-dir.patch, iptables-1.3.7.ebuild:
+ Fix Makefile for non bash shells.
06 May 2007; Marius Mauch <genone@gentoo.org> iptables-1.3.5-r4.ebuild,
iptables-1.3.6.ebuild, iptables-1.3.6-r1.ebuild, iptables-1.3.7.ebuild:
diff --git a/net-firewall/iptables/files/iptables-1.3.7-test-dir.patch b/net-firewall/iptables/files/iptables-1.3.7-test-dir.patch
new file mode 100644
index 000000000000..f9e4b010796b
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.3.7-test-dir.patch
@@ -0,0 +1,15 @@
+-a isn't a valid test here, god knows why bash allows it
+
+http://bugzilla.netfilter.org/bugzilla/show_bug.cgi?id=569
+
+--- Makefile.orig 2007-05-09 16:44:59.000000000 +0100
++++ Makefile 2007-05-09 16:45:06.000000000 +0100
+@@ -79,7 +79,7 @@
+ # Generic test if arch wasn't found above
+ ifneq ($(POINTERTEST),1)
+ # Try to determine if kernel is 64bit and we are compiling for 32bit
+- ifeq ($(shell [ -a $(KERNEL_DIR)/include/asm ] && echo YES), YES)
++ ifeq ($(shell [ -d $(KERNEL_DIR)/include/asm ] && echo YES), YES)
+ 64bitkernel := $(shell echo -e "\#include <asm/types.h>\n\#if BITS_PER_LONG == 64\nkernel_is_64bits\n\#endif" | $(CC) $(CFLAGS) -D__KERNEL__ -E - | grep kernel_is_64bits)
+ ifdef 64bitkernel
+ 32bituser := $(shell echo -e "\#include <stdio.h>\n\#if !defined(__arch64__) && !defined(_LP64)\nuserspace_is_32bit\n\#endif" | $(CC) $(CFLAGS) -E - | grep userspace_is_32bit)
diff --git a/net-firewall/iptables/iptables-1.3.7.ebuild b/net-firewall/iptables/iptables-1.3.7.ebuild
index 4f2718cbf14c..d214f05cdc27 100644
--- a/net-firewall/iptables/iptables-1.3.7.ebuild
+++ b/net-firewall/iptables/iptables-1.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.7.ebuild,v 1.8 2007/05/06 09:54:40 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.7.ebuild,v 1.9 2007/05/09 16:10:00 uberlord Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -58,6 +58,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-more-exact-check-grep.patch #159162
epatch "${FILESDIR}"/${P}-sparc64.patch #166201
epatch "${FILESDIR}"/${P}-kernel-dir.patch #172209
+ epatch "${FILESDIR}"/${P}-test-dir.patch # Find include/asm without bash
EPATCH_OPTS="-p0" \
epatch "${FILESDIR}"/1.3.1-files/install_ipv6_apps.patch