summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-03-14 19:08:05 +0000
committerPeter Johanson <latexer@gentoo.org>2005-03-14 19:08:05 +0000
commit66438ec992b7614410b4888e4f2f7454af807a6b (patch)
treec8757ac3a6453aa2e7502ff23d61dd9e112aec4d /net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild
parentVersion bump. Closing bug #78472. (diff)
downloadgentoo-2-66438ec992b7614410b4888e4f2f7454af807a6b.tar.gz
gentoo-2-66438ec992b7614410b4888e4f2f7454af807a6b.tar.bz2
gentoo-2-66438ec992b7614410b4888e4f2f7454af807a6b.zip
Security bump for buffer underrun. See bug #84479.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild')
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild
new file mode 100644
index 000000000000..515456662058
--- /dev/null
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.5-r1.ebuild,v 1.1 2005/03/14 19:08:05 latexer Exp $
+
+inherit eutils flag-o-matic
+
+MY_P=${P/_/-}
+
+DESCRIPTION="IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."
+HOMEPAGE="http://ipsec-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="ipv6 selinux"
+S=${WORKDIR}/${MY_P}
+DEPEND="virtual/libc
+ || ( >=sys-kernel/linux-headers-2.6 sys-kernel/linux26-headers )
+ >=dev-libs/openssl-0.9.6"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-ipsec-tools )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:#include <sys/sysctl.h>::' src/racoon/pfkey.c src/setkey/setkey.c
+ epatch ${FILESDIR}/${P}-isakmp-underrun.diff || die "epatch failed!"
+ epunt_cxx
+}
+
+src_compile() {
+ # Filter the c3 flag for now. Probably a GCC problem, but we'll
+ # avoid it here for now. See bug #61025
+ filter-flags -march=c3
+
+ econf \
+ --enable-hybrid \
+ --enable-dpd \
+ --enable-natt \
+ --enable-adminport \
+ --enable-frag \
+ $(use_enable ipv6) \
+ || die
+ # Removed due to some problems
+ # --enable-samode-unspec \
+ emake -j1 || die
+}
+
+src_install() {
+ einstall || die
+ keepdir /var/lib/racoon
+ insinto /etc/conf.d && newins ${FILESDIR}/racoon.conf.d racoon
+ exeinto /etc/init.d && newexe ${FILESDIR}/racoon.init.d racoon
+
+ dodoc ChangeLog README NEWS
+ dodoc ${S}/src/racoon/samples/racoon.conf.sample*
+}