summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-02-01 11:35:28 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-02-01 11:35:28 +0000
commitec09341f60fb2910b1af5d2a2323642ee451a7b6 (patch)
tree76a2e9c1019dabbf530dc71485d1c7061272d27b /net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild
parentBump to mips stable (needed for upcoming stageballs) (Manifest recommit) (diff)
downloadgentoo-2-ec09341f60fb2910b1af5d2a2323642ee451a7b6.tar.gz
gentoo-2-ec09341f60fb2910b1af5d2a2323642ee451a7b6.tar.bz2
gentoo-2-ec09341f60fb2910b1af5d2a2323642ee451a7b6.zip
Added metadata, bumped versions, and changed the configure scripts to use /usr/src/... rather than the running kernel for includes. Closes bug #38807.
Diffstat (limited to 'net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild')
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild
new file mode 100644
index 000000000000..7f622982d645
--- /dev/null
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.2.3.ebuild,v 1.1 2004/02/01 11:35:28 plasmaroo Exp $
+
+DESCRIPTION="IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."
+HOMEPAGE="http://ipsec-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+DEPEND="virtual/glibc
+ >=dev-libs/openssl-0.9.6"
+
+pkg_setup() {
+ my_KV=`echo ${KV} | cut -f-2 -d "."`
+ if [ ${my_KV} != "2.6" ] ; then
+ echo; eerror "You need a 2.6.x kernel to use the ipsec tools!"; die "You need a 2.6 kernel to use ipsec-tools!"
+ fi
+}
+
+src_compile() {
+ unset CC
+ ./bootstrap
+ ./configure --prefix=/usr --sysconfdir=/etc --with-kernel-headers=/usr/src/linux/include || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog README NEWS
+ insinto /etc && doins ${FILESDIR}/ipsec.conf.sample
+ insinto /etc/conf.d && newins ${FILESDIR}/racoon.conf.d racoon
+ exeinto /etc/init.d && newexe ${FILESDIR}/racoon.init.d racoon
+}