summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-06-01 23:06:31 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-06-01 23:06:31 +0000
commitdb92d1fddb1aefa9a1b3a00acbccacc3ec0147be (patch)
tree391c18bb64b4f7f7ab6e7152b657c26259834bbb /net-dns
parentVersion bumped. (diff)
downloadgentoo-2-db92d1fddb1aefa9a1b3a00acbccacc3ec0147be.tar.gz
gentoo-2-db92d1fddb1aefa9a1b3a00acbccacc3ec0147be.tar.bz2
gentoo-2-db92d1fddb1aefa9a1b3a00acbccacc3ec0147be.zip
Version bumped. Respect CFLAGS="-O?", bug #369339.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ldns-utils/ChangeLog8
-rw-r--r--net-dns/ldns-utils/files/1.6.10-cflags.patch24
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.6.10.ebuild61
3 files changed, 92 insertions, 1 deletions
diff --git a/net-dns/ldns-utils/ChangeLog b/net-dns/ldns-utils/ChangeLog
index 3592d9f1d96e..3b3fdbca543c 100644
--- a/net-dns/ldns-utils/ChangeLog
+++ b/net-dns/ldns-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/ldns-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.8 2011/03/26 03:03:28 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.9 2011/06/01 23:06:31 matsuu Exp $
+
+*ldns-utils-1.6.10 (01 Jun 2011)
+
+ 01 Jun 2011; MATSUU Takuto <matsuu@gentoo.org> +files/1.6.10-cflags.patch,
+ +ldns-utils-1.6.10.ebuild:
+ Version bumped. Respect CFLAGS="-O?", bug #369339. Removed old versions.
*ldns-utils-1.6.9 (26 Mar 2011)
diff --git a/net-dns/ldns-utils/files/1.6.10-cflags.patch b/net-dns/ldns-utils/files/1.6.10-cflags.patch
new file mode 100644
index 000000000000..baa3e7a82b33
--- /dev/null
+++ b/net-dns/ldns-utils/files/1.6.10-cflags.patch
@@ -0,0 +1,24 @@
+diff -Naur ldns-1.6.10.orig/drill/configure.ac ldns-1.6.10/drill/configure.ac
+--- ldns-1.6.10.orig/drill/configure.ac 2011-03-14 21:43:56.000000000 +0900
++++ ldns-1.6.10/drill/configure.ac 2011-06-01 17:45:30.391357378 +0900
+@@ -33,7 +33,7 @@
+ ACX_CHECK_COMPILER_FLAG(xc99, [C99FLAG="-xc99"])
+
+ AC_TYPE_SIZE_T
+-ACX_CHECK_COMPILER_FLAG(O2, [CFLAGS="$CFLAGS -O2"])
++ACX_CHECK_COMPILER_FLAG(O2, [CFLAGS="-O2 $CFLAGS"])
+
+ ACX_CHECK_COMPILER_FLAG_NEEDED($C99FLAG -D__EXTENSIONS__ -D_BSD_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600,
+ [
+diff -Naur ldns-1.6.10.orig/examples/configure.ac ldns-1.6.10/examples/configure.ac
+--- ldns-1.6.10.orig/examples/configure.ac 2011-03-14 21:43:56.000000000 +0900
++++ ldns-1.6.10/examples/configure.ac 2011-06-01 17:45:29.662354668 +0900
+@@ -31,7 +31,7 @@
+
+
+ AC_TYPE_SIZE_T
+-ACX_CHECK_COMPILER_FLAG(O2, [CFLAGS="$CFLAGS -O2"])
++ACX_CHECK_COMPILER_FLAG(O2, [CFLAGS="-O2 $CFLAGS"])
+
+ ACX_CHECK_COMPILER_FLAG_NEEDED($C99FLAG -D__EXTENSIONS__ -D_BSD_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600,
+ [
diff --git a/net-dns/ldns-utils/ldns-utils-1.6.10.ebuild b/net-dns/ldns-utils/ldns-utils-1.6.10.ebuild
new file mode 100644
index 000000000000..ea12affcd641
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.6.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ldns-utils-1.6.10.ebuild,v 1.1 2011/06/01 23:06:31 matsuu Exp $
+
+EAPI="3"
+inherit autotools eutils
+
+MY_P="${P/-utils}"
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks."
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples gost ssl"
+
+DEPEND=">=net-libs/ldns-${PV}[gost?,ssl?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug #369339
+ epatch "${FILESDIR}/${PV}-cflags.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/drill
+ econf $(use_with ssl) || die
+
+ if use examples; then
+ cd "${S}"/examples
+ econf \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) || die
+ fi
+}
+
+src_compile() {
+ emake -C drill || die "emake for drill failed"
+ if use examples; then
+ emake -C examples || die "emake for examples failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"/drill
+ emake DESTDIR="${D}" install || die "emake install for drill failed"
+ dodoc ChangeLog.22-nov-2005 README REGRESSIONS || die
+
+ if use examples; then
+ cd "${S}"/examples
+ emake DESTDIR="${D}" install || die "emake install for examples failed"
+ newdoc README README.examples || die
+ fi
+}