summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-09-13 15:14:49 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-09-13 15:14:49 +0000
commitcf10221646f4466683e6ac3fb702ea821b705f8f (patch)
treee1a44da40395d3ed28480efd76cff1b365d8b25f /net-dns
parentMask the latest nvidia-drivers package (diff)
downloadgentoo-2-cf10221646f4466683e6ac3fb702ea821b705f8f.tar.gz
gentoo-2-cf10221646f4466683e6ac3fb702ea821b705f8f.tar.bz2
gentoo-2-cf10221646f4466683e6ac3fb702ea821b705f8f.zip
Fixed python modules handling. The patch was submitted by Tom Hendrikx, bug #378395. Removed oknodo from unbound.initd, bug #379947.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog9
-rw-r--r--net-dns/unbound/files/unbound.initd33
-rw-r--r--net-dns/unbound/unbound-1.4.12-r1.ebuild108
3 files changed, 135 insertions, 15 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index f2a75b084a6f..c94c154bb958 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.28 2011/07/16 03:52:59 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.29 2011/09/13 15:14:49 matsuu Exp $
+
+*unbound-1.4.12-r1 (13 Sep 2011)
+
+ 13 Sep 2011; MATSUU Takuto <matsuu@gentoo.org> +unbound-1.4.12-r1.ebuild,
+ files/unbound.initd:
+ Fixed python modules handling. The patch was submitted by Tom Hendrikx, bug
+ #378395. Removed oknodo from unbound.initd, bug #379947.
16 Jul 2011; MATSUU Takuto <matsuu@gentoo.org>
+files/unbound-1.4.12-gentoo.patch:
diff --git a/net-dns/unbound/files/unbound.initd b/net-dns/unbound/files/unbound.initd
index e9e902c9b9cb..90deb23e4ac8 100644
--- a/net-dns/unbound/files/unbound.initd
+++ b/net-dns/unbound/files/unbound.initd
@@ -1,9 +1,15 @@
#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/files/unbound.initd,v 1.1 2009/11/22 16:57:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/files/unbound.initd,v 1.2 2011/09/13 15:14:49 matsuu Exp $
+
+name="unbound daemon"
+extra_commands="configtest"
+extra_started_commands="reload"
+description="unbound is a Domain Name Server (DNS) that is used to resolve host names to IP address."
+description_configtest="Run syntax tests for configuration files only."
+description_reload="Kills all children and reloads the configuration."
-opts="${opts} checkconfig reload"
UNBOUND_BINARY=${UNBOUND_BINARY:-/usr/sbin/unbound}
UNBOUND_CHECKCONF=${UNBOUND_CHECKCONF:-/usr/sbin/unbound-checkconf}
@@ -21,9 +27,15 @@ checkconfig() {
return $?
}
+configtest() {
+ ebegin "Checking ${SVCNAME} configuration"
+ checkconfig
+ eend $?
+}
+
start() {
checkconfig || return $?
- ebegin "Starting unbound"
+ ebegin "Starting ${SVCNAME}"
start-stop-daemon --start --pidfile "${UNBOUND_PIDFILE}" \
--exec "${UNBOUND_BINARY}" -- -c "${UNBOUND_CONFFILE}"
eend $?
@@ -31,21 +43,14 @@ start() {
stop() {
checkconfig || return $?
- ebegin "Stopping unbound"
+ ebegin "Stopping ${SVCNAME}"
start-stop-daemon --stop --pidfile "${UNBOUND_PIDFILE}"
eend $?
}
-restart() {
- checkconfig || return $?
- svc_stop
- svc_start
-}
-
reload() {
checkconfig || return $?
- ebegin "Reloading unbound"
- start-stop-daemon --stop --pidfile "${UNBOUND_PIDFILE}" \
- --signal HUP --oknodo
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile "${UNBOUND_PIDFILE}"
eend $?
}
diff --git a/net-dns/unbound/unbound-1.4.12-r1.ebuild b/net-dns/unbound/unbound-1.4.12-r1.ebuild
new file mode 100644
index 000000000000..5c26ec60257e
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.12-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.12-r1.ebuild,v 1.1 2011/09/13 15:14:49 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils flag-o-matic python
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="debug gost python static-libs test threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libevent
+ >=dev-libs/openssl-0.9.8
+ >=net-libs/ldns-1.6.5[ssl,gost?]"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+ net-dns/dnssec-root"
+
+pkg_setup() {
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # To avoid below error messages, set 'trust-anchor-file' to same value in
+ # 'auto-trust-anchor-file'.
+ # [23109:0] error: Could not open autotrust file for writing, # /etc/dnssec/root-anchors.txt: Permission denied
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack || die
+ econf \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
+ $(use_enable debug) \
+ $(use_enable gost) \
+ $(use_enable static-libs static) \
+ $(use_with threads pthreads) \
+ $(use_with python pyunbound) \
+ $(use_with python pythonmodule) \
+ --disable-rpath || die
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # bug #299016
+ if use python ; then
+ find "${ED}" -name '_unbound.{la,a}' -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
+ newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+
+ # bug #315519
+ #exeinto /usr/libexec/munin/plugins
+ #doexe contrib/unbound_munin_ || die "doexe failed"
+ dodoc contrib/unbound_munin_ || die "dodoc failed"
+
+ docinto selinux
+ dodoc contrib/selinux/* || die "dodoc failed"
+
+ exeinto /usr/share/${PN}
+ doexe contrib/update-anchor.sh || die "doexe failed"
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize unbound.py unboundmodule.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup unbound.py unboundmodule.py
+}