summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-06-19 23:21:44 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-06-19 23:21:44 +0000
commitcdb9570e4cf8b99504fa121c0bc0ed7601709bb0 (patch)
tree0c3658feaf2eaf88248ad180df113ea0d8035e38 /net-dns
parentVersion bumped, bug #418365. Added USE=ecdsa. Removed examples USE flag, bug ... (diff)
downloadgentoo-2-cdb9570e4cf8b99504fa121c0bc0ed7601709bb0.tar.gz
gentoo-2-cdb9570e4cf8b99504fa121c0bc0ed7601709bb0.tar.bz2
gentoo-2-cdb9570e4cf8b99504fa121c0bc0ed7601709bb0.zip
Version bumped.
(Portage version: 2.1.10.54/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ldns-utils/ChangeLog7
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.6.13.ebuild63
-rw-r--r--net-dns/ldns-utils/metadata.xml1
3 files changed, 70 insertions, 1 deletions
diff --git a/net-dns/ldns-utils/ChangeLog b/net-dns/ldns-utils/ChangeLog
index 3286f6c9229a..c70e3f356980 100644
--- a/net-dns/ldns-utils/ChangeLog
+++ b/net-dns/ldns-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ldns-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.15 2012/05/21 09:54:51 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.16 2012/06/19 23:21:44 matsuu Exp $
+
+*ldns-utils-1.6.13 (19 Jun 2012)
+
+ 19 Jun 2012; MATSUU Takuto <matsuu@gentoo.org> +ldns-utils-1.6.13.ebuild:
+ Version bumped.
21 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
ldns-utils-1.6.12.ebuild:
diff --git a/net-dns/ldns-utils/ldns-utils-1.6.13.ebuild b/net-dns/ldns-utils/ldns-utils-1.6.13.ebuild
new file mode 100644
index 000000000000..0e3c9a671916
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.6.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ldns-utils-1.6.13.ebuild,v 1.1 2012/06/19 23:21:44 matsuu Exp $
+
+EAPI="3"
+inherit autotools eutils
+
+MY_P="${P/-utils}"
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks."
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ecdsa examples gost ssl"
+
+DEPEND=">=net-libs/ldns-${PV}[ecdsa?,gost?,ssl?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug #369339
+ epatch "${FILESDIR}/1.6.12-cflags.patch"
+
+ ( cd drill && eautoreconf )
+ ( cd examples && eautoreconf )
+}
+
+src_configure() {
+ cd "${S}"/drill
+ econf $(use_with ssl) || die
+
+ if use examples; then
+ cd "${S}"/examples
+ econf \
+ $(use_enable ecdsa) \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) || die
+ fi
+}
+
+src_compile() {
+ emake -C drill || die "emake for drill failed"
+ if use examples; then
+ emake -C examples || die "emake for examples failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"/drill
+ emake DESTDIR="${D}" install || die "emake install for drill failed"
+ dodoc ChangeLog.22-nov-2005 README REGRESSIONS || die
+
+ if use examples; then
+ cd "${S}"/examples
+ emake DESTDIR="${D}" install || die "emake install for examples failed"
+ newdoc README README.examples || die
+ fi
+}
diff --git a/net-dns/ldns-utils/metadata.xml b/net-dns/ldns-utils/metadata.xml
index 09f6bf435917..cb94a7e24c82 100644
--- a/net-dns/ldns-utils/metadata.xml
+++ b/net-dns/ldns-utils/metadata.xml
@@ -12,5 +12,6 @@ packets.
</longdescription>
<use>
<flag name='gost'>Enable GOST support</flag>
+ <flag name='ecdsa'>Enable ECDSA support</flag>
</use>
</pkgmetadata>