summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-15 22:05:38 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-15 22:05:38 +0000
commit01745e328c9bde830e85eb8e9a3f29fb762d35c9 (patch)
tree878cba051f4c96e390df4e2dfda3cb0f42366486 /net-dns
parentFix for the kde4 patches, thanks ssuominen for spying on my commits (diff)
downloadgentoo-2-01745e328c9bde830e85eb8e9a3f29fb762d35c9.tar.gz
gentoo-2-01745e328c9bde830e85eb8e9a3f29fb762d35c9.tar.bz2
gentoo-2-01745e328c9bde830e85eb8e9a3f29fb762d35c9.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/libidn/ChangeLog7
-rw-r--r--net-dns/libidn/libidn-1.18.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/net-dns/libidn/ChangeLog b/net-dns/libidn/ChangeLog
index e12bda64edb7..7d0c7b50a765 100644
--- a/net-dns/libidn/ChangeLog
+++ b/net-dns/libidn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/libidn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.116 2010/01/14 04:01:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.117 2010/02/15 22:05:38 jer Exp $
+
+*libidn-1.18 (15 Feb 2010)
+
+ 15 Feb 2010; Jeroen Roovers <jer@gentoo.org> +libidn-1.18.ebuild:
+ Version bump.
*libidn-1.16 (14 Jan 2010)
diff --git a/net-dns/libidn/libidn-1.18.ebuild b/net-dns/libidn/libidn-1.18.ebuild
new file mode 100644
index 000000000000..a80d13153bee
--- /dev/null
+++ b/net-dns/libidn/libidn-1.18.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/libidn-1.18.ebuild,v 1.1 2010/02/15 22:05:38 jer Exp $
+
+inherit java-pkg-opt-2 mono elisp-common
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="http://www.gnu.org/software/libidn/"
+SRC_URI="mirror://gnu/libidn/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc emacs java mono nls"
+
+COMMON_DEPEND="emacs? ( virtual/emacs )
+ mono? ( >=dev-lang/mono-0.95 )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( >=sys-devel/gettext-0.17 )
+ java? ( >=virtual/jdk-1.4 dev-java/gjdoc )"
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )
+ java? ( >=virtual/jre-1.4 )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ # bundled, with wrong bytecode
+ rm "${S}/java/${P}.jar" || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable java) \
+ $(use_enable mono csharp mono) \
+ --with-lispdir="${SITELISP}/${PN}" \
+ --with-packager="Gentoo" \
+ --with-packager-version="r${PR}" \
+ --with-packager-bug-reports="https://bugs.gentoo.org" \
+ || die
+
+ emake || die
+
+ if use emacs; then
+ elisp-compile src/*.el || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO || die
+
+ if use emacs; then
+ # *.el are installed by the build system
+ elisp-install ${PN} src/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ else
+ rm -rf "${D}/usr/share/emacs"
+ fi
+
+ if use doc ; then
+ dohtml -r doc/reference/html/* || die
+ fi
+
+ if use java ; then
+ java-pkg_newjar java/${P}.jar ${PN}.jar || die
+ rm -rf "${D}"/usr/share/java || die
+
+ if use doc ; then
+ java-pkg_dojavadoc doc/java
+ fi
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}