summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-04-19 19:57:41 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-04-19 19:57:41 +0000
commit49a33d515830dfa30b0b9731c41d2431a3c642a5 (patch)
tree7c66bab542fa096de17b3d1d08523a36afc4cf58 /net-dns/bind
parentbug 14467, unstable to see if we like it (diff)
downloadgentoo-2-49a33d515830dfa30b0b9731c41d2431a3c642a5.tar.gz
gentoo-2-49a33d515830dfa30b0b9731c41d2431a3c642a5.tar.bz2
gentoo-2-49a33d515830dfa30b0b9731c41d2431a3c642a5.zip
bug 14467, unstable to see if we like it
Diffstat (limited to 'net-dns/bind')
-rw-r--r--net-dns/bind/ChangeLog9
-rw-r--r--net-dns/bind/Manifest4
-rw-r--r--net-dns/bind/bind-9.2.2-r1.ebuild153
-rw-r--r--net-dns/bind/files/127.zone11
-rw-r--r--net-dns/bind/files/digest-bind-9.2.2-r11
-rw-r--r--net-dns/bind/files/localhost.zone9
-rw-r--r--net-dns/bind/files/named.conf-r242
7 files changed, 226 insertions, 3 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index 29c497b8ee45..91196ffce9e3 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/bind
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.24 2003/04/15 14:44:57 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.25 2003/04/19 19:57:36 lostlogic Exp $
+
+*bind-9.2.2-r1 (19 Apr 2003)
+
+ 19 Apr 2003; Brandon Low <lostlogic@gentoo.org> bind-9.2.2-r1.ebuild,
+ files/127.zone, files/localhost.zone, files/named.conf-r2:
+ Fix bug 14467 WRT to .zone extension for zone files. Also keepdir dirs that
+ need to be kept.
*bind-9.2.2 (04 Mar 2003)
diff --git a/net-dns/bind/Manifest b/net-dns/bind/Manifest
index 49582699fc79..83b22ea4b0d9 100644
--- a/net-dns/bind/Manifest
+++ b/net-dns/bind/Manifest
@@ -1,7 +1,7 @@
MD5 20542079b97eb62c2bf449ae44361cc4 bind-9.2.2.ebuild 4584
MD5 f2878b39d022399c9bc5a7eb63763651 bind-9.2.2_rc1-r2.ebuild 4496
-MD5 6375c1cec75e54d9b00e350314fac290 ChangeLog 5051
-MD5 7c1915a3b8b3c1d66ee757aff76ae1b1 bind-9.2.2-r1.ebuild 4792
+MD5 da6cf4036946ba0187693804841af672 ChangeLog 5053
+MD5 d3586eddb838e4392e13d0b2ee4ba5e4 bind-9.2.2-r1.ebuild 4797
MD5 51197afe8da37b1b453456de90ca4f25 files/127 227
MD5 e020f0d41f68e0c47d196c4aa1a06c09 files/digest-bind-9.2.2-r1 63
MD5 e020f0d41f68e0c47d196c4aa1a06c09 files/digest-bind-9.2.2 63
diff --git a/net-dns/bind/bind-9.2.2-r1.ebuild b/net-dns/bind/bind-9.2.2-r1.ebuild
new file mode 100644
index 000000000000..73b56a24caaf
--- /dev/null
+++ b/net-dns/bind/bind-9.2.2-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r1.ebuild,v 1.1 2003/04/19 19:57:36 lostlogic Exp $
+
+IUSE="ssl ipv6 doc"
+
+DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="sys-apps/groff
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+
+ # Adjusting PATHs in manpages
+ for i in `echo bin/{named/named.8,check/named-checkconf.8,nsupdate/nsupdate.8,rndc/rndc.8}`; do
+ sed -i -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ ${i}
+ done
+}
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+
+ econf --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --enable-threads \
+ --with-libtool \
+ ${myconf}
+
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "failed to compile bind"
+}
+
+src_install() {
+ einstall || die "failed to install bind"
+
+ dodoc CHANGES COPYRIGHT FAQ README
+
+ use doc && {
+ docinto misc ; dodoc doc/misc/*
+ docinto html ; dodoc doc/arm/*
+ docinto draft ; dodoc doc/draft/*
+ docinto rfc ; dodoc doc/rfc/*
+ docinto contrib ; dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl
+ }
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/10bind.env 10bind
+
+ # some handy-dandy dynamic dns examples
+ cd ${D}/usr/share/doc/${PF}
+ tar pjxf ${FILESDIR}/dyndns-samples.tbz2
+
+ dodir /etc/bind /var/bind/{pri,sec}
+ keepdir /var/bind/sec
+
+ insinto /etc/bind ; newins ${FILESDIR}/named.conf-r2 named.conf
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind ; doins ${FILESDIR}/named.ca
+ insinto /var/bind/pri ; doins ${FILESDIR}/{127,localhost}.zone
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/named.rc6 named
+ insinto /etc/conf.d ; newins ${FILESDIR}/named.confd named
+
+ dosym ../../var/bind/named.ca /var/bind/root.cache
+ dosym ../../var/bind/pri /etc/bind/pri
+ dosym ../../var/bind/sec /etc/bind/sec
+}
+
+pkg_preinst() {
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f ${D}/usr/share/man/man1/{dig.1.gz,host.1.gz}
+ rm -f ${D}/usr/bin/{dig,host,nslookup}
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ /usr/sbin/rndc-confgen -a -u named
+ fi
+
+ install -d -o named -g named ${ROOT}/var/run/named \
+ ${ROOT}/var/bind/pri ${ROOT}/var/bind/sec
+ chown -R named:named ${ROOT}/var/bind
+
+ einfo "The default zone files are now installed as *.zone,"
+ einfo "be careful merging config files if you have modified"
+ einfo "/var/bind/pri/127 or /var/bind/pri/localhost"
+ einfo
+ einfo "You can edit /etc/conf.d/named to customize named settings"
+ einfo
+ einfo "The BIND ebuild now includes chroot support."
+ einfo "If you like to run bind in chroot AND this is a new install OR"
+ einfo "your bind doesn't already run in chroot, simply run:"
+ einfo "\`ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\`"
+ einfo "Before running the above command you might want to change the chroot"
+ einfo "dir in /etc/conf.d/named. Otherwise /chroot/dns will be used."
+ einfo
+}
+
+pkg_config() {
+
+ CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/named 2>/dev/null`
+ EXISTS="no"
+
+ if [ -z "${CHROOT}" -a ! -d "/chroot/dns" ]; then
+ CHROOT="/chroot/dns"
+ elif [ -d ${CHROOT} ]; then
+ eerror; eerror "${CHROOT:-/chroot/dns} already exists. Quitting."; eerror; EXISTS="yes"
+ fi
+
+ if [ ! "$EXISTS" = yes ]; then
+ einfo ; einfon "Setting up the chroot directory..."
+ mkdir -m 700 -p ${CHROOT}
+ mkdir -p ${CHROOT}/{dev,etc,var/run/named}
+ chown -R named:named ${CHROOT}/var/run/named
+ cp -R /etc/bind ${CHROOT}/etc/
+ cp /etc/localtime ${CHROOT}/etc/localtime
+ chown named:named ${CHROOT}/etc/bind/rndc.key
+ cp -R /var/bind ${CHROOT}/var/
+ chown -R named:named ${CHROOT}/var/
+ mknod ${CHROOT}/dev/zero c 1 5
+ mknod ${CHROOT}/dev/random c 1 8
+ chmod 666 ${CHROOT}/dev/{random,zero}
+ chown named:named ${CHROOT}
+
+ grep -q "^#[[:blank:]]\?CHROOT" /etc/conf.d/named ; RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ sed 's/^# \?\(CHROOT.*\)$/\1/' /etc/conf.d/named > /etc/conf.d/named.orig 2>/dev/null
+ mv --force /etc/conf.d/named.orig /etc/conf.d/named
+ fi
+
+ sleep 1; echo " Done."; sleep 1
+ einfo
+ einfo "Add the following to your root .bashrc or .bash_profile: "
+ einfo " alias rndc='rndc -k ${CHROOT}/etc/bind/rndc.key'"
+ einfo "Then do the following: "
+ einfo " source /root/.bashrc or .bash_profile"
+ einfo
+ fi
+}
diff --git a/net-dns/bind/files/127.zone b/net-dns/bind/files/127.zone
new file mode 100644
index 000000000000..eeb2af97c524
--- /dev/null
+++ b/net-dns/bind/files/127.zone
@@ -0,0 +1,11 @@
+$ORIGIN 127.in-addr.arpa.
+$TTL 1W
+@ 1D IN SOA localhost. root.localhost. (
+ 2002081601 ; serial
+ 3H ; refresh
+ 15M ; retry
+ 1W ; expiry
+ 1D ) ; minimum
+
+ 1D IN NS localhost.
+* 1D IN PTR localhost.
diff --git a/net-dns/bind/files/digest-bind-9.2.2-r1 b/net-dns/bind/files/digest-bind-9.2.2-r1
new file mode 100644
index 000000000000..a11f05a79883
--- /dev/null
+++ b/net-dns/bind/files/digest-bind-9.2.2-r1
@@ -0,0 +1 @@
+MD5 6ea7d64a0856893ab3eb541ab7bbc725 bind-9.2.2.tar.gz 5054652
diff --git a/net-dns/bind/files/localhost.zone b/net-dns/bind/files/localhost.zone
new file mode 100644
index 000000000000..44dff11c69f3
--- /dev/null
+++ b/net-dns/bind/files/localhost.zone
@@ -0,0 +1,9 @@
+$TTL 1W
+@ IN SOA ns.localhost. root.localhost. (
+ 2002081601 ; Serial
+ 28800 ; Refresh
+ 14400 ; Retry
+ 604800 ; Expire - 1 week
+ 86400 ) ; Minimum
+ IN NS ns
+localhost. IN A 127.0.0.1
diff --git a/net-dns/bind/files/named.conf-r2 b/net-dns/bind/files/named.conf-r2
new file mode 100644
index 000000000000..8c62ee9613de
--- /dev/null
+++ b/net-dns/bind/files/named.conf-r2
@@ -0,0 +1,42 @@
+options {
+ directory "/var/bind";
+
+ // uncomment the following lines to turn on DNS forwarding,
+ // and change the forwarind ip address(es) :
+ //forward first;
+ //forwarders {
+ // 123.123.123.123
+ // 123,123.123.123;
+ //};
+
+ listen-on-v6 { none; };
+ listen-on { 127.0.0.1; };
+
+ // to allow only specific hosts to use the DNS server:
+ //allow-query {
+ // 127.0.0.1;
+ //};
+
+ // if you have problems and are behind a firewall:
+ //query-source address * port 53;
+ pid-file "/var/run/named/named.pid";
+};
+
+zone "." IN {
+ type hint;
+ file "named.ca";
+};
+
+zone "localhost" IN {
+ type master;
+ file "pri/localhost.zone";
+ allow-update { none; };
+ notify no;
+};
+
+zone "127.in-addr.arpa" IN {
+ type master;
+ file "pri/127.zone";
+ allow-update { none; };
+ notify no;
+};