summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2005-06-26 10:54:54 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2005-06-26 10:54:54 +0000
commit066583f24f5851e8d6acac471783ab918322c6c0 (patch)
tree796fa0b38d569efff053aaecaa5015aa5485c9a7 /net-dialup
parentDep for hicolor-theme was missing (diff)
downloadgentoo-2-066583f24f5851e8d6acac471783ab918322c6c0.tar.gz
gentoo-2-066583f24f5851e8d6acac471783ab918322c6c0.tar.bz2
gentoo-2-066583f24f5851e8d6acac471783ab918322c6c0.zip
compile fixes for amd64 (see bug #93535)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capi4k-utils/ChangeLog6
-rw-r--r--net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild28
2 files changed, 13 insertions, 21 deletions
diff --git a/net-dialup/capi4k-utils/ChangeLog b/net-dialup/capi4k-utils/ChangeLog
index 4e28c2641745..560158ff65b8 100644
--- a/net-dialup/capi4k-utils/ChangeLog
+++ b/net-dialup/capi4k-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/capi4k-utils
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.35 2005/06/17 20:24:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.36 2005/06/26 10:54:54 sbriesen Exp $
+
+ 26 Jun 2005; Stefan Briesenick <sbriesen@gentoo.org>
+ capi4k-utils-20050509.ebuild:
+ compile fixes for amd64 (see bug #93535)
17 Jun 2005; Stefan Briesenick <sbriesen@gentoo.org>
capi4k-utils-20050509.ebuild:
diff --git a/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild b/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild
index cc9f8c4f4217..e5c52482e080 100644
--- a/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild
+++ b/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild,v 1.2 2005/06/17 20:24:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild,v 1.3 2005/06/26 10:54:54 sbriesen Exp $
-inherit multilib
+inherit multilib gnuconfig
YEAR_PV=${PV:0:4}
MON_PV=${PV:4:2}
@@ -23,10 +23,7 @@ IUSE=""
DEPEND="virtual/linux-sources
dev-lang/perl
>=sys-apps/sed-4
- virtual/os-headers
- sys-devel/automake
- >=sys-devel/autoconf-2.50
- sys-devel/libtool"
+ virtual/os-headers"
RDEPEND=""
S=${WORKDIR}/${PN}
@@ -38,10 +35,10 @@ src_unpack() {
cp -f ${FILESDIR}/config .config
# patch includes of all *.c files
sed -i -e "s:linux/capi.h>$:linux/compiler.h>\n#include <linux/capi.h>:g" */*.c || die "sed failed"
- # patch all Makefile.am and Rules.make to use our CFLAGS
- sed -i -e "s:^CFLAGS\(.*\)-O2:CFLAGS\1${CFLAGS}:g" */Makefile.* */Rules.make || die "sed failed"
- # patch capi20/Makefile.am to use -fPIC for shared library
- sed -i -e "s:^\(libcapi20_la_CFLAGS = \):\1-fPIC :g" capi20/Makefile.* || die "sed failed"
+ # patch all Makefile.* and Rules.make to use our CFLAGS
+ sed -i -e "s:^\(CFLAGS.*\)-O2:\1${CFLAGS}:g" */Makefile.* */Rules.make || die "sed failed"
+ # patch capi20/Makefile.* to use -fPIC for shared library
+ sed -i -e "s:^\(CFLAGS.*\):\1 -fPIC:g" capi20/Makefile.* || die "sed failed"
# patch pppdcapiplugin/Makefile to use only the ppp versions we want
sed -i -e "s:^\(PPPVERSIONS = \).*$:\1${PPPVERSIONS}:g" pppdcapiplugin/Makefile || die "sed failed"
# patch capiinit/capiinit.c to look also in /lib/firmware
@@ -56,16 +53,7 @@ src_unpack() {
}
src_compile() {
- # required by fPIC patch
- cd ${S}/capi20 || die "capi20 directory not found"
- ebegin "Updating autotools-generated files"
- aclocal -I . || die "aclocal failed"
- automake -a || die "automake failed"
- WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
- libtoolize -f -c || die "libtoolize failed"
- eend $?
- cd ${S}
-
+ gnuconfig_update
emake subconfig || die "make subconfig failed"
emake || die "make failed"
}