summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-01-16 10:50:38 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-01-16 10:50:38 +0000
commit3ed7bf4d47dbd78d797eb964ec1b77c251f90d1d (patch)
treed60ad2f3d0faf58a43e32e95d12aaa0347c38a5a /net-dialup/xc/xc-4.3.2-r1.ebuild
parentcleanup (Manifest recommit) (diff)
downloadgentoo-2-3ed7bf4d47dbd78d797eb964ec1b77c251f90d1d.tar.gz
gentoo-2-3ed7bf4d47dbd78d797eb964ec1b77c251f90d1d.tar.bz2
gentoo-2-3ed7bf4d47dbd78d797eb964ec1b77c251f90d1d.zip
Added a small patch which allows xc to use 115200 baud speed for serial port connections. Also tweaked the Makefile to import CFLAGS from the portage environment.
Diffstat (limited to 'net-dialup/xc/xc-4.3.2-r1.ebuild')
-rw-r--r--net-dialup/xc/xc-4.3.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dialup/xc/xc-4.3.2-r1.ebuild b/net-dialup/xc/xc-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..80d46abe0404
--- /dev/null
+++ b/net-dialup/xc/xc-4.3.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.1 2004/01/16 10:50:38 kumba Exp $
+
+DESCRIPTION="unix dialout program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~mips"
+DEPEND="sys-libs/libtermcap-compat"
+RDEPEND=""
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ # Adds 115200 bps support
+ epatch ${FILESDIR}/${P}-add-115200.patch
+
+ # Fixes the Makefile to use gentoo CFLAGS
+ mv ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s:GCCOPT\t= -pipe -O2 -fno-strength-reduce -fomit-frame-pointer:GCCOPT\t= ${CFLAGS} -fno-strength-reduce:g" \
+ ${S}/Makefile.orig > ${S}/Makefile
+}
+
+src_compile() {
+ make WARN="" all prefix=/usr mandir=/usr/share/man || die
+
+}
+
+src_install () {
+ dodir /usr/bin /usr/share/man/man1 /usr/lib/xc
+
+ make DESTDIR=${D} install || die
+
+ insinto /usr/lib/xc
+ doins phonelist xc.init dotfiles/.[a-z]*
+}