summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-03-26 09:13:06 +0000
committerAlin Năstac <mrness@gentoo.org>2006-03-26 09:13:06 +0000
commit5bedfdb3314791964e0a97c9d9e16ce1d43e99d1 (patch)
treef6e310efd41a53b8041e780e9d130cfd36983916 /net-dialup/pptpd/pptpd-1.3.1.ebuild
parentRemoved old non-working CVS ebuild, bumped to a newer CVS snapshot. Thanks t... (diff)
downloadgentoo-2-5bedfdb3314791964e0a97c9d9e16ce1d43e99d1.tar.gz
gentoo-2-5bedfdb3314791964e0a97c9d9e16ce1d43e99d1.tar.bz2
gentoo-2-5bedfdb3314791964e0a97c9d9e16ce1d43e99d1.zip
Version bump. Fix syslog flood with messages like "GRE: accepting packet" (#127388).
(Portage version: 2.0.54)
Diffstat (limited to 'net-dialup/pptpd/pptpd-1.3.1.ebuild')
-rw-r--r--net-dialup/pptpd/pptpd-1.3.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-dialup/pptpd/pptpd-1.3.1.ebuild b/net-dialup/pptpd/pptpd-1.3.1.ebuild
new file mode 100644
index 000000000000..d80e994e6626
--- /dev/null
+++ b/net-dialup/pptpd/pptpd-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.3.1.ebuild,v 1.1 2006/03/26 09:13:06 mrness Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Linux Point-to-Point Tunnelling Protocol Server"
+SRC_URI="mirror://sourceforge/poptop/${P}.tar.gz"
+HOMEPAGE="http://www.poptop.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="tcpd"
+
+DEPEND="net-dialup/ppp
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ #Match pptpd-logwtmp.so's version with pppd's version (#89895)
+ local PPPD_VER=`best_version net-dialup/ppp`
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ sed -i -e "s:\\(#define[ \\t]*VERSION[ \\t]*\\)\".*\":\\1\"${PPPD_VER}\":" "${S}/plugins/patchlevel.h"
+}
+
+src_compile() {
+ eautoreconf
+
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+ econf --with-bcrelay \
+ ${myconf} || die "configure failed"
+ emake COPTS="${CFLAGS}" || die "make failed"
+}
+
+src_install () {
+ einstall || die "make install failed"
+
+ insinto /etc
+ doins samples/pptpd.conf
+
+ insinto /etc/ppp
+ doins samples/options.pptpd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/pptpd-init" pptpd
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/pptpd-confd" pptpd
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+ docinto samples
+ dodoc samples/*
+}