summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-07-12 07:36:27 +0000
committerAlin Năstac <mrness@gentoo.org>2007-07-12 07:36:27 +0000
commite693e28949db7fb92038a36440acdb3597557e55 (patch)
treebb1976a320468b784811ecf0ea2e9e039c777161 /net-dialup/diald
parentwhitespace (diff)
downloadgentoo-2-e693e28949db7fb92038a36440acdb3597557e55.tar.gz
gentoo-2-e693e28949db7fb92038a36440acdb3597557e55.tar.bz2
gentoo-2-e693e28949db7fb92038a36440acdb3597557e55.zip
Add pam USE flag and update /etc/pam.d/diald file (#185016). Add ~amd64 keyword.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-dialup/diald')
-rw-r--r--net-dialup/diald/ChangeLog10
-rw-r--r--net-dialup/diald/diald-1.0-r2.ebuild58
-rw-r--r--net-dialup/diald/files/diald-1.0-gentoo.patch15
-rw-r--r--net-dialup/diald/files/diald-1.0-nopam.patch74
-rw-r--r--net-dialup/diald/files/digest-diald-1.0-r23
5 files changed, 157 insertions, 3 deletions
diff --git a/net-dialup/diald/ChangeLog b/net-dialup/diald/ChangeLog
index 2f8e86c9a76d..2ad62569bc5b 100644
--- a/net-dialup/diald/ChangeLog
+++ b/net-dialup/diald/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dialup/diald
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/diald/ChangeLog,v 1.11 2007/04/14 09:22:04 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/diald/ChangeLog,v 1.12 2007/07/12 07:36:27 mrness Exp $
+
+*diald-1.0-r2 (12 Jul 2007)
+
+ 12 Jul 2007; Alin Năstac <mrness@gentoo.org>
+ files/diald-1.0-gentoo.patch, +files/diald-1.0-nopam.patch,
+ +diald-1.0-r2.ebuild:
+ Add pam USE flag and update /etc/pam.d/diald file (#185016). Add ~amd64
+ keyword.
14 Apr 2007; Alin Năstac <mrness@gentoo.org>
files/diald-1.0-gentoo.patch:
diff --git a/net-dialup/diald/diald-1.0-r2.ebuild b/net-dialup/diald/diald-1.0-r2.ebuild
new file mode 100644
index 000000000000..1873c4fba63b
--- /dev/null
+++ b/net-dialup/diald/diald-1.0-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/diald/diald-1.0-r2.ebuild,v 1.1 2007/07/12 07:36:27 mrness Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Daemon that provides on demand IP links via SLIP or PPP"
+HOMEPAGE="http://diald.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam"
+
+DEPEND="pam? ( sys-libs/pam )
+ sys-apps/tcp-wrappers"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-posix.patch"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ if ! use pam; then
+ epatch "${FILESDIR}/${P}-nopam.patch"
+ cd "${S}"
+ eautoconf
+ fi
+}
+
+src_install() {
+ dodir /etc/pam.d
+ make \
+ DESTDIR="${D}" \
+ sysconfdir=/etc \
+ bindir=/usr/bin \
+ sbindir=/usr/sbin \
+ mandir=/usr/share/man \
+ libdir=/usr/lib/diald \
+ BINGRP=root \
+ ROOTUID=root \
+ ROOTGRP=root \
+ install || die "make failed"
+
+ dodir /var/cache/diald
+ mknod -m 0660 "${D}/var/cache/diald/diald.ctl" p
+
+ dodoc BUGS CHANGES LICENSE NOTES README* \
+ THANKS TODO TODO.budget doc/diald-faq.txt
+ docinto setup ; cp -pPR setup/* "${D}/usr/share/doc/${PF}/setup"
+ docinto contrib ; cp -pPR contrib/* "${D}/usr/share/doc/${PF}/contrib"
+ prepalldocs
+
+ insinto /etc/diald ; doins "${FILESDIR}"/{diald.conf,diald.filter}
+ newinitd "${FILESDIR}/diald-init" diald
+}
diff --git a/net-dialup/diald/files/diald-1.0-gentoo.patch b/net-dialup/diald/files/diald-1.0-gentoo.patch
index d932fd1888cc..541d74dc3c21 100644
--- a/net-dialup/diald/files/diald-1.0-gentoo.patch
+++ b/net-dialup/diald/files/diald-1.0-gentoo.patch
@@ -1,6 +1,17 @@
+diff -Nru diald-1.0.orig/config/diald.pam diald-1.0/config/diald.pam
+--- diald-1.0.orig/config/diald.pam 1999-10-12 00:29:43.000000000 +0300
++++ diald-1.0/config/diald.pam 2007-07-12 09:52:13.000000000 +0300
+@@ -1,4 +1,4 @@
+ #%PAM-1.0
+-auth required pam_nologin.so
+-auth required pam_pwdb.so shadow
+-account required pam_pwdb.so
++auth required pam_nologin.so
++auth include system-auth
++account include system-auth
diff -Nru diald-1.0.orig/Makefile.in diald-1.0/Makefile.in
---- diald-1.0.orig/Makefile.in 2001-06-16 14:16:04.000000000 +0300
-+++ diald-1.0/Makefile.in 2005-09-19 23:40:47.855662256 +0300
+--- diald-1.0.orig/Makefile.in 2007-07-12 09:50:22.000000000 +0300
++++ diald-1.0/Makefile.in 2007-07-12 09:44:14.000000000 +0300
@@ -21,9 +21,13 @@
mandir = @mandir@
diff --git a/net-dialup/diald/files/diald-1.0-nopam.patch b/net-dialup/diald/files/diald-1.0-nopam.patch
new file mode 100644
index 000000000000..4f21d8c849a3
--- /dev/null
+++ b/net-dialup/diald/files/diald-1.0-nopam.patch
@@ -0,0 +1,74 @@
+diff -Nru diald-1.0.orig/configure.in diald-1.0/configure.in
+--- diald-1.0.orig/configure.in 2001-06-16 19:01:25.000000000 +0300
++++ diald-1.0/configure.in 2007-07-12 09:56:35.000000000 +0300
+@@ -10,7 +10,6 @@
+ dnl Checks for libraries.
+ AC_CHECK_LIB(dl, dlsym)
+ AC_CHECK_LIB(nsl, nis_add)
+-AC_CHECK_LIB(pam, pam_start)
+ AC_CHECK_LIB(wrap, request_init)
+ AC_CHECK_LIB(util, openpty)
+
+diff -Nru diald-1.0.orig/doc/diald-control.man diald-1.0/doc/diald-control.man
+--- diald-1.0.orig/doc/diald-control.man 2001-06-15 18:38:20.000000000 +0300
++++ diald-1.0/doc/diald-control.man 2007-07-12 09:55:59.000000000 +0300
+@@ -65,10 +65,6 @@
+ TCP connections.
+ If \fI<method>\fR is "simple" then a single following
+ string specifies the name of the privileges to request.
+-If \fI<method>\fR is "pam" then the two following strings specify
+-the UNIX username and password to be authenticated using PAM
+-(Pluggable Authentication Modules). Privileges are then given
+-according to group membership.
+ .TP
+ .B block
+ Block diald from making outgoing calls until a unblock command is issued.
+diff -Nru diald-1.0.orig/doc/diald.man diald-1.0/doc/diald.man
+--- diald-1.0.orig/doc/diald.man 2001-06-15 18:38:20.000000000 +0300
++++ diald-1.0/doc/diald.man 2007-07-12 09:54:37.000000000 +0300
+@@ -184,11 +184,6 @@
+ (very simple...) for TCP monitor connections.
+
+ .TP
+-.B authpam \fI<file>\fR
+-Specifies the name of a file to be used for PAM authentication
+-(not so simple...) for TCP monitor connections.
+-
+-.TP
+ .B scheduler \fI<class>\fR
+ Set diald's scheduling class. Valid choices for systems that
+ support POSIX scheduling classes are:
+diff -Nru diald-1.0.orig/Makefile.in diald-1.0/Makefile.in
+--- diald-1.0.orig/Makefile.in 2007-07-12 09:44:14.000000000 +0300
++++ diald-1.0/Makefile.in 2007-07-12 09:54:11.000000000 +0300
+@@ -67,8 +67,6 @@
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) lib/*.gif $(DESTDIR)$(libdir)
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 config/diald.defs $(DESTDIR)$(libdir)/diald.defs
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) -m 0644 config/standard.filter $(DESTDIR)$(libdir)/standard.filter
+- $(INSTALL) -d -m 0755 $(DESTDIR)/etc/pam.d
+- $(INSTALL) -o $(ROOTUID) -g $(ROOTGRP) -m 0644 config/diald.pam $(DESTDIR)/$(sysconfdir)/pam.d/diald
+ $(INSTALL) -o $(ROOTUID) -g $(BINGRP) bin/connect $(DESTDIR)$(libdir)/connect
+
+ clean:
+diff -Nru diald-1.0.orig/README.pam diald-1.0/README.pam
+--- diald-1.0.orig/README.pam 1999-10-12 00:29:41.000000000 +0300
++++ diald-1.0/README.pam 1970-01-01 02:00:00.000000000 +0200
+@@ -1,18 +0,0 @@
+- Pluggable Authentication Modules (PAM)
+- ======================================
+-
+-Full authentication based on UNIX user names and user groups and login
+-passwords is now supported on monitor links. This is of most importance
+-to TCP monitor links which were previously very weakly protected.
+-
+-To use PAM authentication, you need to inform diald of the location of the
+-group security permissions file with the "authpam" configuration option. An
+-example security file is provided in "config/auth.pam".
+-
+-
+-*NOTE* In common with many other network password authentication systems,
+-the password is transmitted over the network in unencrypted plain text
+-format. The implications are that if your physical network is not secure, it
+-is possible for intruders to intercept your passwords. The risk can be
+-minimised by using the tcp_wrappers capability to restrict access to
+-machines on the local area network only.
diff --git a/net-dialup/diald/files/digest-diald-1.0-r2 b/net-dialup/diald/files/digest-diald-1.0-r2
new file mode 100644
index 000000000000..878db57d4da3
--- /dev/null
+++ b/net-dialup/diald/files/digest-diald-1.0-r2
@@ -0,0 +1,3 @@
+MD5 84a5aa3b8d1f12dd9e77f2b43b3d159a diald-1.0.tar.gz 199698
+RMD160 e73cb2b027ea5fa96ea9c89057a27600fe3146b9 diald-1.0.tar.gz 199698
+SHA256 dd7630811006ad0f49512de9f2fa6705e50fb475c5bb12e2dde77e198a863bd0 diald-1.0.tar.gz 199698