summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-07-25 08:26:32 +0000
committerJeroen Roovers <jer@gentoo.org>2015-07-25 08:26:32 +0000
commitfa3eb7b00c4b4c51b856a047f0a8590762aae84a (patch)
treee2c560a93ad1f4fa8abecb28eb13c4459c9ef779 /net-analyzer
parentInitial import. Ebuild updated from proaudio overlay. (diff)
downloadgentoo-2-fa3eb7b00c4b4c51b856a047f0a8590762aae84a.tar.gz
gentoo-2-fa3eb7b00c4b4c51b856a047f0a8590762aae84a.tar.bz2
gentoo-2-fa3eb7b00c4b4c51b856a047f0a8590762aae84a.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netperf/ChangeLog10
-rw-r--r--net-analyzer/netperf/files/netperf-2.7.0-includes.patch22
-rw-r--r--net-analyzer/netperf/netperf-2.7.0.ebuild64
3 files changed, 94 insertions, 2 deletions
diff --git a/net-analyzer/netperf/ChangeLog b/net-analyzer/netperf/ChangeLog
index 971e2e434a43..14b0d1eb143d 100644
--- a/net-analyzer/netperf/ChangeLog
+++ b/net-analyzer/netperf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netperf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/ChangeLog,v 1.71 2014/10/29 09:40:30 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/ChangeLog,v 1.72 2015/07/25 08:26:32 jer Exp $
+
+*netperf-2.7.0 (25 Jul 2015)
+
+ 25 Jul 2015; Jeroen Roovers <jer@gentoo.org> +netperf-2.7.0.ebuild,
+ +files/netperf-2.7.0-includes.patch:
+ Version bump.
29 Oct 2014; Jeroen Roovers <jer@gentoo.org> -netperf-2.5.0-r1.ebuild:
Old.
diff --git a/net-analyzer/netperf/files/netperf-2.7.0-includes.patch b/net-analyzer/netperf/files/netperf-2.7.0-includes.patch
new file mode 100644
index 000000000000..63c3cea40f4e
--- /dev/null
+++ b/net-analyzer/netperf/files/netperf-2.7.0-includes.patch
@@ -0,0 +1,22 @@
+--- a/src/net_uuid.c
++++ b/src/net_uuid.c
+@@ -28,6 +28,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <fcntl.h>
++#include <unistd.h> /* read(), close() */
+
+ #if defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+--- a/src/netlib.c
++++ b/src/netlib.c
+@@ -81,6 +81,9 @@
+ #include <endian.h>
+ #endif
+
++#if defined(HAVE_SENDFILE)
++#include <sys/sendfile.h> /* sendfile() */
++#endif
+
+ #ifndef WIN32
+ /* at some point, I would like to get rid of all these "sys/"
diff --git a/net-analyzer/netperf/netperf-2.7.0.ebuild b/net-analyzer/netperf/netperf-2.7.0.ebuild
new file mode 100644
index 000000000000..004c306b402f
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.7.0.ebuild,v 1.1 2015/07/25 08:26:32 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more"
+SRC_URI="ftp://ftp.netperf.org/${PN}/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+HOMEPAGE="http://www.netperf.org/"
+LICENSE="netperf"
+SLOT="0"
+IUSE="demo sctp"
+
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-fix-scripts.patch \
+ "${FILESDIR}"/${PN}-2.6.0-log-dir.patch \
+ "${FILESDIR}"/${PN}-2.7.0-includes.patch
+
+ # Fixing paths in scripts
+ sed -i \
+ -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
+ doc/examples/sctp_stream_script \
+ doc/examples/tcp_range_script \
+ doc/examples/tcp_rr_script \
+ doc/examples/tcp_stream_script \
+ doc/examples/udp_rr_script \
+ doc/examples/udp_stream_script \
+ || die
+
+ # netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
+ # nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
+ append-cppflags -D_GNU_SOURCE
+}
+
+src_configure() {
+ econf \
+ $(use_enable demo) \
+ $(use_enable sctp)
+}
+
+src_install () {
+ default
+
+ # move netserver into sbin as we had it before 2.4 was released with its
+ # autoconf goodness
+ dodir /usr/sbin
+ mv "${D}"/usr/{bin,sbin}/netserver || die
+
+ # init.d / conf.d
+ newinitd "${FILESDIR}"/${PN}-2.2-init netperf
+ newconfd "${FILESDIR}"/${PN}-2.2-conf netperf
+
+ # documentation and example scripts
+ dodoc AUTHORS ChangeLog NEWS README Release_Notes
+ dodir /usr/share/doc/${PF}/examples
+ #Scripts no longer get installed by einstall
+ cp doc/examples/*_script "${D}"/usr/share/doc/${PF}/examples || die
+}