summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-09-28 14:51:11 +0000
committerJeroen Roovers <jer@gentoo.org>2013-09-28 14:51:11 +0000
commitccd4aa7d68ff0fcca4e1a5d931ac9802e47f254a (patch)
tree8fc7c9af0d28fcf60706f735737edfde0a4fb3d0 /net-analyzer
parentStable for HPPA (bug #480038). (diff)
downloadgentoo-2-ccd4aa7d68ff0fcca4e1a5d931ac9802e47f254a.tar.gz
gentoo-2-ccd4aa7d68ff0fcca4e1a5d931ac9802e47f254a.tar.bz2
gentoo-2-ccd4aa7d68ff0fcca4e1a5d931ac9802e47f254a.zip
Version bump by mike (bug #483308).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pypacker/ChangeLog7
-rw-r--r--net-analyzer/pypacker/pypacker-2.4.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/net-analyzer/pypacker/ChangeLog b/net-analyzer/pypacker/ChangeLog
index c16d61b49f8c..48b14671efbe 100644
--- a/net-analyzer/pypacker/ChangeLog
+++ b/net-analyzer/pypacker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pypacker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pypacker/ChangeLog,v 1.2 2013/09/05 18:58:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pypacker/ChangeLog,v 1.3 2013/09/28 14:51:11 jer Exp $
+
+*pypacker-2.4 (28 Sep 2013)
+
+ 28 Sep 2013; Jeroen Roovers <jer@gentoo.org> +pypacker-2.4.ebuild:
+ Version bump by mike (bug #483308).
05 Sep 2013; Michał Górny <mgorny@gentoo.org> pypacker-2.0.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/net-analyzer/pypacker/pypacker-2.4.ebuild b/net-analyzer/pypacker/pypacker-2.4.ebuild
new file mode 100644
index 000000000000..4a86e06d8a91
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pypacker/pypacker-2.4.ebuild,v 1.1 2013/09/28 14:51:11 jer Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://github.com/mike01/pypacker"
+SRC_URI="https://github.com/mike01/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}