summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-11-03 20:50:07 +0000
committerRick Farina <zerochaos@gentoo.org>2014-11-03 20:50:07 +0000
commitc637ffbde9a565ebf14486da75cb553150b1ad2f (patch)
tree735ae4fe5a41c6630b425b55a37ac41c1a95b0e3 /net-analyzer
parentDarwin: make sure we build with GCC by default instead of Clang, bug #528076 (diff)
downloadgentoo-2-c637ffbde9a565ebf14486da75cb553150b1ad2f.tar.gz
gentoo-2-c637ffbde9a565ebf14486da75cb553150b1ad2f.tar.bz2
gentoo-2-c637ffbde9a565ebf14486da75cb553150b1ad2f.zip
various fixes for building docs and making the ebuild maintenance easier
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ChangeLog6
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild9
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild36
3 files changed, 33 insertions, 18 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index a60db55c0edd..fc822d6b178a 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.154 2014/11/02 03:46:45 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.155 2014/11/03 20:50:07 zerochaos Exp $
+
+ 03 Nov 2014; Rick Farina <zerochaos@gentoo.org> ettercap-0.8.1-r1.ebuild,
+ ettercap-9999.ebuild:
+ various fixes for building docs and making the ebuild maintenance easier
02 Nov 2014; Rick Farina <zerochaos@gentoo.org> ettercap-0.8.1-r1.ebuild:
adding misc maintainer note to ebuild, super bad form but otherwise it will be
diff --git a/net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild b/net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild
index 4bc040f89591..c693368d11d7 100644
--- a/net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild,v 1.2 2014/11/02 03:46:45 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.8.1-r1.ebuild,v 1.3 2014/11/03 20:50:07 zerochaos Exp $
EAPI=5
@@ -15,7 +15,6 @@ SRC_URI="https://github.com/Ettercap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~sparc ~x86 ~x86-fbsd"
-#IUSE="doc gtk ipv6 ncurses +plugins test"
IUSE="gtk ipv6 ncurses +plugins"
RDEPEND="dev-libs/libbsd
@@ -42,8 +41,6 @@ RDEPEND="dev-libs/libbsd
DEPEND="${RDEPEND}
sys-devel/flex
virtual/yacc"
- #doc? ( app-text/ghostscript-gpl
- # sys-apps/groff )
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -62,10 +59,6 @@ src_configure() {
#right now we only support gtk2, but ettercap also supports gtk3
#do we care? do we want to support both?
- #we can build the pdf docs, but they don't actually get installed
- #plus, does anyone need this at all???
- #$(cmake-utils_use_enable doc PDF_DOCS)
-
#we want to enable testing but it fails right now
#we want to disable the bundled crap, but we are missing at least "libcheck"
#if we want to enable tests, we need to fix it, and either package libcheck or allow bundled version
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
index 0fc7f9b3d013..1d4df93d3ea0 100644
--- a/net-analyzer/ettercap/ettercap-9999.ebuild
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -1,24 +1,32 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-9999.ebuild,v 1.7 2014/02/23 11:57:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-9999.ebuild,v 1.8 2014/11/03 20:50:07 zerochaos Exp $
EAPI=5
CMAKE_MIN_VERSION=2.8
-inherit cmake-utils git-2
+inherit cmake-utils
DESCRIPTION="A suite for man in the middle attacks"
-HOMEPAGE="http://ettercap.sourceforge.net https://github.com/Ettercap/ettercap"
-EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
+HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
-IUSE="gtk ipv6 ncurses +plugins"
-RDEPEND="dev-libs/openssl
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
+else
+ SRC_URI="https://github.com/Ettercap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" #mirror does not work
+ KEYWORDS="~alpha ~amd64 ~arm ~sparc ~x86 ~x86-fbsd"
+fi
+#IUSE="doc gtk ipv6 ncurses +plugins test"
+IUSE="doc gtk ipv6 ncurses +plugins"
+
+RDEPEND="dev-libs/libbsd
dev-libs/libpcre
+ dev-libs/openssl
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
@@ -38,7 +46,8 @@ RDEPEND="dev-libs/openssl
)"
DEPEND="${RDEPEND}
- app-text/ghostscript-gpl
+ doc? ( app-text/ghostscript-gpl
+ sys-apps/groff )
sys-devel/flex
virtual/yacc"
@@ -52,8 +61,17 @@ src_configure() {
$(cmake-utils_use_enable gtk)
$(cmake-utils_use_enable plugins)
$(cmake-utils_use_enable ipv6)
- -DENABLE_SSL=ON
+ $(cmake-utils_use_enable doc PDF_DOCS)
+ -DBUNDLED_LIBS=OFF
+ -DSYSTEM_LIBS=ON
-DINSTALL_SYSCONFDIR="${EROOT}"etc
)
+ #right now we only support gtk2, but ettercap also supports gtk3
+ #do we care? do we want to support both?
+
+ #we want to enable testing but it fails right now
+ #we want to disable the bundled crap, but we are missing at least "libcheck"
+ #if we want to enable tests, we need to fix it, and either package libcheck or allow bundled version
+ #$(cmake-utils_use_enable test TESTS)
cmake-utils_src_configure
}