summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-01-15 05:02:55 +0000
committerJeroen Roovers <jer@gentoo.org>2009-01-15 05:02:55 +0000
commit72ae1d555926bd66a18b500f568863b9b6f6e670 (patch)
treebf9e119466640d36f410c8fb2034a8819f0320fc /net-analyzer
parentRe-add my <description> tag for metadata.xml, because it's a full description... (diff)
downloadgentoo-2-72ae1d555926bd66a18b500f568863b9b6f6e670.tar.gz
gentoo-2-72ae1d555926bd66a18b500f568863b9b6f6e670.tar.bz2
gentoo-2-72ae1d555926bd66a18b500f568863b9b6f6e670.zip
New toolchain patch. New strip patch (bug #251974). Unify patches. Clean up ebuild.
(Portage version: 2.2_rc22/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cnet/ChangeLog9
-rw-r--r--net-analyzer/cnet/cnet-2.0.10.ebuild16
-rw-r--r--net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch94
3 files changed, 38 insertions, 81 deletions
diff --git a/net-analyzer/cnet/ChangeLog b/net-analyzer/cnet/ChangeLog
index 0fc8ce54249c..62984c63ca3c 100644
--- a/net-analyzer/cnet/ChangeLog
+++ b/net-analyzer/cnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cnet
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/ChangeLog,v 1.15 2007/06/02 22:42:58 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/ChangeLog,v 1.16 2009/01/15 05:02:55 jer Exp $
+
+ 15 Jan 2009; Jeroen Roovers <jer@gentoo.org>
+ files/cnet-2.0.10-gentoo.patch, cnet-2.0.10.ebuild:
+ New toolchain patch. New strip patch (bug #251974). Unify patches. Clean
+ up ebuild.
02 Jun 2007; Markus Ullmann <jokey@gentoo.org>
-files/cnet-2.0.5-gentoo.patch, -files/cnet-2.0.9-gentoo.patch,
diff --git a/net-analyzer/cnet/cnet-2.0.10.ebuild b/net-analyzer/cnet/cnet-2.0.10.ebuild
index 4ec38067ad37..2f799a64feb6 100644
--- a/net-analyzer/cnet/cnet-2.0.10.ebuild
+++ b/net-analyzer/cnet/cnet-2.0.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-2.0.10.ebuild,v 1.3 2007/04/07 04:21:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-2.0.10.ebuild,v 1.4 2009/01/15 05:02:55 jer Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Network simulation tool"
SRC_URI="http://www.csse.uwa.edu.au/cnet/${P}.tgz"
@@ -16,15 +16,15 @@ IUSE=""
DEPEND=">=dev-lang/tk-8.3.4
dev-libs/elfutils"
-#RDEPEND=""
-
-# unpacking the source
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
- epatch "${FILESDIR}"/${PN}-2.0.10-gentoo.patch
- sed -i.orig -e "s/^CFLAGS.*/CFLAGS=${CFLAGS}/" "${S}"/src/Makefile.linux
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" || die "make failed"
}
src_install() {
diff --git a/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch b/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch
index 24c4a51a9731..ec35e0cc221d 100644
--- a/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch
+++ b/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch
@@ -1,6 +1,5 @@
-diff --exclude='*~' -Naur cnet-2.0.10.orig/Makefile cnet-2.0.10/Makefile
---- cnet-2.0.10.orig/Makefile 2006-04-20 21:54:40.000000000 -0300
-+++ cnet-2.0.10/Makefile 2006-04-20 21:54:54.000000000 -0300
+--- cnet-2.0.10/Makefile.orig 2006-03-06 20:03:14.000000000 +0100
++++ cnet-2.0.10/Makefile 2009-01-15 05:51:23.000000000 +0100
@@ -7,14 +7,14 @@
# It is presumed that BINDIR and MANDIR exist, so you may need
# to create them, and set their permissions, if necessary.
@@ -20,77 +19,30 @@ diff --exclude='*~' -Naur cnet-2.0.10.orig/Makefile cnet-2.0.10/Makefile
# ---------------------------------------------------------------------
-diff --exclude='*~' -Naur cnet-2.0.10.orig/Makefile.orig cnet-2.0.10/Makefile.orig
---- cnet-2.0.10.orig/Makefile.orig 1969-12-31 21:00:00.000000000 -0300
-+++ cnet-2.0.10/Makefile.orig 2006-03-06 16:03:14.000000000 -0300
-@@ -0,0 +1,46 @@
-+NAME = cnet
-+VERSION = 2.0.10
-+SHELL = /bin/sh
-+#
-+# Change the following 5 constants to suit your local site.
-+#
-+# It is presumed that BINDIR and MANDIR exist, so you may need
-+# to create them, and set their permissions, if necessary.
-+#
-+PREFIX = /usr/local
-+#
-+BINDIR = $(PREFIX)/bin
-+CNETDIR = $(PREFIX)/cnetlib
-+MANDIR = $(PREFIX)/man/man1
-+MANEXT = 1
-+MANFILE = $(MANDIR)/$(NAME).$(MANEXT)
-+WEBDIR = /home/httpd/html/cnet
-+
-+# ---------------------------------------------------------------------
-+
-+it:
-+ (cd src && make)
-+
-+install:
-+ (cd src && make)
-+ cp $(NAME) $(BINDIR)/$(NAME) && chmod 755 $(BINDIR)/$(NAME)
-+ mkdir -p $(CNETDIR) && chmod 755 $(CNETDIR)
-+ cp cnetlib/* $(CNETDIR) && chmod 644 $(CNETDIR)/*
-+ cp DOC/$(NAME).man $(MANFILE) && chmod 644 $(MANFILE)
-+
-+web:
-+ mkdir -p $(WEBDIR) && chmod 755 $(WEBDIR)
-+ mkdir -p $(WEBDIR)/images && chmod 755 $(WEBDIR)/images
-+ cp DOC/*.* $(WEBDIR)
-+ cp DOC/images/* $(WEBDIR)/images
-+ chmod 644 $(WEBDIR)/*.* $(WEBDIR)/images/*
-+
-+# ---------------------------------------------------------------------
-+
-+clean:
-+ (cd src && make clean)
-+ (cd DOC && make clean)
-+ (cd EXAMPLES && make clean)
-+
-+uninstall:
-+ rm -rf $(BINDIR)/$(NAME) $(MANFILE) $(CNETDIR) $(WEBDIR)
-diff --exclude='*~' -Naur cnet-2.0.10.orig/src/config.h cnet-2.0.10/src/config.h
---- cnet-2.0.10.orig/src/config.h 2006-04-20 21:54:40.000000000 -0300
-+++ cnet-2.0.10/src/config.h 2006-04-20 21:54:55.000000000 -0300
-@@ -169,7 +169,7 @@
- #if defined(USE_FREEBSD)
- #define CNETPATH "/usr/local/share/cnet:/usr/local/include:/usr/local/cnetlib"
- #else
--#define CNETPATH "/usr/local/cnetlib:/usr/lib/cnet:/cslinux/cnetlib"
-+#define CNETPATH "/usr/lib/cnetlib:/usr/lib/cnet:"
- #endif
+--- cnet-2.0.10/src/Makefile.common.orig 2004-05-10 21:26:53.000000000 +0200
++++ cnet-2.0.10/src/Makefile.common 2009-01-15 05:51:23.000000000 +0100
+@@ -18,7 +18,6 @@
+ $(NAME): $(OBJ)
+ $(LD) $(LDFLAGS) -o $(NAME) $(OBJ) $(LIBDIRS) $(XLIBS) $(LIBS)
+- @$(STRIP) $(NAME)
+ @chmod 755 $(NAME)
-diff --exclude='*~' -Naur cnet-2.0.10.orig/src/Makefile.linux cnet-2.0.10/src/Makefile.linux
---- cnet-2.0.10.orig/src/Makefile.linux 2006-04-20 21:54:40.000000000 -0300
-+++ cnet-2.0.10/src/Makefile.linux 2006-04-20 21:54:55.000000000 -0300
-@@ -29,7 +29,7 @@
- ANSICC = gcc -ansi
+
+--- cnet-2.0.10/src/Makefile.linux.orig 2004-05-10 21:27:19.000000000 +0200
++++ cnet-2.0.10/src/Makefile.linux 2009-01-15 05:51:23.000000000 +0100
+@@ -26,12 +26,10 @@
+
+ # Cannot use the -pedantic option if requiring 'long long' syntax.
+ #ANSICC = gcc -ansi -pedantic
+-ANSICC = gcc -ansi
++ANSICC = $(CC) -ansi
INCLUDES = $(LIBELFINC)
-CFLAGS = -O -Wall -fPIC $(INCLUDES) $(XINCLUDES)
-+CFLAGS = -march=pentium3 -O3 -pipe -fPIC $(INCLUDES) $(XINCLUDES)
-
- LD = gcc -rdynamic
+-
+-LD = gcc -rdynamic
++LD = $(CC) -rdynamic
LIBDIRS = -L/usr/X11R6/lib $(XLIBDIRS) $(LIBELFDIR)
+ LIBS = -lelf -ldl -lm
+ STRIP = strip