summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-06-22 14:53:45 +0000
committerMichael Orlitzky <mjo@gentoo.org>2015-06-22 14:53:45 +0000
commit28f6d0ee208a09548b44eeebc7321ba8855b24a5 (patch)
treefd138965793f94036a7552a64aa8c225485458e9 /net-analyzer
parentNon-maintainer commit: Drop depend.php in favor of an explicit dep which does... (diff)
downloadgentoo-2-28f6d0ee208a09548b44eeebc7321ba8855b24a5.tar.gz
gentoo-2-28f6d0ee208a09548b44eeebc7321ba8855b24a5.tar.bz2
gentoo-2-28f6d0ee208a09548b44eeebc7321ba8855b24a5.zip
Version bump fixing bug #541128 in the process. Add myself as a maintainer.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-check_mysql_health/ChangeLog10
-rw-r--r--net-analyzer/nagios-check_mysql_health/metadata.xml10
-rw-r--r--net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.1.9.2.ebuild42
3 files changed, 59 insertions, 3 deletions
diff --git a/net-analyzer/nagios-check_mysql_health/ChangeLog b/net-analyzer/nagios-check_mysql_health/ChangeLog
index 6472d7f77cfc..e6151599d7d0 100644
--- a/net-analyzer/nagios-check_mysql_health/ChangeLog
+++ b/net-analyzer/nagios-check_mysql_health/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios-check_mysql_health
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_mysql_health/ChangeLog,v 1.9 2014/01/26 02:59:42 creffett Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_mysql_health/ChangeLog,v 1.10 2015/06/22 14:53:45 mjo Exp $
+
+*nagios-check_mysql_health-2.1.9.2 (22 Jun 2015)
+
+ 22 Jun 2015; Michael Orlitzky <mjo@gentoo.org>
+ +nagios-check_mysql_health-2.1.9.2.ebuild, metadata.xml:
+ Version bump fixing bug #541128 in the process. Add myself as a maintainer.
26 Jan 2014; Chris Reffett <creffett@gentoo.org>
-nagios-check_mysql_health-2.1.5.ebuild,
diff --git a/net-analyzer/nagios-check_mysql_health/metadata.xml b/net-analyzer/nagios-check_mysql_health/metadata.xml
index a77e7e5189e7..b38d16492bd3 100644
--- a/net-analyzer/nagios-check_mysql_health/metadata.xml
+++ b/net-analyzer/nagios-check_mysql_health/metadata.xml
@@ -1,15 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+
<maintainer>
<email>andrew@ahamilto.net</email>
<name>Andrew Hamilton</name>
<description>Maintainer. Assign bugs to him.</description>
</maintainer>
+
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ <description>Secondary maintainer. CC him on bugs.</description>
+ </maintainer>
+
<maintainer>
<email>sdamashek@gentoo.org</email>
<name>Samuel Damashek</name>
<description>Proxy maintainer. CC him on bugs.</description>
</maintainer>
- <herd>proxy-maintainers</herd>
</pkgmetadata>
diff --git a/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.1.9.2.ebuild b/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.1.9.2.ebuild
new file mode 100644
index 000000000000..7b28cbad430b
--- /dev/null
+++ b/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.1.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.1.9.2.ebuild,v 1.1 2015/06/22 14:53:45 mjo Exp $
+
+EAPI=5
+
+inherit multilib
+
+MY_PN="${PN#nagios-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A nagios plugin for checking MySQL server health"
+HOMEPAGE="https://labs.consol.de/nagios/${MY_PN}/"
+SRC_URI="https://labs.consol.de/assets/downloads/nagios/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Found by grepping for "use " in the built
+# plugins-scripts/check_mysql_health.
+RDEPEND="dev-perl/DBD-mysql
+ dev-perl/DBI
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-Net-Ping
+ virtual/perl-Time-HiRes"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure(){
+ # Should match net-analyzer/{monitoring,nagios}-plugins.
+ econf --libexecdir="/usr/$(get_libdir)/nagios/plugins"
+}
+
+# Here we should have a pkg_preinst() that creates the nagios user/group
+# (using the same command from e.g. net-analyzer/nagios-plugins). But
+# right now, the build system for check_mysql_health has a bug: it
+# doesn't use the configured user (INSTALL_OPTIONS aren't passed to
+# /usr/bin/install), so it's pointless. Don't forget to inherit
+# user.eclass!