summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-12-08 07:30:18 +0000
committerJeroen Roovers <jer@gentoo.org>2009-12-08 07:30:18 +0000
commit2345788ec4cd7262a8f0b1fd3fbdf3b07b10140e (patch)
tree77f4d94eb48d122b089c7f9cf12d1c28010c38fc /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-2345788ec4cd7262a8f0b1fd3fbdf3b07b10140e.tar.gz
gentoo-2-2345788ec4cd7262a8f0b1fd3fbdf3b07b10140e.tar.bz2
gentoo-2-2345788ec4cd7262a8f0b1fd3fbdf3b07b10140e.zip
Version bump.
(Portage version: 2.2_rc56/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog8
-rw-r--r--net-analyzer/nmap/files/nmap-5.10_beta1-string.patch11
-rw-r--r--net-analyzer/nmap/nmap-5.10_beta1.ebuild53
3 files changed, 71 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index ac70c6e6b5f4..58eabaea880e 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.209 2009/12/07 23:02:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.210 2009/12/08 07:30:18 jer Exp $
+
+*nmap-5.10_beta1 (08 Dec 2009)
+
+ 08 Dec 2009; Jeroen Roovers <jer@gentoo.org> +nmap-5.10_beta1.ebuild,
+ +files/nmap-5.10_beta1-string.patch:
+ Version bump.
07 Dec 2009; Markus Meier <maekke@gentoo.org> nmap-5.00-r2.ebuild:
arm stable, bug #295134
diff --git a/net-analyzer/nmap/files/nmap-5.10_beta1-string.patch b/net-analyzer/nmap/files/nmap-5.10_beta1-string.patch
new file mode 100644
index 000000000000..df29db3782d5
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-5.10_beta1-string.patch
@@ -0,0 +1,11 @@
+--- nmap-5.10BETA1/Target.h.org 2009-12-08 08:21:59.000000000 +0100
++++ nmap-5.10BETA1/Target.h 2009-12-08 08:22:02.000000000 +0100
+@@ -99,6 +99,8 @@
+
+ #ifndef NOLUA
+ #include "nse_main.h"
++#else
++#include <string>
+ #endif
+
+ #include "portreasons.h"
diff --git a/net-analyzer/nmap/nmap-5.10_beta1.ebuild b/net-analyzer/nmap/nmap-5.10_beta1.ebuild
new file mode 100644
index 000000000000..5404171274d9
--- /dev/null
+++ b/net-analyzer/nmap/nmap-5.10_beta1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.10_beta1.ebuild,v 1.1 2009/12/08 07:30:18 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5[sqlite]
+ >=dev-python/pysqlite-2 )
+ )
+ lua? ( >=dev-lang/lua-5.1.4-r1[deprecated] )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.75-include.patch"
+ epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
+ epatch "${FILESDIR}/${P}-string.patch"
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with lua liblua) \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}