summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-12-10 04:02:28 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-12-10 04:02:28 +0000
commit124226f329c60ba761ef2cb87c5f46f9a6259730 (patch)
treeec51c9d463d33a04c624f64da4d9f4be1d09dc8f /net-analyzer
parentAdd py3.4 support (diff)
downloadgentoo-2-124226f329c60ba761ef2cb87c5f46f9a6259730.tar.gz
gentoo-2-124226f329c60ba761ef2cb87c5f46f9a6259730.tar.bz2
gentoo-2-124226f329c60ba761ef2cb87c5f46f9a6259730.zip
fixing the usage of postgres and mysql
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/ChangeLog5
-rw-r--r--net-analyzer/icinga2/icinga2-2.2.1.ebuild20
2 files changed, 23 insertions, 2 deletions
diff --git a/net-analyzer/icinga2/ChangeLog b/net-analyzer/icinga2/ChangeLog
index cc2ff19e68f0..a9a97ea1848f 100644
--- a/net-analyzer/icinga2/ChangeLog
+++ b/net-analyzer/icinga2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/icinga2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.12 2014/12/09 15:29:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.13 2014/12/10 04:02:28 prometheanfire Exp $
+
+ 10 Dec 2014; Matthew Thode <prometheanfire@gentoo.org> icinga2-2.2.1.ebuild:
+ fixing the usage of postgres and mysql
09 Dec 2014; Matthew Thode <prometheanfire@gentoo.org> icinga2-2.2.1.ebuild:
fixing the group ownership stuff
diff --git a/net-analyzer/icinga2/icinga2-2.2.1.ebuild b/net-analyzer/icinga2/icinga2-2.2.1.ebuild
index fb400e37386b..b0f7c62a0df9 100644
--- a/net-analyzer/icinga2/icinga2-2.2.1.ebuild
+++ b/net-analyzer/icinga2/icinga2-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.2.1.ebuild,v 1.2 2014/12/09 15:29:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.2.1.ebuild,v 1.3 2014/12/10 04:02:28 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -60,6 +60,24 @@ src_configure() {
-DICINGA2_COMMAND_GROUP=icingacmd
-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
)
+ if use postgres; then
+ mycmakeargs+=(
+ -DICINGA2_WITH_PGSQL=ON
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_WITH_PGSQL=OFF
+ )
+ fi
+ if use mysql; then
+ mycmakeargs+=(
+ -DICINGA2_WITH_MYSQL=ON
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_WITH_MYSQL=OFF
+ )
+ fi
cmake-utils_src_configure
}