summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-21 06:16:01 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-21 06:16:01 +0000
commitf781b308d6a263d76cf45259c59f2bc875360e09 (patch)
treee28fbbb32122b5b8780c458931ef60bb766e639f /net-analyzer/softflowd
parentppc/ppc64/x86 stable wrt #406035 (diff)
downloadgentoo-2-f781b308d6a263d76cf45259c59f2bc875360e09.tar.gz
gentoo-2-f781b308d6a263d76cf45259c59f2bc875360e09.tar.bz2
gentoo-2-f781b308d6a263d76cf45259c59f2bc875360e09.zip
Version bump.
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/softflowd')
-rw-r--r--net-analyzer/softflowd/ChangeLog10
-rw-r--r--net-analyzer/softflowd/files/softflowd-0.9.9-no-strip.patch12
-rw-r--r--net-analyzer/softflowd/softflowd-0.9.9.ebuild33
3 files changed, 53 insertions, 2 deletions
diff --git a/net-analyzer/softflowd/ChangeLog b/net-analyzer/softflowd/ChangeLog
index 6b0dfcf9722e..24a6d131f275 100644
--- a/net-analyzer/softflowd/ChangeLog
+++ b/net-analyzer/softflowd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/softflowd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/softflowd/ChangeLog,v 1.1 2011/10/12 19:57:02 vadimk Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/softflowd/ChangeLog,v 1.2 2012/03/21 06:16:01 radhermit Exp $
+
+*softflowd-0.9.9 (21 Mar 2012)
+
+ 21 Mar 2012; Tim Harder <radhermit@gentoo.org> +softflowd-0.9.9.ebuild,
+ +files/softflowd-0.9.9-no-strip.patch:
+ Version bump.
*softflowd-0.9.8 (12 Oct 2011)
diff --git a/net-analyzer/softflowd/files/softflowd-0.9.9-no-strip.patch b/net-analyzer/softflowd/files/softflowd-0.9.9-no-strip.patch
new file mode 100644
index 000000000000..75588112355a
--- /dev/null
+++ b/net-analyzer/softflowd/files/softflowd-0.9.9-no-strip.patch
@@ -0,0 +1,12 @@
+--- softflowd-0.9.9/Makefile.in
++++ softflowd-0.9.9/Makefile.in
+@@ -52,7 +52,7 @@
+ $(srcdir)/mkinstalldirs $(DESTDIR)$(sbindir)
+ [ -d $(DESTDIR)$(mandir)/man8 ] || \
+ $(srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man8
+- $(INSTALL) -m 0755 -s softflowd $(DESTDIR)$(sbindir)/softflowd
+- $(INSTALL) -m 0755 -s softflowctl $(DESTDIR)$(sbindir)/softflowctl
++ $(INSTALL) -m 0755 softflowd $(DESTDIR)$(sbindir)/softflowd
++ $(INSTALL) -m 0755 softflowctl $(DESTDIR)$(sbindir)/softflowctl
+ $(INSTALL) -m 0644 softflowd.8 $(DESTDIR)$(mandir)/man8/softflowd.8
+ $(INSTALL) -m 0644 softflowctl.8 $(DESTDIR)$(mandir)/man8/softflowctl.8
diff --git a/net-analyzer/softflowd/softflowd-0.9.9.ebuild b/net-analyzer/softflowd/softflowd-0.9.9.ebuild
new file mode 100644
index 000000000000..9ce6131afdf1
--- /dev/null
+++ b/net-analyzer/softflowd/softflowd-0.9.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/softflowd/softflowd-0.9.9.ebuild,v 1.1 2012/03/21 06:16:00 radhermit Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A flow-based network monitor."
+HOMEPAGE="http://www.mindrot.org/softflowd.html"
+SRC_URI="http://softflowd.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-strip.patch
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc collector.pl
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}