summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-01-25 12:58:58 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-01-25 12:58:58 +0000
commit967caf053df2f64216daf2bb17f6a50246fdeb8e (patch)
tree8c2cba0af17e8ffe75833997d5d30a089e2958e8 /net-analyzer/snortsam/snortsam-2.29.ebuild
parent Don't break the description line by overriding it in the eclass. (diff)
downloadgentoo-2-967caf053df2f64216daf2bb17f6a50246fdeb8e.tar.gz
gentoo-2-967caf053df2f64216daf2bb17f6a50246fdeb8e.tar.bz2
gentoo-2-967caf053df2f64216daf2bb17f6a50246fdeb8e.zip
Version bump for bug 78252.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-analyzer/snortsam/snortsam-2.29.ebuild')
-rw-r--r--net-analyzer/snortsam/snortsam-2.29.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.29.ebuild b/net-analyzer/snortsam/snortsam-2.29.ebuild
new file mode 100644
index 000000000000..74a9c6628ed9
--- /dev/null
+++ b/net-analyzer/snortsam/snortsam-2.29.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/snortsam-2.29.ebuild,v 1.1 2005/01/25 12:58:58 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
+HOMEPAGE="http://www.snortsam.net/"
+SRC_URI="http://www.snortsam.net/files/snortsam-v2_multi-threaded/${PN}-src-${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-no-ugly----lines.diff
+}
+
+src_compile() {
+ sed -i "s: -O2 : ${CFLAGS} :" makesnortsam.sh || die "sed failed"
+ ./makesnortsam.sh || die "makesnortsam.sh failed"
+}
+
+src_install() {
+ find ${S} -type f -name "*.asc" -exec rm -f {} \;
+ dobin snortsam || die "dobin failed"
+ dodoc docs/* conf/*
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
+ einfo "Read the INSTALL file to configure snort for snortsam, and configure"
+ einfo "snortsam for your particular firewall."
+ echo
+}
+
+