summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-01 02:15:03 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-01 02:15:03 +0000
commit3dcfb8d4dbcdbb5f41aefbb0b8c15a9c1b3de644 (patch)
tree35ecac98b2cd8773c756bc314119ce3d5f28855b /net-analyzer/scli/scli-0.4.0.ebuild
parentInitial commit (for net-analyzer/scli-0.4). (diff)
downloadgentoo-2-3dcfb8d4dbcdbb5f41aefbb0b8c15a9c1b3de644.tar.gz
gentoo-2-3dcfb8d4dbcdbb5f41aefbb0b8c15a9c1b3de644.tar.bz2
gentoo-2-3dcfb8d4dbcdbb5f41aefbb0b8c15a9c1b3de644.zip
Version bump.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/scli/scli-0.4.0.ebuild')
-rw-r--r--net-analyzer/scli/scli-0.4.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/scli/scli-0.4.0.ebuild b/net-analyzer/scli/scli-0.4.0.ebuild
new file mode 100644
index 000000000000..c0136974e65f
--- /dev/null
+++ b/net-analyzer/scli/scli-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scli/scli-0.4.0.ebuild,v 1.1 2011/06/01 02:15:03 jer Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+
+DESCRIPTION="SNMP Command Line Interface"
+HOMEPAGE="http://www.ibr.cs.tu-bs.de/projects/scli/"
+SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/gnet
+ net-libs/gsnmp
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+ debug? ( dev-libs/dmalloc )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-flags -I/usr/include/libxml2
+ econf \
+ --enable-warnings \
+ $(use_enable debug dmalloc) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS NEWS TODO ChangeLog PORTING
+}