summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-06 00:33:40 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-06 00:33:40 +0000
commit586ad35fb9a3667e9fb8546da91f61b41c9cb7dc (patch)
tree18dec684498d77e7feeb3f73bc43db01a83ae090 /net-analyzer/rrdtool
parentmasked rrdtool new version for testing (diff)
downloadgentoo-2-586ad35fb9a3667e9fb8546da91f61b41c9cb7dc.tar.gz
gentoo-2-586ad35fb9a3667e9fb8546da91f61b41c9cb7dc.tar.bz2
gentoo-2-586ad35fb9a3667e9fb8546da91f61b41c9cb7dc.zip
version bump
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog10
-rw-r--r--net-analyzer/rrdtool/files/digest-rrdtool-1.0.391
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.39.ebuild112
3 files changed, 122 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 64b37a3dab75..ab0bcd36b1be 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.5 2002/06/11 01:01:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.6 2002/08/06 00:33:40 seemant Exp $
+
+*rrdtool-1.0.39 (05 Aug 2002)
+
+ 05 Aug 2002; Seemant Kulleen <seemant@gentoo.org> rrdtool-1.0.39.ebuild
+ files/digest-rrdtool-1.0.39 :
+
+ Version bump. Thanks to: tlund@springboardhosting.com (Tyler Lund) in bug
+ #5795.
*rrdtool-1.0.35-r3 (10 Jun 2002)
diff --git a/net-analyzer/rrdtool/files/digest-rrdtool-1.0.39 b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.39
new file mode 100644
index 000000000000..124d4f235415
--- /dev/null
+++ b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.39
@@ -0,0 +1 @@
+MD5 fcceaaf7ee7727d8d1bde53b0b5ab231 rrdtool-1.0.39.tar.gz 1147176
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.39.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.39.ebuild
new file mode 100644
index 000000000000..9f7b972b63af
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.0.39.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.39.ebuild,v 1.1 2002/08/06 00:33:40 seemant Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A system to store and display time-series data"
+SRC_URI="http://ee-staff.ethz.ch/~oetiker/webtools/rrdtool/pub/${P}.tar.gz"
+HOMEPAGE="http://ee-staff.ethz.ca/~oetiker/webtools/rrdtool/"
+
+DEPEND="perl? ( sys-devel/perl )
+ sys-apps/gawk
+ >=media-libs/libgd-1.8.3"
+
+RDEPEND="tcltk? ( dev-lang/tcl )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+TCLVER=""
+
+pkg_setup() {
+ use tcltk && \
+ TCLVER=`awk -F\' '/TCL_VERSION/ {print $2}' /usr/lib/tclConfig.sh`
+
+ use perl && ( \
+ perl-post_pkg_setup
+ )
+}
+
+src_compile() {
+
+ local myconf
+ use tcltk \
+ && myconf="${myconf} --with-tcllib=/usr/lib" \
+ || myconf="${myconf} --without-tcllib"
+
+ econf \
+ --datadir=/usr/share \
+ --enable-shared \
+ --with-perl-options='INSTALLMAN1DIR=/usr/share/man/man1 INSTALLMAN3DIR=/usr/share/man/man3' \
+ ${myconf} || die
+
+
+ make || die
+}
+
+src_install () {
+
+ einstall || die
+
+ # this package completely ignores mandir settings
+
+ doman doc/*.1
+ dohtml doc/*.html
+ dodoc doc/*.pod
+ dodoc doc/*.txt
+
+ rm -rf ${D}/usr/doc
+ rm -rf ${D}/usr/html
+ rm -rf ${D}/usr/man
+ a
+ rm -rf ${D}/usr/contrib
+ rm -rf ${D}/usr/examples
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*
+
+ use perl && ( \
+ perl_perlinfo
+ mytargets="site-perl-install"
+ perl-module_src_install || die
+ )
+
+ use tcltk && ( \
+ mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
+ insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
+ doins ${S}/tcl/tclrrd${PV}.so
+ echo "package ifneeded Rrd ${PV} [list load [file join \$$dir .. tclrrd${PV}.so]]" \
+ >> ${D}/usr/lib/tcl${TCL_VER}/tclrrd${PV}/pkgIndex.tcl
+ )
+
+ dodoc CHANGES COPY* CONTR* README TODO
+
+}
+
+
+pkg_preinst() {
+
+ use perl && perl-post_pkg_preinst
+}
+
+pkg_postinst() {
+
+ use perl && perl-post_pkg_postinst
+}
+
+
+pkg_prerm() {
+
+ use perl && perl-post_pkg_prerm
+}
+
+
+pkg_postrm() {
+
+ use perl && perl-post_pkg_postrm
+}