summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-21 22:43:34 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-21 22:43:34 +0000
commit2fffd8e319e5a598be3a81f0489bb48b2d46c05f (patch)
treea5b90d12e90f37fabffb1b24f9736f2bca7f472e /net-analyzer/rrdtool
parentVersion bump - added CAN-2004-0447 and CAN-2004-0565. (Manifest recommit) (diff)
downloadgentoo-2-2fffd8e319e5a598be3a81f0489bb48b2d46c05f.tar.gz
gentoo-2-2fffd8e319e5a598be3a81f0489bb48b2d46c05f.tar.bz2
gentoo-2-2fffd8e319e5a598be3a81f0489bb48b2d46c05f.zip
tidy; fixed 64-bit arch compile issue ; fixed rrdtool install - closes #57651
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog6
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.47.ebuild37
2 files changed, 20 insertions, 23 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 98d661861a81..e948a4719fa2 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.37 2004/07/08 23:29:32 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.38 2004/07/21 22:43:34 eldad Exp $
+
+ 22 Jul 2004; Eldad Zack <eldad@gentoo.org> rrdtool-1.0.47.ebuild:
+ Tidy up. Fixed issue with 64-bit archs, when perl is in USE. Fixed duplicate
+ installation on /usr/lib/perl. Closes #57651.
09 Jul 2004; Eldad Zack <eldad@gentoo.org> rrdtool-1.0.46.ebuild,
rrdtool-1.0.47.ebuild:
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.47.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.47.ebuild
index c1cc1f32c64b..5f6c411c6bec 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.47.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.47.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.47.ebuild,v 1.6 2004/07/14 22:33:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.47.ebuild,v 1.7 2004/07/21 22:43:34 eldad Exp $
inherit perl-module flag-o-matic gnuconfig eutils
@@ -41,34 +41,24 @@ src_compile() {
filter-flags -ffast-math
local myconf
+ myconf="${myconf} --datadir=/usr/share --enable-shared"
+
use tcltk \
&& myconf="${myconf} --with-tcllib=/usr/lib" \
|| myconf="${myconf} --without-tcllib"
- if use perl ; then
- MMSIXELEVEN=`perl -e 'use ExtUtils::MakeMaker; print( $ExtUtils::MakeMaker::VERSION ge "6.11" )'`
- if [ "${MMSIXELEVEN}" ]; then
- econf \
- --datadir=/usr/share \
- --enable-shared \
- --with-perl-options='INSTALLDIRS=vendor destdir=${D}/' \
- ${myconf} || die
-
- else
- econf \
- --datadir=/usr/share \
- --enable-shared \
- --with-perl-options='PREFIX=${D}/usr INSTALLDIRS=vendor' \
- ${myconf} || die
- fi
+ if use perl; then
+ econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
+
+ # libraries without -fPIC? feh!
+ for libdir in cgilib* gd* libpng* zlib*; do
+ sed -i -e 's/^CFLAGS.*/& -fPIC/' ${libdir}/Makefile
+ done
else
- econf \
- --datadir=/usr/share \
- --enable-shared \
- ${myconf} || die
+ econf ${myconf} || die "econf failed"
fi
- make || die
+ make || die "make failed"
}
src_install() {
@@ -96,6 +86,9 @@ src_install() {
perlinfo
mytargets="site-perl-install"
perl-module_src_install || die
+
+ # remove duplicate installation into /usr/lib/perl
+ rm -Rf ${D}/usr/lib/perl
fi
if use tcltk ; then