summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-01 12:07:33 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-01 12:07:33 +0000
commit90429e4a95fc1fc6e493e54653cf4a7231c5a0d5 (patch)
tree08c2517fc778df2707ab2a1a28675e1e95a65385 /net-analyzer/pmacct
parentFixed for Prefix, bug #499456 (diff)
downloadgentoo-2-90429e4a95fc1fc6e493e54653cf4a7231c5a0d5.tar.gz
gentoo-2-90429e4a95fc1fc6e493e54653cf4a7231c5a0d5.tar.bz2
gentoo-2-90429e4a95fc1fc6e493e54653cf4a7231c5a0d5.zip
Version bump. Clean up patch. Use /run not /var/run in init script.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog8
-rw-r--r--net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch4
-rw-r--r--net-analyzer/pmacct/files/pmacctd-init.d8
-rw-r--r--net-analyzer/pmacct/pmacct-1.5.0_rc2.ebuild70
4 files changed, 83 insertions, 7 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index ae8d0629f7b1..4591f9003866 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.91 2014/02/01 11:50:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.92 2014/02/01 12:07:33 jer Exp $
+
+*pmacct-1.5.0_rc2 (01 Feb 2014)
+
+ 01 Feb 2014; Jeroen Roovers <jer@gentoo.org> +pmacct-1.5.0_rc2.ebuild,
+ files/pmacct-0.12.0-gentoo.patch, files/pmacctd-init.d:
+ Version bump. Clean up patch. Use /run not /var/run in init script.
01 Feb 2014; Jeroen Roovers <jer@gentoo.org> -pmacct-0.14.2.ebuild,
pmacct-0.14.3.ebuild:
diff --git a/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch b/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch
index a367d98ceb6a..34efc1eda34d 100644
--- a/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch
+++ b/net-analyzer/pmacct/files/pmacct-0.12.0-gentoo.patch
@@ -1,5 +1,5 @@
---- configure.org 2010-02-16 13:06:04.000000000 +0100
-+++ configure 2010-02-25 22:57:08.000000000 +0100
+--- a/configure
++++ b/configure
@@ -1103,7 +1103,7 @@
echo $ac_n "checking whether to enable debugging compiler options""... $ac_c" 1>&6
echo "configure:1105: checking whether to enable debugging compiler options" >&5
diff --git a/net-analyzer/pmacct/files/pmacctd-init.d b/net-analyzer/pmacct/files/pmacctd-init.d
index 2de867d99fbd..87609ece0f6a 100644
--- a/net-analyzer/pmacct/files/pmacctd-init.d
+++ b/net-analyzer/pmacct/files/pmacctd-init.d
@@ -1,13 +1,13 @@
#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/files/pmacctd-init.d,v 1.7 2012/11/03 11:30:36 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/files/pmacctd-init.d,v 1.8 2014/02/01 12:07:33 jer Exp $
PMACCTDDIR=${PMACCTDDIR:-/etc/pmacctd}
if [ ${SVCNAME} != "pmacctd" ]; then
- PMACCTDPID="/var/run/${SVCNAME}.pid"
+ PMACCTDPID="/run/${SVCNAME}.pid"
else
- PMACCTDPID="/var/run/pmacctd.pid"
+ PMACCTDPID="/run/pmacctd.pid"
fi
PMACCTDCONF="${PMACCTDDIR}/${SVCNAME}.conf"
diff --git a/net-analyzer/pmacct/pmacct-1.5.0_rc2.ebuild b/net-analyzer/pmacct/pmacct-1.5.0_rc2.ebuild
new file mode 100644
index 000000000000..8550202b01a5
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-1.5.0_rc2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-1.5.0_rc2.ebuild,v 1.1 2014/02/01 12:07:33 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A network tool to gather IP traffic information"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="64bit debug geoip ipv6 mongodb mysql postgres sqlite threads ulog"
+
+DEPEND="
+ net-libs/libpcap
+ geoip? ( dev-libs/geoip )
+ mongodb? ( dev-libs/mongo-c-driver )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( =dev-db/sqlite-3* )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/_/}"
+
+DOCS=(
+ CONFIG-KEYS ChangeLog FAQS KNOWN-BUGS QUICKSTART README TODO TOOLS UPGRADE
+ docs/INTERNALS docs/PLUGINS docs/SIGNALS
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.12.0-gentoo.patch
+ sed -i \
+ -e '/[[:space:]]ar /s|ar |$(AR) |g' \
+ $(find . -name Makefile.in) || die
+}
+
+src_configure() {
+ tc-export CC AR RANLIB
+
+ econf \
+ $(use_enable 64bit) \
+ $(use_enable debug) \
+ $(use_enable geoip) \
+ $(use_enable ipv6) \
+ $(use_enable mongodb) \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable sqlite sqlite3) \
+ $(use_enable threads) \
+ $(use_enable ulog)
+}
+
+src_install() {
+ default
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc -r ${dirname}/*
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd
+
+ insinto /etc/pmacctd
+ newins examples/pmacctd-imt.conf.example pmacctd.conf
+}